Topic on Extension talk:LDAP Authentication

Jump to navigation Jump to search

LDAPAuthentication with Mediawiki 1.27.1

4
2620:0:1AF0:F100:A1E1:5564:C09B:29E (talkcontribs)

The configuration required to use LDAPAuthentication with Mediawiki 1.27.x must change. It caused us problem when combining LDAPAuthentication with the Translate extension, which uses the local user Fuzzybot. We had to change

$wgAuth = new LdapAuthenticationPlugin();

by

$wgAuthManagerAutoConfig['primaryauth'] += [

LdapPrimaryAuthenticationProvider::class => [

'class' => LdapPrimaryAuthenticationProvider::class,

'args' => [ [

'authoritative' => true, // don't allow local non-LDAP accounts

] ],

'sort' => 50, // must be smaller than local pw provider

],

];

This was taken from here:

https://gerrit.wikimedia.org/r/#/c/293086/4/wmf-config/wikitech.php

and was pointed to me by Anomie in this chat log:

http://bots.wmflabs.org/~wm-bot/logs/%23wikimedia-dev/20161122.txt

Lsilverman (talkcontribs)

Thank you very much for this. It solved my problem on 1.27.3 with LDAP.

Lsilverman (talkcontribs)

Hmm, correction. Translate started working, but auth no longer worked.

Jbrekelbaum (talkcontribs)

I am a mediawiki newbie. I have just installed 1.28 and LDAP auth is a requirement. Do you recommend that I downgrade to a previous version, or are you aware of an alternate plugin that would give us the same functionality. Thanks!

Reply to "LDAPAuthentication with Mediawiki 1.27.1"