Topic on Talk:VisualEditor

Jump to navigation Jump to search
217.12.16.56 (talkcontribs)
217.12.16.56 (talkcontribs)

I still have the trouble , you can see in the link, any help?, thansk.

Whatamidoing (WMF) (talkcontribs)

Are you running "matching" versions of MediaWiki, VisualEditor, and Parsoid? Your note on Stack Overflow said that you're running MediaWiki 1.26.2 but did not (AFAICS) mention the version numbers for the extensions.

217.12.16.56 (talkcontribs)
217.12.16.56 (talkcontribs)

I'm thinking I am not using the correct version of parsoid, nodejs and VisualEditor with work right all together with de mediawiki 1.27.0 version.

Any help?, thank you very much

217.12.16.56 (talkcontribs)

I would apreciate if any body can give me the links and the correct protocol to dwonload and install the correct version of parsoid, nodejs and VisualEditor for mediawiki 1.27.0, thanks in advanced.

Whatamidoing (WMF) (talkcontribs)

I don't know how to install the software myself. If we're lucky, someone else will be able to help us.

Whatamidoing (WMF) (talkcontribs)
217.12.16.56 (talkcontribs)
217.12.16.56 (talkcontribs)

I'm afraid this wiki documentation or wiki does not show the correct protocol to install the visual editor, I've spent a lot of time trying without result, I'm thinking about change the product for a wiki, does not give me the correspondent support or help.

the documentation of this wiki is so rolled that is imposible to configure this extension, is not clear at all, apart of that I think there woul be a wiki page describing the complete protocol to install the 3 products , nodejs with the correct version of each SO, the correct version of parsoid for each SO and nodejs and mediawiki, and finally the correct version os visual Editor Extension.

Whatamidoing (WMF) (talkcontribs)

I'm sorry that it's so frustrating. As I said, I don't know how to do it myself. The WMF can't provide support to other people's wikis. Perhaps it'd be possible to find a consultant, or advice from a user group?

201.230.117.133 (talkcontribs)

What we need is a step by step install Wiki+VisualEditor/Parsoid for CentOS7 and Ubuntu. I am too spending a LOT of time trying to get it to work.

Nowhere does it say how and where to download the appropriate versions of MediaWiki/Parsoid (how is the pairing working, any list of versions that work?)

Whatamidoing (WMF) (talkcontribs)

If you figure it out, then please feel free to start a doc page here.

I've heard that the versions of MediaWiki, VisualEditor, and Parsoid must all match (so if you do 1.27 for one, then you have to do 1.27 for all three of them).

Richbodo2 (talkcontribs)

I realize this is an ancient thread, but FWIW, having just installed mediawiki (about an hour including server setup, config, security, etc.) and parsoid (about a week and still slews of errors), for the record it's still non-trivial and I think anyone who can offer consulting services to people trying to set this up would make a mint.


Could be wrong, but it seems that in it's current state, Parsoid/VisualEditor setup really changes the equation as to which wiki people will use drastically and unexpectedly.

Reply to "Can't run VisualEditor y my wiki"