Topic on Project:Support desk

Jump to navigation Jump to search

MediaWiki 1.26.x on GoDaddy Win2008R2 Plesk VPS issues

4
Trunzoc (talkcontribs)

I've tried just about every possible combination of settings and can't seem to get the wiki to work correctly.

http://wiki.mywinkathome.net

This is from a brand new dump of 1.26.1 into an empty folder.
I have tried PHPs v5.3.29, 5.4.45, 5.5.30, & 5.6.16
MySQL v5.6.26

The version that comes bundled with Plesk, 1.23.13, installs fine. But updating it to anything else does what you see in the link above. The same behavior is displayed if I copy in any version of MediaWiki > 1.25

Can anyone offer any suggestions?

87.123.52.87 (talkcontribs)

First things first: If you are starting a new wiki, using version 1,26 instead of 1.23 is a good idea. For the PHP version, anything starting from PHP 5.3 is supported by MediaWiki. Given the choices you have, I would choose PHP 5.6.

Your wiki currently shows "LocalSettings.php not found. Please set up the wiki first."

This message is displayed, when the LocalSettings.php file is not at the place, where it should be.

If what you are doing currently is ''not'' a MediaWiki upgrade, but a new installation, then you should follow the link in that message and complete the setup of your wiki.

I just tried that and it brings up the web installer, but it is completely unstyled.

Reason for this is that you are encountering the following error:

Exception encountered, of type &quot;Less_Exception_Parser&quot;<br /> [97f55149] /mw-config/index.php?css=1   Less_Exception_Parser from line 447 of C:\Inetpub\vhosts\mywinkathome.net\wiki.mywinkathome.net\vendor\oyejorge\less.php\lib\Less\Parser.php: Less.php cache directory isn't writable: C:\Windows\TEMP<br />

I am not an expert in setting up Windows servers, but you have to configure a temporary directory, which is writable for the webserver. The folder C:\Windows\TEMP, which currently is configured as cache directory, obviously is not writable.

Trunzoc (talkcontribs)

Thanks for that. Where did you get that error log form?

I'll go make sure the web's user acct has access and try it again.

As far as not set up, I've been playing for a while so it keeps changing, but what I was getting at is the unstyled part which happens whether is't fully setup or not.

Thanks again for the tip!

Trunzoc (talkcontribs)

well crap. That was easy.

Thanks again anonymous friend!

(Still curious how you got the error log)