Topic on Template talk:Extension

Jump to navigation Jump to search

what should mediawiki parameter represent?

4
SPage (WMF) (talkcontribs)

Template parameters include

mediawiki
required version of MediaWiki

but is this the earliest version of MediaWiki for which there's a branch of the extension, or the earliest version of MediaWiki on which the extension's latest master will work?

There seems to be consensus that instead of the "master" branch supporting old MediaWiki releases, developers on releases should use the version of the extension tagged for that release from Special:ExtensionDistributor.

SPage (WMF) (talkcontribs)

In a related hack, in {{ExtensionInstall}} when it displays "To users running MediaWiki 1.24 or earlier: The instructions above describe the new way ..." I think[*] I added

(To run an extension on an earlier release, you may need to download the version of it tagged for that release from Special:ExtensionDistributor.)

It's really a more general point.

[*] I don't know how to test templates using TNT and translation.

Ciencia Al Poder (talkcontribs)

Note that even users running MediaWiki 1.25 should download the version tagged for that, because incompatibilities may happen if the extension was adapted to use new features introduced on master. This warning should probably be on the Special:ExtensionDistributor page

Ciencia Al Poder (talkcontribs)

It may also be "the latest know MediaWiki version where this extension has been tested and is supposed to work"

Reply to "what should mediawiki parameter represent?"