Topic on Extension talk:Scribunto

Jump to navigation Jump to search
ElementalLagomorph (talkcontribs)

Hello,

I'm getting the "Script error: Lua error: Internal error: Error reading from pipe." error on a MediaWiki installation with the "Linux cPanel" version of the GoDaddy host.

I've tested the LocalSettings.php from this installation on a WAMP server on my laptop, and Scribunto runs perfectly there with this LocalSettings.php, so the trouble must lie in the online installation.

I tried chmodding every file in the Scribunto folder to 755, but that didn't change anything, so I deleted the Scribunto folder and reuploaded it to set some of the other files back to their default permissions, then re-chmodded the only file that the instructions say needs the chmod.

The "errorFile" log only works if I use the "luaPath" configuration to point to a non-existant file/directory that isn't the lua binary, and even then it will only just say that there's no such file/directory. If I point it to the lua binary, the errorFile won't log anything, but the "Script error: Lua error: Internal error: Error reading from pipe." error still happens.

Any help would be greatly appreciated.

ElementalLagomorph (talkcontribs)

MediaWiki's backtrace log gives these lines containing "Scribunto" if anyone needs it:

[ContentHandler] Created handler for Scribunto: ScribuntoContentHandler
Scribunto_LuaStandaloneInterpreter::__construct: creating interpreter: '/bin/sh' '/home/elementlagomorph/public_html/wiki/NeonWabbit/extensions/Scribunto/engines/LuaStandalone/lua_ulimit.sh' '7' '8' '51200' ''\''/home/elementlagomorph/public_html/wiki/NeonWabbit/extensions/Scribunto/engines/LuaStandalone/binaries/lua5_1_5_linux_64_generic/lua'\'' '\''/home/elementlagomorph/public_html/wiki/NeonWabbit/extensions/Scribunto/engines/LuaStandalone/mw_main.lua'\'' '\''/home/elementlagomorph/public_html/wiki/NeonWabbit/extensions/Scribunto'\'' '\''0'\'''
Scribunto_LuaStandaloneInterpreter::terminate: terminating
ElementalLagomorph (talkcontribs)

SOLVED! After countless attempts of trying this and that, the problem was solved by:

1) Using a somehow larger lua 2.1.5 linux64 binary I found at the luabinaries sourceforge, and then, 2) Running MediaWiki's purge action.

I leave this information here, in hopes that other people may find it useful.

73.185.196.96 (talkcontribs)

I'm having the same problem, but I wasn't able to resolve it with your solution. The Lua supplied with Scribunto only had the one file in each of the Lua folders. It was labeled "Lua". But the download provided by luabinaries.sourceforge contains 6 files. Did you replace the Lua files in the Scribunto extension with the downloaded? Did you change anything in one of the config PHP files?

Thanks.

71.64.195.175 (talkcontribs)

The lua binary is no longer on sourceforge

Tim Spaulding (talkcontribs)

There are lua binaries on Sourceforge. Are you saying that they aren't current? Where are the current libraries? All roads lead to Sourceforge.

Reply to "Error reading from pipe?"