Topic on Extension talk:ConfirmAccount

Jump to navigation Jump to search

Could not create directory "mwstore://accountcreds-backend/accountcreds-public/w/wi/wik".

27
Daniel K. Schneider (talkcontribs)

MediaWiki 1.25beta (696dc35) Extension: code from GIT (both master and REL_25)

Hello,

  • I ran into this problem: Could not create directory "mwstore://accountcreds-backend/accountcreds-public/w/wi/wik"
  • Several persons reported this in older archieved messages, but my file permission are ok (i.e I can upload an image)
  • $wgFileStore to manually specify a directory will not work (has been removed since MW 1_24

Workaround (I find this truly freaky since the version appear to be the same, according to the "version" page in the wiki):

git checkout REL1_24

- cheers ! Daniel

Lajosb (talkcontribs)

I had this exact same problem, and your trick worked for me too.

But why?...

Nemo bis (talkcontribs)

It means the lastest code of the extension is not compatible with your MediaWiki.

Lajosb (talkcontribs)

Yes, of course that's what it means, but that's really very odd. Like Daniel, I'm using WM 1.25 and the extension version for WM 1.25 (i.e. the version intended for that MW version) isn't working, while an older version (namely that for MW 1.24) is. In other words, the "right" version doesn't work, while a "wrong" version does.

(By the way, I had this problem also with the WikiForum extension. In that case too the 1.25 version had a problem that was solved by downgrading to the 1.24 version.)

Nemo bis (talkcontribs)

There is no guarantee that extensions work with any version. The branches are just a time approximation.

Bawolff (talkcontribs)

Usually that type of error is caused by a permission issue. The extension defaults to $wgUploadDirectory . "/accountcreds" as the directory to use. Make sure that php can create that directory and any subdirectories (e.g. Let the php user [usually www-data] own that directory).

Well $wgFileSotre was removed, you can still set it in LocalSettings.php. The more proper way would be to adjust $wgConfirmAccountFSRepos

Wess (talkcontribs)

Facing the same problem too, downgrading the syst. I could not understand the solution described above. As I understand it tries to save those files at the server root directory. Right now my workaround was to comment out all the file saving issues...

In addition - right now the e-mails to the admin are sent only after email address confirmation. Is there's any possibility to send them at the time of registration?

38.89.3.44 (talkcontribs)
80.252.174.242 (talkcontribs)

Any solution to this? I don't get the comment "git checkout REL1_24"

117.203.118.130 (talkcontribs)

Hello. I am facing the same problem. This discussion does not make clear about how to resolve it. Please guide in a step by step manner.

Jschrempp (talkcontribs)

I have the same problem. I just applied the 1.24.3 patch to 1.24.2. The ConfirmAccount extension was working with 1.24.2.

193.33.2.101 (talkcontribs)

Do you have $wgUploadDirectory = true; in Local Settings?

Wmat (talkcontribs)

This is still a problem with MW 1.25.1 and REL1_25 of the extension.

Ken Roy (talkcontribs)

Download and install the ConfirmAccount extensions for MW 1.24.

I had to do a similar backlevel for the CategoryTree extension where I needed the MW 1.23 version for it to work with MW 1.25.3

Eburcat (talkcontribs)

With MW 1.26 this has become a real issue for us. Can't checkout REL1_25 or REL1_24 - it crashes the whole site, and can't confirm any new accounts now...

Edit: solved it by replacing in the file ConfirmAccount.config.php, this line:

$wgFileStore['accountcreds']['directory'] : $wgUploadDirectory . "/accountcreds",

with the line:

$wgFileStore['accountcreds']['directory'] : "{$IP}/images/accountcreds",

212.122.223.98 (talkcontribs)

Thats great... thanks a lot :)

Dvlink (talkcontribs)

Thank you Eburcat!!

Paladox (talkcontribs)
74.76.112.55 (talkcontribs)

Patch worked for me... I manually made the edits found in the above link by looking at the diff. So far so good.

Paladox (talkcontribs)
Frdpnl (talkcontribs)

Hi,

Absolutely new to mediawiki, so please correct any mistakes :-)

I noticed that the global $wgUploadDirectory is not set when the ConfirmAccount.config.php is loaded (which is a little weird). But, the file ConfirmAccount.php does mention a "hook after setup", where it is set. So, I just added the directory values in that hook function, as below, to remove the error.

function efLoadConfirmAccount() {
  global $wgEnableEmail;
  # This extension needs email enabled!
  # Otherwise users can't get their passwords...
  if ( !$wgEnableEmail ) {
    echo "ConfirmAccount extension requires \$wgEnableEmail set to true.\n";
    exit( 1 ) ;
  }
  # added directory settings here:
  global $wgUploadDirectory, $wgConfirmAccountFSRepos;
  $wgConfirmAccountFSRepos['accountreqs']['directory']  = $wgUploadDirectory . "/accountreqs";
  $wgConfirmAccountFSRepos['accountcreds']['directory'] = $wgUploadDirectory . "/accountcreds";
}

Probably not an ideal place, but it kind of made sense ;-)

Till Kraemer (talkcontribs)

Thank you guys for all your suggestions! I had to make the following changes to LocalSettings.php in order to make it work with MediaWiki 1.27.0:

#$wgFileStore['accountreqs']['directory'] = "{$wgUploadDirectory}/accountreqs";

$wgConfirmAccountFSRepos['accountreqs']['directory']  = "{$IP}/images/accountcreds";

#$wgFileStore['accountcreds']['directory'] = "{$wgUploadDirectory}/accountcreds";

$wgConfirmAccountFSRepos['accountcreds']['directory'] = "{$IP}/images/accountcreds";
94.197.121.127 (talkcontribs)
2A00:23C4:AD02:100:A86F:6D2D:8728:6C06 (talkcontribs)
Paladox (talkcontribs)
119.81.135.29 (talkcontribs)

Receiving this error on confirming accounts on 1.28 and latest release of the extension (ConfirmAccount-REL1_28-8795bd4). Attempted the changes above with the directories with no success.

I'm pretty new to mediawiki and could use some direction on how to resolve the issue. Can upload with no issues, permissions set.

Paladox (talkcontribs)
Reply to "Could not create directory "mwstore://accountcreds-backend/accountcreds-public/w/wi/wik"."