Topic on Project:Support desk

Jump to navigation Jump to search

[RESOLVED] Jobs won't run, templates not updating.

8
86.148.146.56 (talkcontribs)
88.130.96.175 (talkcontribs)

Hi!

The issue that jobs generally do not run automatically was a problem in MediaWiki 1.22. It should have been solved in MediaWiki 1.23 (which you are running currently).

That a certain job does just not do anything at all can happen sometimes. Reasons for this may vary, e.g. the page, which should be indexed by the job may have been deleted in the meantime or another job already did, what this job is about to do. In this case it is save to go to the database table jobs and to manually delete the according rows.

Ciencia Al Poder (talkcontribs)
95.144.138.233 (talkcontribs)

Thanks for the replies! I will take a look at the database - Unfortunately I can't get into it at the moment.

The template not updating was down to my own stupidity - I was editing the wrong section of the page!

The jobs however are still not running. I have specifically set the JobRunRate to 1.

195.234.150.70 (talkcontribs)

I have the same problem, no jobs are running on MW.1.23. Anyone having an idea? $wgJobRunRate is set to 1, $wgPhpCli="C:\Program Files (x86)\PHP". There are no errors when running the RunJobs.php manually and the Job table is empty after running.

Ciencia Al Poder (talkcontribs)

Try setting $wgRunJobsAsync to false (for MediaWiki 1.23 and later) and see if that helps.

Soumya.sadanandan (talkcontribs)

Thanks, this solved my problem with template not getting updated.