Topic on Extension talk:StructuredDiscussions

Jump to navigation Jump to search
MarkJurgens (talkcontribs)

Just trying to install on a clean 1.23wmf14+ (A git master from Feb27th)

I have this error. [cce633e8] 2014-02-28 06:43:02: Fatal exception of type Flow\Exception\InvalidInputException

Notice: Uncommitted DB writes (transaction from DatabaseBase::query (LCStoreDB::get)). in /home/kidsopen/public_html/wiki/includes/db/Database.php on line 4118

I know it's still early but I thought I'd try. :)

SeanFoe (talkcontribs)

You have to run maintenance/update.php before using this extension. (talkcontribs)

Tried it again. Fresh Install from Master 1.23, installed the Flow extension at the same time, no errors on the install.

On discussion page load, I got:

Invalid value was provided for loading flow content. Return to Main Page. [a77b3b08] /core5/index.php?title=User_talk:MarkJurgens Exception from line 166 of /home/wiki/public_html/core5/extensions/Flow/includes/WorkflowLoader.php: Unknown flow type 'discussion' requested Backtrace:

  1. 0 /home/wiki/public_html/core5/extensions/Flow/includes/WorkflowLoader.php(111): Flow\WorkflowLoader->loadDefinition()
  2. 1 /home/wiki/public_html/core5/extensions/Flow/includes/WorkflowLoader.php(85): Flow\WorkflowLoader->loadWorkflow(Title)
  3. 2 /home/wiki/public_html/core5/extensions/Flow/includes/WorkflowLoader.php(344): Flow\WorkflowLoader->__construct(Title, NULL, boolean, Flow\DbFactory, Flow\Data\LocalBufferedCache, Flow\Data\ManagerGroup, Flow\Data\RootPostLoader, Flow\NotificationController)
  4. 3 /home/wiki/public_html/core5/extensions/Flow/Hooks.php(194): Flow\WorkflowLoaderFactory->createWorkflowLoader(Title, NULL)
  5. 4 [internal function]: FlowHooks::onPerformAction(OutputPage, Article, Title, User, WebRequest, MediaWiki)
  6. 5 /home/wiki/public_html/core5/includes/Hooks.php(206): call_user_func_array(string, array)
  7. 6 /home/wiki/public_html/core5/includes/GlobalFunctions.php(4011): Hooks::run(string, array, NULL)
  8. 7 /home/wiki/public_html/core5/includes/Wiki.php(410): wfRunHooks(string, array)
  9. 8 /home/wiki/public_html/core5/includes/Wiki.php(292): MediaWiki->performAction(Article, Title)
  10. 9 /home/wiki/public_html/core5/includes/Wiki.php(588): MediaWiki->performRequest()
  11. 10 /home/wiki/public_html/core5/includes/Wiki.php(447): MediaWiki->main()
  12. 11 /home/wiki/public_html/core5/index.php(49): MediaWiki->run()
  13. 12 {main}
SeanFoe (talkcontribs)

I have installed Flow on a fresh 1.23wmf18 and it works using flow 1.23wmf18

The main trouble is when you try to use flow for the first time on a given page it doesn't work and you have to modify the URL to something like

MarkJurgens (talkcontribs)

Thanks for the reply Sean, but I still can't make it work.

Anyone want to help me by installing it for me? I'd like to use it with my grade 2/3 class. I'm also trying to get Visual Editor to work, can't do it.

I just need someone else to do it. I'm a front-end designer, not a backend guy.

SPage (WMF) (talkcontribs)

Mark, Flow adds the "discussion" workflow at setup time. It should happen the first time you run maintenance/update.php after adding Flow, it adds the Flow database tables and runs 'FlowInsertDefaultDefinitions'. So run that as SeanFoe suggested.

One problem is if Flow install goes wrong, MediaWiki can think that this step completed (the step is recorded in the table 'updatelog'), so you get

 ...Update 'FlowInsertDefaultDefinitions' already logged as completed

If you have some kind of mysql inspection tool (e.g. mysql -u root mywikidb),

mysql> SELECT * FROM flow_definition;

should show two definitions,for "topic" and "discussion". If it complains the table doesn't exist, then you need to rerun update.php; if it doesn't find anything, you can follow EBernhardson's instructions below to delete this:

mysql> DELETE FROM updatelog WHERE ul_key = 'FlowInsertDefaultDefinition' LIMIT 1';

then rerun update.php

In general, if you have developer problems, we're in the (poorly-named) #wikimedia-corefeaturesconnect. (talkcontribs)

Hi ! I was also stuck with the Unknown flow type 'discussion' requested Backtrace. After some time, i tried at least with :

  • MW versions (2.22, 2.23),
  • Flow versions (Master, REL_1.22, REL_1.23)
  • Different configurations (with/without visualEditor, with/without Echo, with differents namespaces, ...)

All seems fine but responses with an error. In my LocalSettings.php, i change :

$wgEnableParserCache = true;
$wgMainCacheType = CACHE_DB;


$wgEnableParserCache = true;

// $wgMainCacheType = CACHE_DB;

And... It appears to work Oo' The update.php run without problem and i can access Talk pages (NS_TALK). It display some input boxes and elements. But when i click the button to post a subject, it trhow me that :

Une valeur non valide a été fournie lors du chargement du contenu du flux.

[edaeaea2] /wiki/index.php?title=Discussion:Agentivit%C3%A9&workflow=ruw4yp3yjq5vhry4&action=new-topic Exception from line 135 of C:\wamp\www\wiki\extensions\Flow\includes\WorkflowLoader.php: Invalid workflow requested by id


#0 C:\wamp\www\wiki\extensions\Flow\includes\WorkflowLoader.php(84): Flow\WorkflowLoader->loadWorkflowById(Title, Flow\Model\UUID)
#1 C:\wamp\www\wiki\extensions\Flow\includes\WorkflowLoader.php(346): Flow\WorkflowLoader->__construct(Title, Flow\Model\UUID, boolean, Flow\DbFactory, Flow\Data\LocalBufferedCache, Flow\Data\ManagerGroup, Flow\Data\RootPostLoader, Flow\NotificationController)
#2 C:\wamp\www\wiki\extensions\Flow\Hooks.php(268): Flow\WorkflowLoaderFactory->createWorkflowLoader(Title, Flow\Model\UUID)
#3 [internal function]: FlowHooks::onPerformAction(OutputPage, Article, Title, User, WebRequest, MediaWiki)
#4 C:\wamp\www\wiki\includes\Hooks.php(199): call_user_func_array(string, array)
#5 C:\wamp\www\wiki\includes\GlobalFunctions.php(3877): Hooks::run(string, array)
#6 C:\wamp\www\wiki\includes\Wiki.php(430): wfRunHooks(string, array)
#7 C:\wamp\www\wiki\includes\Wiki.php(312): MediaWiki->performAction(Article, Title)
#8 C:\wamp\www\wiki\includes\Wiki.php(602): MediaWiki->performRequest()
#9 C:\wamp\www\wiki\includes\Wiki.php(467): MediaWiki->main()
#10 C:\wamp\www\wiki\index.php(49): MediaWiki->run()
#11 {main}

Here is the line 135 of Workflowloader.php, where it seems to be a bug with $workflow (but how? why? (need help)) :

protected function loadWorkflowById( /* Title or false */ $title, $workflowId ) {
     $workflow = $this->storage->getStorage( 'Workflow' )->get( $workflowId );
           if ( !$workflow ) {
     throw new InvalidInputException( 'Invalid workflow requested by id', 'invalid-input' );
Mmullie (WMF) (talkcontribs)


You've uncovered some bugs there!

The first one: CACHE_DB causes some issues.
Apparantly, there's a small discrepancy in how SqlBagOStuff (SQL-based cache) returns cache misses, compared to other cache types.
I've filed bug
Fix should be at

The second: you seem to be running with javascript disabled (or something preventing it from being executed). Apparently, we've broken our no-js pretty bad and it's now impossible to submit new topics/replies without JS.
I've filed bug
There's a couple of fixes, at:,,
I still have to figure out if there are other actions that are now broken without JS; the above patches should fix create-topic & reply.

Once the patches I've linked to have been merged, these issues should be fixed. Or you can cherry-pick the to your local setup.

Thanks for the help! (talkcontribs)

Would mathematics like following work on Flow comments/replies?


TitusiMW (talkcontribs)

Of course I am assuming mathematics work on the rest of the wiki.

Reply to "Errors, just trying it out"