Topic on Talk:MediaWiki 1.18

Jump to: navigation, search
147.6.1.121 (talkcontribs)

Recenetly, i upgrade 1.18 version from 1.17.x. And i met the error message when i upload a file. The message is "The file is a corrupt or otherwise unreadable ZIP file. It cannot be properly checked for security" The format are doc,xls.....not a zip... How can i solve this error.

178.120.222.189 (talkcontribs)

I figured out that it tries to Unzip Doc file with ZipDirectoryReader::read and fails. Actually doc file is some kind of zip file but even standard zip program raises warnings: Archive: text.doc warning [text.doc]: 167526 extra bytes at beginning or within zipfile

 (attempting to process anyway)
 inflating: [Content_Types].xml     
 inflating: _rels/.rels             
 inflating: theme/theme/themeManager.xml  
 inflating: theme/theme/theme1.xml  

It is not much secure but I'm block this by: $wgAllowJavaUploads = true;

May be its help you

78.57.225.39 (talkcontribs)

Ty it solved my problem.

Steve.Tarzon (talkcontribs)

Hi, I tried this and got an error 500, still trying to figure out exactly what the problem is. If I comment out $wgAllowJavaUploads = true; I get the message: The file is a corrupt or otherwise unreadable ZIP file. It cannot be properly checked for security.

Regards, Steve

Bawolff (talkcontribs)

[for Steve.Tarzon's issue] 500 error indicates php fatal error (aka bug in MediaWiki or an extension). If you enable php error reporting (See How to debug) it would be helpful in fixing the issue.

177.103.206.192 (talkcontribs)

I'm having the same problem with version 1.18. I'm try to upload XLS, DOC, files. It is impossible. I've searched around the web and found no help.

Sumanah (talkcontribs)

You can now upgrade to MediaWiki 1.19 to see if that helps....

155.33.208.227 (talkcontribs)

Upgrading did not help us. We are still unable to upload .doc files. This is a major bug, it must be fixed ASAP.

Sumanah (talkcontribs)

We urge you to file it in Bugzilla, our bug reporting system, with as many details as possible about your setup, the behavior, and anything else that might be relevant to tracking down and fixing the problem. Thanks!

Sumanah (talkcontribs)

Please file it in http://bugzilla.wikimedia.org which is our bug tracker, indicate how severe the problem is, and give us the information we need to fix it. Thanks!

Sumanah (talkcontribs)

test.

Lbillett (talkcontribs)

Setting $wgAllowJavaUploads = true fixed it for me too

217.114.100.74 (talkcontribs)

For me (1.15, managed by debian squeeze) $wgAllowJavaUploads=true was not enough. I had to use $wgVerifyMimeType=false as well. Be warned though, this is bound to lead to some serious security issues.

203.41.203.50 (talkcontribs)

Fixed it for me too.

192.54.145.146 (talkcontribs)

M$ documents (doc, dot) generated with OOo or LOo are uploaded with success.

Lilis2nd (talkcontribs)

Solved my problem as well.
Thanks for the tip!

24.114.255.83 (talkcontribs)

I got same error but trying to attach a Draft email .msg

While inserting a .msg from completely received email worked...

I am using 1.22 tho :\

Reply to "file upload error"