Topic on Project:Support desk

Jump to: navigation, search
Jasper Deng (talkcontribs)

I've configured email using $wgSMTP, but when I send an e-mail to another user, my $wgNoReplyAddress is used instead of the e-mail address the user set.

Bawolff (talkcontribs)

You need to set $wgUserEmailUseReplyTo in order for from address to be another user. Note there may be some problems with doing this and spam detection, (from code comments):

                        // Put the sending user's e-mail address in the From: header.
                        // This is clean-looking and convenient, but has issues.
                        // One is that it doesn't as clearly differentiate the wiki mail
                        // from "directly" sent mails.
                        // Another is that some mailers (like sSMTP) will use the From
                        // address as the envelope sender as well. For open sites this
                        // can cause mails to be flunked for SPF violations (since the
                        // wiki server isn't an authorized sender for various users'
                        // domains) as well as creating a privacy issue as bounces
                        // containing the recipient's e-mail address may get sent to
                        // the sending user.
Jasper Deng (talkcontribs)

It didn't work.

Bawolff (talkcontribs)

Just to clarify, I meant set that setting to false.

Note: for non user to user email, the relavent setting is $wgEnotifRevealEditorAddress, $wgEnotifFromEditor and a preference option I believe.

Reply to "User-to-user e-mail return addresses"