Topic on Project:Support desk

Jump to navigation Jump to search

Thumbnail not working in MediaWiki 1.19

11
Stefahn (talkcontribs)

Most of my thumbnails are not working since I updated to MediaWiki 1.19. I get an error message saying

Error creating thumbnail: Unable to save thumbnail to destination

This problem seems to affect many other users as well. I already found this thread and posted my question there (on 16. Jun. 2012, at the very bottom) but didn't get an answer so far: http://www.mediawiki.org/wiki/Talk:MediaWiki_1.19#Thumbnails_didn.27t_work_since_Update_to_1.19_15046

Who can help me please??

BTW: The same problems occurs with a brandnew MediaWiki 1.19.1.
I run another wiki on the same shared hosting with MediaWiki 1.16.2 and all thumbnailing works fine on this installation.

MediaWiki: 1.19.1
PHP version: 5.3.13-1~dotdeb.0 (cgi-fcgi)
MySQL version: 5.5.25-1

88.130.119.82 (talkcontribs)

Hi Stefahn,

I think thi might be caused by wrong permissions to the images/ directory, in which the thumbnail should be saved. Maybe the PHP log contains more detailed information.

Stefahn (talkcontribs)

Thanks for your quick reply.
I tried chmod 775 and 777 for the images folder (and all subfolders) but it still didn't work.

My webspace is configured in such way that PHP errors are displayed on the screen directly - but I get nothing except a error message from MediaWiki (in German: "Fehler beim Erstellen des Vorschaubildes: Die Miniaturansicht konnte nicht am vorgesehenen Ort gespeichert werden", in English: "Error creating thumbnail: Unable to save thumbnail to destination").

If you read the mentioned thread you will see that there's a problem with a temp folder - the first offered fix didn't work in my case, the second one is within the 1.20 branch and I don't know if I can use it with 1.19.1? And if yes, how to use it since there's a new variable...

Stefahn (talkcontribs)
37.24.93.18 (talkcontribs)

Hi there,

after upgrading to 1.19 i have the same problem subscribed above with the following german error message: "Fehler beim Erstellen des Vorschaubildes: Die Miniaturansicht konnte nicht am vorgesehenen Ort gespeichert werden"

I followed the above steps and also the link provided and tried to insert the variables to the localsettings and cecked /cache /images/*

for write permissons.

my web provider has not installed imagemagic, but provides gd, which worked for images and thumbnails before.

Thanx Ric

Stefahn (talkcontribs)

Hi Ric,

did you apply the patch as shown here? The patch is actually for 1.20 but it also worked for me with 1.19.1.

There's only one line to be added to LocalSettings.

Did you create the directory "temp" as a subdirectory of the images folder? As far as I can remember I created it manually.

BTW: I updated the link to the other discussion since it was broken.

37.24.93.18 (talkcontribs)

Hi Stefahn,

thanks for your reply. I have not aplyed this patch. I had a look at the file, which contains the discription for many changes. Do I have to aply the changes manually or is there an automated way?

The /images contains the following subdirectories: /imags/archive

/imags/temp

/imags/thumb

I had to create all of them manually in they all have 775 recursive rights.

Strange thing is when uploading an images a thumb frame with the pic to upload is shown. but the thumb of an uploaded images shows the above error. I have an image, but can not upload it until I am autoaprove iin the next 4 days.

Ric

Stefahn (talkcontribs)

You definitely should apply the patch!

If you have Git or Tortoise you can patch the files automatically.
If you don't have any of these you can just download the files and upload them via FTP. Mark posted this yesterday in the other thread: http://www.mediawiki.org/wiki/Thread:Talk:MediaWiki_1.19/Thumbnails_didn't_work_since_Update_to_1.19/reply_(36)

After updating the files make sure to create a subfolder called temp and to add the following line to localsettings.php

$wgTmpDirectory = "$IP/images/temp";

Cheers.

Rickster mediawiki (talkcontribs)

Thanx for your hints Stefahn, I finaly got it to work.

I downloaded the files seperately from your given link http://www.mediawiki.org/wiki/Thread:Talk:MediaWiki_1.19/Thumbnails_didn't_work_since_Update_to_1.19/reply_(36)

and uploaded them manually to my webspace. Then I inserted the above variable into localsettings.php

But I wonder if there is an easier way to aply the patch. Why did this problem occure? Does every wiki has this prob with the newest version. Will there be a new wiki version with this prob fixed?

Ric

Stefahn (talkcontribs)

Good to hear that you got it to work :)

I wonder about this as well.
It will be fixed in version 1.20 - I don't know if the developers will add the fix also to the 1.19 version. If I got it right this issue appears only if you use shared hosting (I do).

Stefahn (talkcontribs)
Reply to "Thumbnail not working in MediaWiki 1.19"