Topic on Project:Support desk

Jump to navigation Jump to search

includes/WebRequest.php: MediaWiki does not function when magic quotes are enabled. Problems with installing mediawiki

10
95.112.0.184 (talkcontribs)

Hello, i am trying to install mediawiki, unfortunately i am getting this error report. Can anyone help me please? Many gretings Gloria


[c8aeae25] [no req] Exception from line 61 of /data/multiserv/users/1289248/projects/2707382/www/mediawiki-1.24.1/includes/WebRequest.php: MediaWiki does not function when magic quotes are enabled.

Backtrace:

  1. 0 /data/multiserv/users/1289248/projects/2707382/www/mediawiki-1.24.1/includes/Setup.php(544): WebRequest->__construct()
  2. 1 /data/multiserv/users/1289248/projects/2707382/www/mediawiki-1.24.1/includes/WebStart.php(121): require_once(string)
  3. 2 /data/multiserv/users/1289248/projects/2707382/www/mediawiki-1.24.1/mw-config/index.php(36): require(string)
  4. 3 {main}
88.130.79.243 (talkcontribs)

This error means that there is a problem with your PHP configuration: You have an option called "magic quotes" enabled. However, MediaWiki needs this option to be disabled in order to work properly.

You need to disable magic quotes in the PHP configuration to fix this problem!

95.113.128.195 (talkcontribs)

thank for the answer. Can you tell how i find my php configuration. I have kilu.de and also filezilla. Is it anywhere there?

88.130.127.250 (talkcontribs)

The PHP configuration usually is located inside php.ini files. Where the according files are located in your case depends on the server setup. Your host will know that! Note that many shared hosters do not allow you to edit these files as doing so you would be able to change the PHP configuration.

I would have lked to give you a link to the PHP manual where you will find further details about how to enable/disable magic quotes, but mediawiki.org does not let me save posts, if they contain links. So no link for you.

95.113.128.195 (talkcontribs)

maybe you could send it to my emailadress: Glow88 (at) gmx. net That would be so great. Thank You

Glameglumps33 (talkcontribs)

Oh, I just happened to notice this comment and just figured I'd mention that I found a quick fix for that. If you surround the link in nowiki tags, you can display the link, although it won't be clickable.

For example:

https://en.wikipedia.org/wiki/Main_Page

Also, internal links seem to work fine.

88.130.127.250 (talkcontribs)
Glameglumps33 (talkcontribs)

Lol yeah I hope it's just a bug that gets fixed soon.

Florianschmidtwelzow (talkcontribs)

@88.130.127.250: I have fixed your post to make it a clickable link :) (hope that's not a general problem? :/)

88.130.81.215 (talkcontribs)

Thanks for fixing, Florian!

I think it is a general problem: It worked until maybe two weeks or so back and then it stopped. Since then, when I have a link in my posts, after clicking "Save page", these posts are not saved. As I said that started maybe two weeks or so ago. Since then, this problem is there with every single post I try to make here.

I don't know if a captcha is wanted or whatever, anyway: The current situation is just bad! This should be fixed again!

Reply to "includes/WebRequest.php: MediaWiki does not function when magic quotes are enabled. Problems with installing mediawiki"