Topic on Extension talk:WYSIWYG

Jump to: navigation, search

Yes: Working with MW-1.21+ with some settings

33
Godvicien (talkcontribs)

Hello!

Sorry for my poor English, I'm French...

I succeed to WISIWYG in latest version to work with MW-1.21.1, simply with this LocalSettings:

1] Comments the 2(+?) lines that have "wfLoadExtensionMessages" in "CKeditor.body.php".

2] Here are my LocalSettings that works:

//WYSIWYG:
<syntaxhighlight lang="PHP">
require_once( "$IP/extensions/WikiEditor/WikiEditor.php" ); //By Texts (very old)
require_once("$IP/extensions/WYSIWYG/WYSIWYG.php");//Activation some for all extensions
$wgGroupPermissions['*']['wysiwyg'] = true;//Everyone can use (if can edit)...
$wgDefaultUserOptions['cke_show'] = 'richeditor';//Enable CKEditor
$wgDefaultUserOptions['riched_use_toggle'] = true;//Editor can toggle between CKEditor/WikiTextBox
$wgDefaultUserOptions['riched_start_disabled'] = false;//Important!!! else bug...
$wgDefaultUserOptions['riched_toggle_remember_state'] = true;//working/bug?)
$wgDefaultUserOptions['riched_use_popup'] = false;//Deprecated

3] Add these line into LocalSettings for exclude WISIWIG from this sections (not compatible):

$wgFCKEditorExcludedNamespaces[] = NS_MEDIAWIKI;
$wgFCKEditorExcludedNamespaces[] = NS_TEMPLATE;

Then needs to read the others threads of this forum to have helpful ;-) Godvicien (talk) 08:25, 15 June 2013 (UTC)

Edit: If you want and if developers here we can open a common SourceForge project with this Extension (I'm Web-developer)... If you are Web Developer, respond to this thread !

91.3.200.76 (talkcontribs)

Works for me too! Thanks!

138.11.0.153 (talkcontribs)

It doesn't seem to work when editing in Internet Explorer though. I get a blank page... do you have any idea what to change?

174.46.144.130 (talkcontribs)

It worked fine for me with internet explorer 10.

what version of IE are you using?

also check your web server error logs. there may be a clue there

134.134.139.74 (talkcontribs)

I tried it with Chrome and it worked fine. I tried to do the same edit on IE8 and instead of storing my edit it stored nothing back into the whole section of the page I was editing. I tried it with IE10: that also threw away my changes and stored an empty section. Worse, when I tried to roll-back the edit on IE8, it put the entire page into edit mode and while it looked like it was all back in the Preview, when I saved the "undo" it blanked the entire Wiki page- so it even kills off the rollback ability. --Flint

This post was posted by 134.134.139.74, but signed as 134.134.137.75.

194.25.45.16 (talkcontribs)

My IE8 does also empty the page when I save the page. But I do even get an empty page when I switch directly from WYSIWYG to the common text editor without changing a bit of the page. Does anybody have found any solution for that bug in the meantime?

194.25.45.16 (talkcontribs)

addition: switching to IE9 did not yield any improvement. Will try IE10 later on.

Amitk75mw (talkcontribs)

Hi,

Even I am facing issues with IE9. If I add any link (internal/external) then the whole linked text disappears as soon as I save the page or switch to text editor. I am using MW 1.21 and used the extension recommended on the page as well as made the changes suggested. It seems to be working properly with FireFox. Any idea what could be wrong?

66.128.103.114 (talkcontribs)

Works for me too. I found "wfLoadExtensionMessages" in my "CKeditor.body.php" on lines 345 and 532.

186.105.213.118 (talkcontribs)

Found only one expression in CKeditor.body.php....

121.235.29.188 (talkcontribs)

wocao i can not understand what are talkking about

217.19.202.58 (talkcontribs)

Hello !

Have you any issue with cancel button when you use this editor ?

I can use it with your instructions (thanks !) but if i try to create a page (or edit) and after that, cancel action, i've an issue with url redirection.

For example, if i try to edit home page and cancel it, i've this url : http://xxxx.com/Home instead of http://xxxx.com/index.php?title=Homme

186.105.213.118 (talkcontribs)

Dommage....

Fatal error: Call to undefined method Parser::strip() in /XXXX/extensions/WYSIWYG/CKeditor.body.php on line 90 Je n'ai trouvé qu'une expression wfLoadExtensionMessages

81.144.199.142 (talkcontribs)

Extension itself is working. I have noticed problem with inserting image ( wiki 1.21 ) one thing is that I have list of avaliable pictures, serch is wokring ok but when I'm selecting some picture I don't have preview, I have picture indicating that image file is unavaliable. If will select picture (even if I don't have preview) in content I have link to picture http://mydomain.com/extensions/WYSIWYG/ckeditor/skins/kama/images/noimage.png?t=B49E5BQ (mydomain is changed by me ;))

Any ideas ?

Thanks

F123h (talkcontribs)

This instruction only works for a previous version of WYSIWYG (see Installation on Mediawiki 1.17.x to 1.20.x). Download link https://docs.google.com/file/d/0B-aiZzKTmWI2bG8yVzBCOWNLamM/view Does not work for WYSIWYG which 'Works on Mediawiki 1.21.1' .

88.138.228.144 (talkcontribs)

hello. same problem with Mediawiki 1.21.1 WYSIWYG is not work.

49.144.39.7 (talkcontribs)

Hi. I need help. My version is 1.20.3. I installed this WYSIWYG extension. After installing, I saw it on Special:Version.

But when I started to edit a page, I can see the editor is there but the icons or buttons are greyed out. And I cannot type in on the editor itself. Hope someone can help me on these. :(

49.144.39.7 (talkcontribs)

Hi. I need help. My version is 1.20.3. I installed this WYSIWYG extension. After installing, I saw it on Special:Version.

But when I started to edit a page, I can see the editor is there but the icons or buttons are greyed out. And I cannot type in on the editor itself. Hope someone can help me on these. :(

193.26.194.93 (talkcontribs)

Great! Works like a charm :) Thanks a lot!

DaPi (talkcontribs)

Pilot testing with BitNami MW 1.21.2 under Windows. Looking good except that a links to non-standard file extensions pose a problem:

[[Media:AnnualReport2013.pdf|Annual Report]]

is replaced by

[[/mediawiki/images/c/ca/AnnualReport2013.pdf|Annual Report]]

which is interpreted as a non-existent page.

Ooops - sorry this is addressed in another thread. My bad.

50.126.86.211 (talkcontribs)

I got a "Strict Standards: Declaration of CKeditorParserOptions::getSkin() should be compatible with ParserOptions::getSkin($title = NULL) in ...\extensions\WYSIWYG\CKeditorParserOptions.body.php on line 3". To fix it, I changed "function getSkin()" to "function getSkin( $title = null )" in CKeditorParserOptions.body.php (Line 7). Now it matches the getSkin() function in \includes\parser\ParserOptions.php, line 262.

194.25.45.16 (talkcontribs)

When I put the line with <syntaxhighlight lang="PHP"> into my LocalSettings.php file I can't load any page of the wiki. All I get is a blank page. Without that line I can edit pages with firefox and ie10 (earlier ie versions empty the pages after saving) and the editor chews up all category lines. All category entries just disappear after saving the work! :(

2.180.154.251 (talkcontribs)

It works, thank you so much. I hope the WYSIWYG author release an update.

Il fonctionne, je vous remercie beaucoup. J'espère que l'auteur de WYSIWYG libérer une mise à jour.

Doun (talkcontribs)

Hello I tried everything and still doesnt work for me?. They told me there would be a popup for the wysiwyg editor. BNutit doesn't appear. What do I have to do ?? :(

Riparap (talkcontribs)

You could perhaps try to modify following setting in LocalSettings.php (set value to "true"):

  • $wgDefaultUserOptions['riched_use_popup'] = false; //Deprecated

Based on comment in the end of that line, setting it to value "true" may not work properly at least with programs of #6 bundle of download section.

Ersansoucis (talkcontribs)

Deux siècles plus tard, sur MediaWiki 1.24.1

Après différentes installations (à partir de https://www.mediawiki.org/wiki/Extension:WYSIWYG ) qui ont toutes échoué, j'ai tenté l'install de Godvicien.

Et pour le moment, elle échoue ici : Fatal error: Cannot access protected property OutputPage::$styles in /homepages/24/d535053617/htdocs/New node/extensions/WYSIWYG/CKeditor.body.php on line 194

Alors je suis épuisé. Je me demande si WYSIWIG n'a pas un successeur digne de ce nom. J'ai fait quelques recherches mais en plus d'être épuisé, je suis malade, donc je ne pige rien. Merci de m'aider si vous le pouvez.

Varlin (talkcontribs)

Salut. Chez moi ça marche pourtant. En tout cas, avec Mediawiki 1.23.7, et la dernière version de WYSIWYG maintenue par Riparap.

Riparap (talkcontribs)

If you have problem with MW 1.24+ and protected property OutputPage::$styles, you have to make manual adjustments in one of the files of wysiwyg extension (latest version at current moment is 1.5.6_0 [B551+02.02.2015] and it can be found here in Github)

For more details about protected property OutputPage::$styles, please see this thread and links Protected_variable_in_MW1.24.

Reply to "Yes: Working with MW-1.21+ with some settings"