Topic on Extension talk:VisualEditor

Jump to navigation Jump to search

Installing VisualEditor on MediaWiki 1.25.1 and 1.26.0 on Debian 7

10
MKruer (talkcontribs)

This is an overview of what it took for me to get VisualEditor working with MediaWiki 1.25.1, I hope this helps other people that might be experiencing issues in the setup.

Requirements (This is what My System is currently using)

  • MediaWiki 1.25.1
  • VisualEditor REL1_25
  • UniversalLanguageSelector REL1_25
  • parsoid 2.2.0
  • nodejs 0.10.38-1chl1
  • php5-curl 5.4.39-0+deb7u

Installing/Update parsoid'

apt-get install parsoid
apt-get install nodejs
apt-get install php5-curl

Testing parsoid to make sure it works

cd /usr/lib/parsoid/src/tests
./runtests.sh

The test should run and complete, there will be warning and possibly errors for parsoid bugs. The full results can be viewed in the folder /usr/lib/parsoid/src/tests/results/all.txt

Update the following files with the correct parsoidConfig settings (I seems like you need both for it to work in a Debian Environment) Also you MUST restart the parsoid service every time you change either file for the changes to take effect.

/etc/mediawiki/parsoid/settings.js
/usr/lib/parsoid/src/api/localsettings.js

i.e. parsoidConfig.setInterwiki( 'mediawiki', 'http: //localhost/mediawiki/api.php'); <- Remove the space between http: //localhost

Installing MediaWiki 1.25.1 and VisualEditor

Instructions on configuring the LocalSettings.php (More or less copy and paste)

Notes: Multiple MediaWiki Instances on Single Host I can confirm that I am able to run multiple MediaWiki instances on a single host and VisualEditor works fine. Parse the Link below for how I am doing it on my site.

http: //sharkysoft.com/wiki/how_to_configure_multiple_MediaWiki_instances_on_a_single_host

Slowness with parsoid Still have not quite figured this one out, but after stopping restarting apache and parsoid the parser times have stabilized for me.

Jdforrester (WMF) (talkcontribs)

Thank you.

5.35.186.135 (talkcontribs)

Thanks for the help this worked, I have been trying to get this running for a week now!!

MKruer (talkcontribs)

Update for the New Media Wiki 1.26.0

You should be able to do a upgrade "sudo apt-get update && sudo apt-get upgrade"

  • MediaWiki 1.26.0
  • VisualEditor REL1_26
  • UniversalLanguageSelector REL1_26
  • parsoid 0.4.1all (Parsoid/Setup)
  • nodejs 0.10.41-1nodesource1~wheezy1
  • php5-curl 5.4.45-0+deb7u2

After the upgrade you will need to update the two following files as the syntax has changes between versions.

/etc/mediawiki/parsoid/settings.js
/usr/lib/parsoid/src/api/localsettings.js < localsettings.js.example

You also need to update the LocalSettings.php as the VisualEditor syntax has also changed.

Finally It appears that the Multiple MediaWiki Instances on Single Host is no longer working. The Parsoid only seems to recognize the last site setting from the /usr/lib/parsoid/src/api/localsettings.js

What I mean by this is that if you have two or more sites defined in Parsoid, VisualEditor will only work on the last site defined. If you try to user VisualEditor on the First Sites pages, the editor will load correctly but the Parsoid instance used is for the second site (last site defined) This cause the entire editor to render a new page. The Parsoid Log also show this same behavior.

Niamb001 (talkcontribs)

Hi, i am trying to install MediaWiki on a mac on XAMPP.

I have tried to do it with the latest version as well as with version 1.25.

I am always getting the error message:

"Uncaught exception 'Exception' with message 'VisualEditor is not compatible with the current MediaWiki core (version 1.26.0), it requires: >= 1.27.0.' "

Jdforrester (WMF) (talkcontribs)

You need to use the relevant version of VisualEditor for that version of MediaWiki. Master/latest of MediaWiki requires master/latest of MediaWiki, not the latest release version (which is seven months old at this point).

139.169.194.112 (talkcontribs)

MKruer, you saved me! The required version of parsoid for VisualEditor really ought to be officially documented.

71.93.58.162 (talkcontribs)

what is the required version of parsoid for VisualEditor REL1_27?

71.93.58.162 (talkcontribs)

I am trying to install Visual Editor REL1_27 on MediaWiki V27

I get this error when trying to edit: Warning Parameter 1 to VisualEditorHooks::onBeforePageDisplay() expected to be a reference, value given in C:\xampp\htdocs\mediawiki\includes\Hooks.php on line 195

does it matter that I am using php version 7.1?

71.93.58.162 (talkcontribs)

nevermind. downgraded to xampp with php 5.6.3 and everything's working.

Reply to "Installing VisualEditor on MediaWiki 1.25.1 and 1.26.0 on Debian 7"