Topic on Extension talk:UserAdmin

Jump to navigation Jump to search
ClementLinz (talkcontribs)

Product Version MediaWiki 1.20.3 PHP 5.3.21 (cgi-fcgi) MySQL 5.1.52-log

+User Administration (Version 0.5.0)

+ required_once for UserAdmin.php in Localettings. By Submitting form (Edit/Add/Purge) -> "No such special page" Can anyone help ?

Thanks.

Smenci (talkcontribs)

I'm having the same problem:
When I go to wiki/index.php?title=Special:UserAdmin I see the first 25 users, and everything looks good.
But if I do any action that adds arguments to the URL, it doesn't work.
For example going to wiki/index.php?title=Special:UserAdmin?pagesize=50 says "You have requested an invalid special page."
MediaWiki version: 1.20.3
User Administration version: 0.5.0

Weiserma (talkcontribs)

I get the same problem installed on an older wiki MediaWiki 1.16.5

130.15.92.149 (talkcontribs)

I'm having the same problem

Product Version

MediaWiki 1.19.0

PHP 5.2.17 (cgi)

MySQL 5.5.28-29.3-log

Btechnix (talkcontribs)

To fix that change SpecialUADMBase.class.php about line 440 in function getURL($params) to replace '?' by '&',

from:

$retvURL .= '?' . http_build_query($nonDefaultParams);

to:

$retvURL .= '&' . http_build_query($nonDefaultParams);

76.118.31.113 (talkcontribs)

Yeah, it definitely seems like this is a main problem. If I manually change the ? to a & on pages that give the error it works fine, although you can't do that with some of the functions obviously.

I tried your fix. Worked like a charm. Thanks!

130.255.16.114 (talkcontribs)

This fix worked fine for me, however, when editing an email address, I need to change back the & to a ? in order to get it to work. Maybe an if which checks if an ? or & is needed needs to be implemented somewhere along this code.. Sadly I don't have the time right now to experiment with this. I don't need to change things that often so changing the ? to an & or vice versa is not that much work, but it is not an ideal situation

206.81.211.98 (talkcontribs)

This fix worked perfect for me. However, editing users and changing passwords only works in Firefox(well not IE10 anyway).

Cheers, Matt H

67.171.158.66 (talkcontribs)

Special:UserAdmin reads, "Fatal error: Call to undefined function wfLoadExtensionMessages() in /home/scratcha/public_html/extensions/UserAdmin/SpecialUADMBase.class.php on line 59"

146.1.1.1 (talkcontribs)

Perform a check if ? exists. Made changes on line 440

if (count($nonDefaultParams) > 0){

 if (strpos($retvURL,'?')!==FALSE){
   $retvURL .= '&' . http_build_query($nonDefaultParams);
 }else{
   $retvURL .= '?' . http_build_query($nonDefaultParams);
 }

}

Adelovieira (talkcontribs)

Hello,

I have the same problem, but it doesn't work for me. It has also disabled Special:SpecialPages

User Administration Version 0.5.0

MediaWiki 1.22.6

PHP 5.3.2-1ubuntu4.24 (apache2handler)

MySQL 5.1.73-0ubuntu0.10.04.1

Thanks for your help.

212.118.223.36 (talkcontribs)
Stoczko (talkcontribs)

Same here. I added this:

require_once("$IP/extensions/UserAdmin/UserAdmin.php"); in LocalSettings.php

to the end of the LocalSettings.php file, and lost the entire wiki. I needed to comment it out to get the wiki back again. I wonder where I am supposed to add the fix mentioned above by Btechnix...?

83.246.9.107 (talkcontribs)

@Stoczo, you need to add only the following line at the end of your LocalSettings.php file

require_once("$IP/extensions/UserAdmin/UserAdmin.php");

Lungpu (talkcontribs)

We finally made it work for MW 1.26. These are the changes you need to make:

1- Mentioned earlier in this thread:

Near line 440 in SpecialUADMBase.class.php change the if to look like

if (strpos($retvURL,'?')!==FALSE){
  $retvURL .= '&' . http_build_query($nonDefaultParams);
}else{
  $retvURL .= '?' . http_build_query($nonDefaultParams);
}

2- Function isValidEmailAddr has been deprecated versions ago, so you need to change that call in SpecialEditUser.class.php and SpecialAddUser.class.php.

User::isValidEmailAddr( ... ) changes to: Sanitizer::validateEmail ( ... )

and that's it.

62.145.36.18 (talkcontribs)

Trying to get this to work with 1.28 mediawiki.. I get a generic server error when loading the UserAdmin and applying the above mentioned changes :(

Anyone figured this out yet with the current stable version?

Reply to "No such special page"