Jump to content


About this board

XMLHttpRequest endpoint - Http

Felipemr98 (talkcontribs)

I'm trying to run this on a server, but when I try to add statements I get the following error while typing on the input box

jquery.js:9940  Mixed Content: The page at 'https://my.host/wiki/Item:Q1?wprov=acrw1_0' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://my.host/w/api.php?action=wbsearchentities&search=s&format=json&errorformat=plaintext&language=en&uselang=en&type=property'. This request has been blocked; the content must be served over HTTPS.

Is there a way to solve this problem? make this request with https?

Changing $wgServer from WebRequest::detectServer() to "https://my.host" will 'solve' this problem but then QS and WDQS will not work.

Reply to "XMLHttpRequest endpoint - Http"

WDQS - No matching records found for content added to main wikibase store

Felipemr98 (talkcontribs)

I'm encountering an issue while working with the tags/wmde.17 branch and setting up the extended installation on my server, which includes Wikibase, WDQS, and Quickstatements. Despite adding data to Wikibase, I'm unable to retrieve any results when executing my query.

I've configured the necessary variables in my .env file

## Image Configuration










## Wikibase Configuration


# wikibase.svc is the internal docker hostname, change this value to the public hostname




## WDQS-frontend Configuration

# wdqs-frontend.svc is the internal docker hostname, change this value to the public hostname



## Quickstatements Configuration

# quickstatements.svc is the internal docker hostname, change this value to the public or local hostname




## ElasticSearch

## Comment out MW_ELASTIC_HOST to disable ElasticsSearch

## See https://github.com/wmde/wikibase-release-pipeline/blob/wmde.11/Docker/build/WikibaseBundle/LocalSettings.d.template/WikibaseCirrusSearch.php#L6



I've not made any major changes to docker-compose.extra.yml

When I run this project locally, Wikibase works perfectly with WDQS and QS, but that's not the case when I'm running these services on a server, so I'm wondering if there's something I'm missing with the configuration?

Felipemr98 (talkcontribs)

I switched to the tags/wmde.20 branch and now WDQS and QS are working fine.

localhost didn't send any data

1 (talkcontribs)

I've followed the instructions to set up a wikibase sandbox on my local. I used the minimal install to launch my wikibase. I have verified that all three containers are up and running. However, I get ERR_EMPTY_REPONSE when I tried to access my localhost from the browser. In the past, I have successfully deployed a wikibase sandbox with the same process before (I think it was tags/wmde.13), but I started to encounter this issue since last week. Please let me know if I need to provide more information.

Reply to "localhost didn't send any data"

Sitelinks between Wikibase and Mediawiki on local install

Dmitry Brant (talkcontribs)

I've followed to instructions to set up Wikibase in Docker, but now I'd like to make links between my wikibase items and my Mediawiki pages (on the same install). The instructions say to "run the addSite.php" script, but what parameters should I give it?

Addshore (talkcontribs)
Reply to "Sitelinks between Wikibase and Mediawiki on local install"

error: /jobrunner-entrypoint.sh: Is a directory

2 (talkcontribs)

Has anyone run into this when installing?

`/jobrunner-entrypoint.sh: /jobrunner-entrypoint.sh: Is a directory`

Any pointers would be welcome!

Addshore (talkcontribs)
Reply to "error: /jobrunner-entrypoint.sh: Is a directory"

Search is not working

Podbrushkin (talkcontribs)

After fresh installation, search function isn't working, and search extensions aren't enabled in LocalSettings.php. Was it made on purpose?

Dan Shick (WMDE) (talkcontribs)
Podbrushkin (talkcontribs)

@Dan Shick (WMDE) Hello! Actually, I am writing an instruction on this topic, and you can see exactly how I've installed Wikibase in first section of it. And in Search function subsection there is an explanation of how to make MediaWiki search to work. I hope it will help to get a notion of what's going on. wikiversity:User:Podbrushkin/Wikibase:_Local_Instance

Podbrushkin (talkcontribs)

Yes, I am. Everything works fine: SparQL, QuickStatements, new Wikibase-item creation. But to make search work, I have to add lines to LocalSettings.php and execute 3 commands in the end of this instruction: mw:Wikibase/Suite#Instructions_5

Reply to "Search is not working"
Yurik (talkcontribs)

It seems this page misses one critical piece of info - which repo(s) to clone to get started. It talks about locally available code as a given.

Dan Shick (WMDE) (talkcontribs)

The process doesn't involve cloning a git repo. Under Wikibase/Docker#Preparing your environment you'll see instructions to examine and modify the example files, which you will then use with Docker to launch your instance.

Yurik (talkcontribs)

@Dan Shick (WMDE) I saw that -- but that doesn't explain from which files one should start! I.e. given a blank slate, which git repo should i clone, or which files should I create and where to get to the running state. I could run "docker run ..." to get some container running, but the moment you switch to docker-compose, one should probably have some local config files, or possibly a locally modified clone of some repo.

Dan Shick (WMDE) (talkcontribs)

Please refer to the "Before you start" section. The process relies on your familiarity with docker-compose to recognize how to use the docker-compose.yml file in the examples directory. The instructions that follow explain how to modify that file.

Yurik (talkcontribs)

@Dan Shick (WMDE) I have used docker-compose for many years. My point is about those files - should I just copy that one file from the example directory? Should I clone the whole repo and just use that one dir?

Dan Shick (WMDE) (talkcontribs)

Glad to hear you're familiar with docker-compose. As the instructions indicate, you should use the example docker-compose.yml file, the template.env file, and, optionally, the docker-compose-extra.yml file, customized for your own install.

The docs take their time explaining things in detail -- our intention is not to provide ready-to-run docker-compose files, but to explain to experienced users such as yourself how to construct your own based on our examples.

Abbe98 (talkcontribs)

Came here with the same question. The docs could need some work.

Reply to "Missing GIT link" (talkcontribs)

I would like to link Wikidata items on my local wikibase to pages on my Wiki. I understand that I need to run the addSite script. I have done that but I cannot seem to find the right settings for the SiteID for it to be recognised.

I have tried both AddSite and importSites using these settings:

<sites version="1.0" xmlns="http://www.mediawiki.org/xml/sitelist-1.0/">

   <site type="mediawiki">



       <path type="page_path">http://192.168.xx.yy/wiki/</path>

       <path type="file_path">http://192.168.xx.yy/</path>



When I try to Set Item Sitelink I get:

The site ID "mywiki" is unknown. Please use an existing site ID, such as "enwiki".

Please can you describe how I can determine and set the globalid / SiteID. I am running a wikibase docker implementation.

Valerie Wollinger (WMDE) (talkcontribs)


Hey, thank you for letting us know. We will find out how to help you best in this regard and come back to you soon! (talkcontribs)


Ok, awesome thank you.

The OAUTH setup for QuickStatements needs to be described too. I needed to propose a consumer, grab the keys, approve the proposal, paste the keys into various places, restart, then I realised that oauth.ini did not exist. Grabbed a copy of that from a previous release and placed in /quickstatements/data.

I had to hard code the credentials into oauth.ini as the environment variables in .env were not picked up but something else is wrong:

<br /> <b>Fatal error</b>: Uncaught Exception: Error retrieving token1: {&amp;quot;error&amp;quot;:&amp;quot;mwoauth-callback-not-oob-or-prefix&amp;quot;,&amp;quot;message&amp;quot;:&amp;quot;oauth_callback must be set, and must be set to \&amp;quot;oob\&amp;quot; (case-sensitive), or the configured callback must be a prefix of the supplied callback.&amp;quot;,&amp;quot;callback&amp;quot;:&amp;quot;192.168.xx.yyy:8840\/api.php&amp;quot;} in /var/www/html/magnustools/public_html/php/oauth.php:289

Stack trace:

#0 /var/www/html/quickstatements/public_html/api.php(123): MW_OAuth-&gt;doAuthorizationRedirect('192.168.xx.yyy:...')

#1 {main} thrown in <b>/var/www/html/magnustools/public_html/php/oauth.php</b> on line <b>289</b><br />

All looks ok at mediawiki OAuth though.

Would be awesome to get this sorted for when 1.39 Wiki for Docker is packaged, if not sooner. Thanks for this though, amazing stuff.

Reply to "How to AddSite"

.sh files should be downloaded as well?

VeniVidiVicipedia (talkcontribs)

The jobrunner-entrypoint.sh script is not mentioned in the instructions.

It seems to be needed to get things working (at least on windows it does).

Otherwise a directory with the same name is created and an error occurs.

When using the docker-compose.extra.yml the extra-install.sh is needed/used.

This script seems to be less essential as no errors occur at all.

Valerie Wollinger (WMDE) (talkcontribs)


Hey, we will forward your questions to our technical team and get back to you shortly.

Valerie Wollinger (WMDE) (talkcontribs)


could you give us more background information? We need to know more about your configuration files, details of where you are running it and what you are trying to do.

VeniVidiVicipedia (talkcontribs)

@Valerie Wollinger (WMDE)

O wait it does work =)

Even though the wikibase_jobrunner-1 is failing and restarting.

I'm following these instructions

That means there are two files when I do docker-compose up -d:

- .env

- docker-compose.yml

The container with the name "wikibase-test-wikibase_jobrunner-1" (image: wikibase/wikibase-bundle:1.36.4-wmde.8) has the following logs

/jobrunner-entrypoint.sh: /jobrunner-entrypoint.sh: Is a directory

/jobrunner-entrypoint.sh: /jobrunner-entrypoint.sh: Is a directory

Additional information:

- docker desktop: v4.12.0

- docker engine: v20.10.17

Is this enough background information?

Reply to ".sh files should be downloaded as well?"
There are no older topics