Talk:Semantic Bundle

Jump to: navigation, search

About this board

This talk page switched to using LiquidThreads in 2012; before then, discussions were done via regular wikitext. You can find all these old discussions in the discussion archive.

2003:C3:CBEA:C8F5:64BE:B50:3CC2:45F2 (talkcontribs)

Why is the SemanicBundle offered for download at Special:ExtensionDistributor when the downloaded file contains nothing but a few php setings, but none of the extensions that are shown here on the help page. As always with Mediawiki, the instsallation process and documentation are ABSOLUTELY BULLSHIT.

Yaron Koren (talkcontribs)

I agree that Special:ExtensionDistributor is not good for most extensions - or for this bundle. I wish there weren't so many links to it everywhere.

Reply to "unusable for non-professionals"
Tenbergen (talkcontribs)

Hi Yaron,

I installed the newest version of MW a few days ago and am now realizing that something in there is messing with at least some of the SMW functionality. For example, I can no longer get a link to properties from the property browser, and the SMW elements are no longer listed in the advanced search. Internet Search tells me that a bunch of things have changed and that with the Bundle I am a full version behind the current SMW. I used the bundle in the first place because we are in a shared hosting environment and I don't have the access to use Composer. So, I was wondering... do you think you will get to updating the Bundle in the next little while?

Thanks!

82.5.22.54 (talkcontribs)

I too am getting this error, would love to know if there's a fix or a workaround.

Tenbergen (talkcontribs)

I believe a lot of that got fixed when I installed the newest version of SMW manually rather than using the bundle. It was a little tricky but doable.

Iamacyborg (talkcontribs)

Did you do a fresh install or did you update SMW? I tried updating to the newest version but saw a ton of errors and had to revert the process. Would love to know what you tried to fix it!

Tenbergen (talkcontribs)

If I remember right I just got rid of all files and reference of the bundle and installed SMW fresh. That (and possibly other steps, can't remember) got rid of the errors. Since all the information is stored in markup in the DB it picked up pretty clean. Possibly after running rebuildData.php. However...

I upgraded MW at the same time, and had to mess with another extension that is no longer supported, and between all of that, our MW seems to no longer update categories etc as promptly as it used to. I have a crontab for both runJobs.php and rebuildData.php (think that's what it was called) running each night and that seems to have things settled the next day, but it's not a satisfying solution.

I don't get the impression that the bundle will receive any more TLC, I'd suggest trying it again.

Iamacyborg (talkcontribs)

Thanks, that's definitely a solid pointer, will give it a bash over the coming week. Really appreciate you taking the time to talk through the process you used!

Reply to "SMW fails with new version ot MW"

Installation via GIT: make throws 403 errors for some included packages/extensions

1
Achimbode (talkcontribs)

Hi Yaron,

I tried to install SemanticBundle in a MW 1.27.1 via GIT. I know the instructions say "WARNING! This is experimental!", but I keep getting 403-Errors when I do "make" in the console. Is this part of the "experimental" thing? I scrutinized my firewall settings, but they don't seem to be the problem - while phabricator.wikimedia.org looks splendidly up and running to me.

Here's some of the errors during the make process:

HEAD is now at abb1156... Update INSTALL

rm: "." and ".." may not be removed

Cloning into 'SemanticForms'...

fatal: unable to access 'https://phabricator.wikimedia.org/diffusion/MEXT/extensions.git/SemanticForms.git/': The requested URL returned error: 403

Cloning into 'SemanticFormsInputs'...

fatal: unable to access 'https://phabricator.wikimedia.org/diffusion/MEXT/extensions.git/SemanticFormsInputs.git/': The requested URL returned error: 403

Cloning into 'SemanticCompoundQueries'...

fatal: unable to access 'https://phabricator.wikimedia.org/diffusion/MEXT/extensions.git/SemanticCompoundQueries.git/': The requested URL returned error: 403

Cloning into 'SemanticDrilldown'...

Other packages like ParamProcessor, Validator, SemanticExtraSpecialProperties, etc., clone nicely and don't throw errors.

Has that happened to others, too? Any hints?

No hurry, there are alternatives - I was just wondering...

Thanks and all the best, Achim

Reply to "Installation via GIT: make throws 403 errors for some included packages/extensions"
86.126.160.220 (talkcontribs)

Hi Yaron,

I'm sure you're busy, but just asking if a new version of semantic bundle will be out soon...

This one is not compatible with the latest MW 1.27 (had issues with semantic forms) :)

Also if I just copy and paste latest SMW and semantic forms over in this semantic bundle will it work?

Thanks so much!

Yaron Koren (talkcontribs)

As you know, I haven't upgraded Semantic Bundle in a long time... I do want to do it, but I don't have any immediate plans to. If you can install SMW yourself, I would just install all the extensions that way.

86.126.160.220 (talkcontribs)

Thanks so much!

Reply to "New Version"
Mhadihedayati (talkcontribs)

I am new in semantic mediawiki, I have installed mediawiki over the wamp, after that I downloaded semantic bundle and it is extracted. I copied the extracted folder to mediawiki pasted inside extension folder.

what to do the rest?

Reply to "urgent help needed"
Перевод15 (talkcontribs)

Please add this page to translate

Reply to "Please add this page to translate"
The Patriot Woodworker (talkcontribs)

Good day Yaron, reading some of the comments below it appears there is an updated Semantic Bundle that should be out soon? Or is it already out? The downloads at the "Page" appear to be for MW 1.92 ? Any help is greatly appreciate Yaron, and thanks again for your hard work!

Yaron Koren (talkcontribs)

Not yet, unfortunately.

Fustbariclation (talkcontribs)

Is there any news about this yet?

I'm having a lot of trouble upgrading to 1.25.2 some helped by this page.

What puzzles me about the Semantic Bundle is that it's supposed, at least I thought it was supposed, to be for people who have problems using composer (usually systems hosted on CPANEL [as mine is]), but the documentation now says it relies on validator, and some others, being installed with composer - which defeats the object of the exercise.

What I've tried to do, to work around this, is to use composer to install the required stuff on my own machine, along, then, with the semantic bundle - then copy the whole lot up onto the CPANEL machine. Despite this, I'm still struggling.

Jwes115 (talkcontribs)

Same error here - database error 500 when installing SemanticBundle. Have been trying to do this for months now since I had issues with Composer and basically gave up trying to extend by Wiki install, though I'd really love to work with this if anyone has a solution.

Reply to "Semantic Bundle For MW 1.25.2"
JeremiPlazas (talkcontribs)

Hi Yaron,

Thanks for all the hard work on this. I was wondering what the correct process would be to remove SB and go back to installing extensions one at a time, using Composer when possible?

Thanks so much.

Yaron Koren (talkcontribs)

Just comment out, or remove, the relevant line in LocalSettings.php.

JeremiPlazas (talkcontribs)

Hey Yaron, back to this thread.

I've been trying to remove the Semantic Bundle settings, transfering all the extensions call onto the LocalSettings.php file. And it all works out except for one setting that I can't comment out without breaking the wiki.

$classMap = require_once( "$IP/extensions/SemanticBundle/SB_AutoloadClassmap.php" );

foreach ( $classMap as $className => $fileName ) {

$wgAutoloadClasses[$className] = $fileName;

}

This was originally in the SemanticBundleSettings.php file. But somehow without it, the wiki breaks. Currently I moved it to the LocalSettings file so I could comment out the call for the SemanticBundleSettings.php all together, but this setting is still calling a SemanticBundle file, which I'm not finding a way around.

Do you know anything about it?

Reply to "Removing Semantic Bundle"
130.83.165.129 (talkcontribs)

Hi,

I just updated my mediawiki from 1.16.5 to 1.25.2.

To stay up to date I also downloaded the new Semantic-Bundle tarball and unzipped it in my extensions folder.

I enabled it with require_once( "$IP/extensions/Validator/Validator.php" ); in my LocalSettings.php

After this didn't work because of ParamProcessor being missing I downloaded that tarball and unzipped it too.

I also enabled it using require_once( "$IP/extensions/ParamProcessor/src/Processor.php" ); where I'm not sure if this is correct.

Ultimately it gave me more errors than before. I now get lots of these for newly installed ParamProcesser:

PHP Warning:  Class 'ParamProcessor\\ParamDefinitionFactory' not found in /var/www/mediawiki-1.25.2/extensions/Validator/Validator.php on line 79

And lots of these which I had before already:

PHP Warning:  Class 'SMW\\Store' not found in /var/www/mediawiki-1.25.2/extensions/SemanticMediaWiki/SemanticMediaWiki.php on line 60

Any ideas here?

I would like to avoid using composer.

130.83.165.129 (talkcontribs)

Since I don't seem to be able to edit my initial post:

I am running Ubuntu 12.04.5 with PHP 5.3.10 and mysql 5.5.44

130.83.165.129 (talkcontribs)

Well.. okay.

Issue was simply my old config-file which I copied without checking.

Obvously there has been an update to it which makes old config-files invalid.

Took the sample of the new version and made some changes I needed - works.

129.215.210.114 (talkcontribs)

Which Config file specifically? I am having this same problem.

Reply to "Class not found on 1.25.2"

Installation Error: (requires change to SB distribution)

2
Summary by WmBliss

RECOMMENDATIONS: 1) Before running it, edit SemanticBundleSettings.php to remove the erroneous include_once call to SemanticTasks. 2) Run update.php before accessing the wiki.

WmBliss (talkcontribs)

Installation, at first, seemed to be ok, The "Initialize or upgrade tables" button worked fine, and the extensions show up in Special:Version, but I now have a ...

"A database query error has occurred. This may indicate a bug in the software." error, and no page output.

PROBLEM: It seems the tar file extractor did not create the SemanticTasks directory, and the SemanticBundleSettings.php initialization file tried to crank-up this non-existing extension (at line 67).

I tried simply commenting out the call to initialize SemanticTasks but that didn't work.

PROBLEM RESOLVED: running update.php seems to have fixed the problem

RECOMMENDATIONS: 1) Edit SemanticBundleSettings.php to remove the erroneous call to SemanticTasks. 2) Run update.php before accessing the wiki.

Yaron Koren (talkcontribs)

You should add "$wgShowSQLErrors = true;" to LocalSettings.php to see the DB error.