Talk:Content translation

About this board

Please provide feedback about the Content translation tool on this page.

We suggest checking the Frequently Asked Questions page first.

When reporting a bug, it will help a lot if you will indicate the following things:

  • Which article were you translating and to which language
  • Which browser did you use (Firefox, Chrome, Microsoft Internet Explorer, Safari, Opera, etc.)
  • If you're getting any errors, please provide log from browser console if possible. To open browser console: press Ctrl+Shift+j (or cmd+alt+J () on a Mac).

In case you are familiar with Phabricator, please consider reporting a bug there.

See also:

2001:861:5700:9E70:60B0:2AC0:AFBF:F969 (talkcontribs)

Hi ! I'm curently translating articles about video games and have a question : when "translating" an infobox, the data is kept only if the parameter in English and French are exactly the same. Is there a way to match French parameters to equivalent English parameters to facilitate the "translation" ?

Reply to "Infobox keeping data"

Content translation in sister project

1
MdsShakil (talkcontribs)

Hey Developers, Content translation is able to support sister project? (Likes Wikibooks/Wikivoy)

Reply to "Content translation in sister project"

First experience leaves me puzzling

2
Martinus KE (talkcontribs)

After my first session with this tool, I've got two crucial questions:

'''(1)''' Traditionally, articles from another Wikipedia had to be "imported" first, for reasons of license compliance. Otherwise, the translation would basically be copyright fraud. – '''Does the tool take care of this automatically?''' Does it import the foreign-language article history into the history of the new target-language article? That would be really helpful.

'''(2)''' I just completed my first (short) translation and saved it to my user namespace. However, on the corresponding path in DE-Wikipedia, I am told that the page does not exist.

Of course, I could reload the page into the translation tool. But that's not what I want to do. I want to do further editing in the source, to expand and enhance the article.

If that's not possible, let's just forget about the tool. Then, it's just overly simplistic to be practical for my purposes and working habits.

So, '''where do I find the file?''' (If it cannot be accessed in the required way, it does not matter. Then, just let's forget about it. I also have a full draft on my hard drive.)

By the way, I miss a Preview button on this Talk page. I also miss the Switch button which a pop-up tells me to click to enable Wiki markup. -- ~~~~

Amire80 (talkcontribs)

(1) License compliance is ensured by forcing a hyperlink into the edit summary of the published revision, according to section 7bi of the Wikimedia Terms of Use and section 4(c) of the CC-BY-SA license.

(2) Did you publish your translation by clicking the Publish button ("Veröffentlichen")? I don't see a published revision anywhere in the contributions under this username. Your translation is automatically saved, and you can access it by going to Contributions -> Translations (Beiträge -> Übersetzungen) and clicking on its title from the "In progress" ("In Vorbereitung") tab. It becomes a full-fledged wiki page only after you publish it.

Reply to "First experience leaves me puzzling"

Default to empty box on "automatic translation failed"

3
Hjk321 (talkcontribs)

I am currently trying to translate English articles to Simple English. For obvious reasons, machine translation does not work here. However, when I click "add translation" I simply get a message saying the translation failed, and I cannot type or begin the process at all. It still forces me to try again to "add translation" per-paragraph, which, again, doesn't work. This is clearly an oversight and a regression from a few years ago when I remember it working properly. Please fix. Thanks.


Edit: There seems to be a "copy original content" option but even now I have no idea how I managed to find it. Perhaps it should be more visible? Pop up on a failed translation?

Santhosh.thottingal (talkcontribs)

Is this happening to all translations or any specifc article? The "copy original content" is the default option for English-> Simple English. When you click on "Add translation", this must be the option applied there. See screenshot Is it possible to look at the developer console and tell the error if any when you get errors(Right click->Inspect, goto Console)?

Hjk321 (talkcontribs)

I can no longer reproduce the issue I was experiencing. Sorry.

Reply to "Default to empty box on "automatic translation failed""

Feedback on experimental FLORES MT for yue

2
H78c67c (talkcontribs)

FLORES is horrible and unusable for translating to yue. Its quality is comparable to Bing Translator.

This is my feedback on FLORES after trying it out to translate a few sentences from en to yue.

  1. FLORES fails to translate common punctuation marks, including commas.
  2. Unlike Google Translate, FLORES completely fails to generate anything grammatically correct.
  3. FLORES only occasionally uses a few yue words, with most output being in jumbled zh-hant.
UOzurumba (WMF) (talkcontribs)

Thank you, H78c67c, for your feedback. We have notified FLORES of the issues you pointed out and they are looking into it.


Best regards

Reply to "Feedback on experimental FLORES MT for yue"

Old versions of translations!

3
Dr-Taher (talkcontribs)

I translated an article and published it. After a while there were updates to the source article, When I try to translate the new version, I have a message telling me that "This is an old version of the article"!, and the old translation is loaded. There is no option to update the source in order to be able to translate the new version. I have deleted the "translation" and try to translate the article again, but I have the same message!

ArchaeoData (talkcontribs)
Dr-Taher (talkcontribs)

Hello @ArchaeoData: I try now, I find a new option to (Restart Translation), When I press it I have a message telling me that (A new translation will start to the latest version of the page, all changes will be lost.)

Reply to "Old versions of translations!"
Sabelöga (talkcontribs)

I recently wanted to substitute a date using this <code>{{subst:CURRENTDAY}} code. This didn't get substituted. Does it need to be in all caps or is this a bug?

Reply to "subst: not working"

Doesn't attach to Wikidata anymore?

4
EdoAug (talkcontribs)

Hi! I've noticed that in the previous translations I've done (From English or NN to NO/Norsk bokmål), the articles have not been attached to any Wikidata item, and I've had to manually attach it myself. I swear that the tool used to attach the translated page to the original page's Wikidata item automatically upon completion. Is this an intentional change? Thanks.

1234qwer1234qwer4 (talkcontribs)

I strongly doubt this is intentional. Maybe better to report to Phabricator.

EdoAug (talkcontribs)

Ah! I see. I'm unfamiliar with Phabricator, but I believe this entry might be relevant for this issue?

1234qwer1234qwer4 (talkcontribs)

Ah, great, thanks for looking. Indeed, seems to be the relevant task.

Reply to "Doesn't attach to Wikidata anymore?"

Translation can not be published because there is too much of unedited text.

2
Tom.mahi (talkcontribs)

I have just used the wiki translation tool to translate a wiki page from English to Slovak. I checked the translated text and found out the tool translated text so good that I did not need to edit it, I only did few minor changes. Even though the text is good I am not able to publish the article, because I get error which says the text is unedited. How do I override the error? Do I need to rewrite the text just to satisfy some algorithm? That would not help at all. I am also trying to mark problems as solved, but it does not seem to register my mark.

I would also like to keep references and quotes from translated page, I am not sure if they are going to be transferred - anchors are kept by translator.

Translation is from English to Slovak

Tom.mahi (talkcontribs)
Reply to "Translation can not be published because there is too much of unedited text."

Could this tool remove the hidden or tracking categories automatically?

3
迴廊彼端 (talkcontribs)

As title, because these categories should track the local templates or modules, the hidden or tracking categories from the original language is unnecesary such as the "Category:Articles with hCards" of https://zh.wikipedia.org/w/index.php?title=%E9%AB%98%E5%A1%94%E5%A7%86%C2%B7%E9%98%BF%E9%81%94%E5%B0%BC&diff=71022090&oldid=71022038. Moreover, please fix it on both Content translation and Content translation V2, Thanks.


1234qwer1234qwer4 I've hidden the same topic on V2 talk page. please don't remove this topic.--~~~~

1234qwer1234qwer4 (talkcontribs)

Though there is still Topic:Wtz0g5axi1e9es69. I wonder what would be the best way to detect such categories programatically (hidden should be relatively simple, not sure about tracking though).

迴廊彼端 (talkcontribs)

I've hidden it, too. Thank you.

Reply to "Could this tool remove the hidden or tracking categories automatically?"