Talk:Content translation

Jump to navigation Jump to search

About this board

Please provide feedback about the Content translation tool on this page.

We suggest checking the Frequently Asked Questions page first.

When reporting a bug, it will help a lot if you will indicate the following things:

  • Which article were you translating and to which language
  • Which browser did you use (Firefox, Chrome, Microsoft Internet Explorer, Safari, Opera, etc.)
  • If you're getting any errors, please provide log from browser console if possible. To open browser console: press Ctrl+Shift+j (or cmd+alt+J () on a Mac).

In case you are familiar with Phabricator, please consider reporting a bug there.

See also:

You cannot publish the article

1
Neghasht (talkcontribs)

You can not publish the article because you used an emoji, but after deleting the emojis you still get the error message.

Reply to "You cannot publish the article"

Automatic edit filters have identified problematic content in your translation. Filter hit: Бос бет3

2
5.227.122.29 (talkcontribs)

Automatic edit filters have identified problematic content in your translation. Filter hit: Бос бет3

1234qwer1234qwer4 (talkcontribs)

Unrelated to content translation. Report at local edit filter false positives.

Reply to "Automatic edit filters have identified problematic content in your translation. Filter hit: Бос бет3"

Annoying scroll jump to top while typing first paragraph

30
Pabloab (talkcontribs)

I'm trying to translate "Lactarius subdulcis" (en to es). I'm not sure if related to infobox (which I'm unsure if will be translated, translation of infoboxes always was a problem, should let me the alternative to create it on destination language if it's not there) but as soon I try to fix some problems of the automated translation the scroll keeps jumping to the top of the document. The document jump back and forth from where I'm typing to the top, so I have to practically blindly type everything and then scroll to the section to see if everything went fine. Something odd is that this happens only on the first paragraph, on all the other sections of the document scroll doesn't jump to the top.

Всевидяче Око (talkcontribs)

Hi!

For help your, need more information.

When reporting a bug, it will help us a lot if you will indicate the following things:

  • Which article were you translating and to which language
  • Which browser did you use (Firefox, Chrome, Microsoft Internet Explorer, Safari, Opera, etc.)
  • If you're getting any errors, please provide log from browser console if possible. To open browser console: press Ctrl+Shift+j (or cmd+alt+J () on a Mac).

In case you are familiar with Phabricator, please consider reporting a bug there.

Pabloab (talkcontribs)

I was translating Lactarius subdulcis from English to Spanish (en to es), with Chrome 85.

Next time I'll add the relevant console log.

It's not clear to me when I should post the issue here and when directly on Phabricator.

Всевидяче Око (talkcontribs)

HI! If Your place issue in Phabricator, you don't need place here.

With respect

AquAFox (talkcontribs)

Same problem here. I'm using Chrome browser in Windows 10, translating en→ko.

when I write a word for translating long document, often scroll jumping. this problem occured seems from 3 months ago.

I hope solve this problem as soon as possible.

Haziq Faruqi (talkcontribs)

I'm having that problem too. I'm on Chrome browser, translating en - ms and it happens on all articles I'm translating. It's been like this for months on all computers I have, even my father's new laptop.

Hope this stops soon.

1234qwer1234qwer4 (talkcontribs)
Zaschid (talkcontribs)

I have the same problem.

Ynneblack (talkcontribs)

I ran into the same issue, both with the infobox (it just doesn't transfer at all, but doesn't let me rewrite it manually) and with scrolling. English > Czech.

42.200.187.185 (talkcontribs)

Yeah same problem, using Chrome, translating en - zh.

Somar1987 (talkcontribs)

i also have the same problem while translating from EN to AR

Euro know (talkcontribs)
1234qwer1234qwer4 (talkcontribs)

Thanks, the topic you linked suggests this is already worked on, see Phabricator.

Всевидяче Око (talkcontribs)

+ )

1234qwer1234qwer4 (talkcontribs)
1234qwer1234qwer4 (talkcontribs)
1234qwer1234qwer4 (talkcontribs)
1234qwer1234qwer4 (talkcontribs)
1234qwer1234qwer4 (talkcontribs)
1234qwer1234qwer4 (talkcontribs)
Charlestpt (talkcontribs)

Hello, I've had this problem on hundreds of translations over months (en -> fr, Brave Browser/Chrome on W10, nearly all the time). It's so potent that I've learned to live with it and to regularly scroll back, but it would be nice if it was patched, yes. Regards,

1234qwer1234qwer4 (talkcontribs)
Alex Blokha (talkcontribs)

Still have this problem. Browser: Chrome. UBlock is on.

1234qwer1234qwer4 (talkcontribs)
1234qwer1234qwer4 (talkcontribs)
Greatder (talkcontribs)

Reproducable on all infobox page in mobile version.

C messier (talkcontribs)

It appears everytime you skip moving a paragraph, the infobox, a table or even just a photo from the original text to the translated , right above the paragraph you are translating, not just the first one. I use chome and have faced the same problem in hundrends of translations from english, german and french to greek.

Alex Blokha (talkcontribs)

Wikimedia have dozens millions of dollars on account, but can not give money to translator.

Greatder (talkcontribs)

Off topic, this is about software issue

1234qwer1234qwer4 (talkcontribs)

What exactly is off-topic?

Reply to "Annoying scroll jump to top while typing first paragraph"

Colbegin and Colend refusing to get translated

1
C messier (talkcontribs)

I noticed that while trying to translate Atomoxetine from english to greek using Chrome, the lists using colbegin and colend couldn't be moved from the english text to the translation to greek area with just clicking on them. I managed to do it manually. Then I translated one of them by clicking on it, but apparently it didn't get stored and when I opened the translation again the translated columned list was back in english.

Reply to "Colbegin and Colend refusing to get translated"

How to delete a translation completely or restart it?

6
McYata (talkcontribs)

I left one of my translation for a long time, so an alert which states "This translation is based on an older version of the content. The source page may have changed significantly, and you may want to restart the translation." appears.

Then how to "restart" it? I tried deleting the translation many times, seeing the caution "Are you sure you want to permanently delete this translation?" but every time I "delete" it and restarted as "New Translation" the old uncompleted translation appears again with the alert above.

Actually I asked similar question here 2 years ago but haven't find the answer yet. How to delete the translation literally "permanently" or what to do when I "want to restart the translation"?

Tomchen1989 (talkcontribs)

Yeah I have exactly the same problem. It seems to me that, when someone starts a translation from "en:A" to "yourlang:A" with Content translation tool, the Content translation tool caches the content of "en:A". Even if you delete your translation draft and start a whole new translation, the Content translation tool still uses the old, cached content of "en:A". I don't see any button to delete the cache.

Tomchen1989 (talkcontribs)
Tomchen1989 (talkcontribs)
Euro know (talkcontribs)
McYata (talkcontribs)

Maybe I have to restart the translation 1 year later from now...?

Reply to "How to delete a translation completely or restart it?"
DeusPatriaRei (talkcontribs)

We need an option to switch the page to the source-code, sometimes the predefinitions simply doesn't work and there's no way to fix it before posting the page. So if we had an option to edit through the source-code (before posting) it would be helpful!!!

Reply to "Suggestion for the tool"

Suggestion: new translator tool, DeepL

2
Misibacsi (talkcontribs)

Hello


I strongly recommend using the DeepL software, which gives much better quality translated text than the currently used tools. It has a limit of 5000 characters, but you can avoid this limit, if you cut the original long text into more pieces.

It supports 26 languages at the moment.

It can be used in Windows environment, and requires to install a piece of software to your personal computer.

It is independent from the browser you use, it can be used without browser, on any selected text.

I use it for more than a month on a daily basis, and I am happy to use it. Of course, the translated text requires some proofreading and some corrections, but with less work than with the current tools.

Sometimes I use it on "source view", so the links will be also translated (more or less modification needed). The "ref"s remain in their original form.

Greatder (talkcontribs)

For the languages that deepl supports I think the wikimedia foundation should pay the 5$+/month and use it for translations. It's simply too good to ignore. --~~~~

Reply to "Suggestion: new translator tool, DeepL"

Hyphen minus turns into emoji-snowman

9
Omotecho (talkcontribs)

A particular character is replaced by emoji on Safari_CX2, with_snowman. iOS 13.7, iPhone 6s Plus model MKU72J/A.

  • Snowman emoji replaced hyphen minus, or – character;
  • Translation original as: :de:Großkomtur_(Ordenskunde) &oldid=203310426
  • Language pair as de-ja.
  • The sentence matching was seen rearranging a split of second before the characters were replaced. I usually don’t apply de-ja language pair, and not sure what was not working.
  • FYI, it happened more than 20 months ago when I was on Win notebook, using CX2 on Firefox as well. That time the problem rather happened without common condition.
YTRK (talkcontribs)

Could you clarify the very last part? Is this the second time that this sort of thing happened?

Omotecho (talkcontribs)

Yes, in the past I have experienced the same phenomenon several times, but situation varied: maybe as below in the sequence of input. Sorry I can’t recreate it on my Win PC as it is not functioning anymore (got dropped into water).

Wish I could be more specific. On iPhone, how do we retrieve the log on Safari? I tried how-to websites, but couldn’t find the procedure.

Addendum: this time, I recalled that I changed one character before the incident: The section after "top section", the second Chinese character which shows in the screen shot as "労". Guess the return key after I input that character could have triggered the error.

1234qwer1234qwer4 (talkcontribs)
Omotecho (talkcontribs)

Visually, yes, they are identical as I see in your sample as I copied below, but not sure if the edited contributor was aware of that. Not sure exactly what causes those snowman e-moji pops in....

  • and 1 Type III or 2 Type II or 2 Type I PCMIA slots.☃☃
Arlo Barnes (talkcontribs)
1234qwer1234qwer4 (talkcontribs)
Omotecho (talkcontribs)

FYI, I commented on @Euro know’s input at @Arlo Barnes’ link Topic:Vvg7f52m3q4zqzic if they would input what triggered two emoji-Snowman. Either here or at the above link.

My working environ If it helps; I link via BlueTooth a keyboard to iPhone 6Plus S as:

  • Model: MKU72J/A, OS: 13.7; Safari (when bug occured);
  • keyboard: elecom TK-DCP02

Chhers,

Greatder (talkcontribs)

I thought I was hacked, thankfully seems like a wiki issue: MobileCoin edit 1028545152(it thinks I am link spamming)

I was using browser mobile editing going from source editing to visual, after that I made the citation with the citation button then the text got copied and replaced with these creepy snowmen.

--~~~~

Reply to "Hyphen minus turns into emoji-snowman"

My text is constantly jumping out of view

2
Bertux (talkcontribs)

Hi, I am translating ru:Daimler Motorkutsche, which has a large infobox with no Dutch equivalent. That (or something else) makes my text constantly jump up and down. Whenever I touch the arrow keys, insert a link, touch backspace or do whatever with the keyboard except typing, the infobox gets displayed, rendering my own text out of view.

What can I do to tame this nausea inducing behavior and what are the developers going to do to cure this bizarre Fawlty Text?

Btw, my computer is a 17'' chromebook with all the updates.

Update: I found a workaround: after trying in vain to type text beside the Russian box, I noticed the 'insert an alinea' prompt. Click! Then I filled the space with random text. This has normalised the behavior.

Still wondering why years of development didn't cure this ludicrous fault.

1234qwer1234qwer4 (talkcontribs)
Reply to "My text is constantly jumping out of view"

Please don’t output en-ja "Cat:Coordinates not on Wikidata"

1
Omotecho (talkcontribs)

It has been pointed out to me at ja Wikipedia that I have added CX2 output(s) to local wikipedia and added up unwanted :en:Category:Coordinates_not_on_Wikidata. Jawp, too, has an equivalent category, but unmanaged but expanding with translated articles; since wikipedias don’t share how we use coordinates, or enwp vs jawp. which should be prevented or such template will only snowball choirs for admins at jawp.

  • Proposal: CX2 will stop to output administrative templates from source to target language, and to be specific, Category:Coordinates_not_on_Wikidata;
  • Reason: admin tasks regarding Coordinates and wikidata is not a universal nor higher priority task on jawp; (1) source and target language communities not necessarily share tasks and goals regarding coordination of places-> wikipedia article(s)-> wikidata; (2) CX2 users are translators, and not necessarily specific about cleaning up CX2 output when it comes to categories; it is rather hard to notice that any category you tried to reflect on CX2 to target language or simply did not care, will be visible as if to push a dish to admins and serve extra task to solve;
  • Additional support/documentation: we lack documenting how category will function at CX2 introduction page; your good intention to output as many categories from source to target languages, you could end up adding ambiguous tabs to the original ; in this case ''wikidata needs somebody to give coordinates on Wikidata for the subject of a wikipedia article.
  • Advanced help: the geography wikipedians or cartographers will be invited to support the task to fill coordinates on wikidata, whenever a CX2-translated page indicates you need to add coordinates on wikidata; tutorial, or links to how-to or Help-pages an outline solution.
  • What was tried: to add coordinates to wikidata for the page I translated with CX2, but failed;
  • open issue: How do we know, then, if the target language. eg jawp, needs to know about a particular issue which they not necessarily need to look at (due lack of volunteers who cleans up that category). Which community holds the initiative to edit wikidata, at jawp or enwp in this case?
Reply to "Please don’t output en-ja "Cat:Coordinates not on Wikidata""