MediaWiki 1.3 comments and bug reports/Resolved

From MediaWiki.org
Jump to navigation Jump to search

This page contains some posts with issues that were resolved and moved here to keep the other page as short as possible. Feel free to move it back if you think the issue is still unresolved.

Post new section

Meta subpages[edit]

Please turn subpages back on for Meta's content pages please. See: Wikimedia PayPal donations for 2003. --mav 09:38, 22 May 2004 (UTC)

They seem to have been enabled. Dori | Talk 05:07, 23 May 2004 (UTC)

Where did the copyright notice go?[edit]

What happened to the copyright notice at the bottom of every page? --mav 10:03, 22 May 2004 (UTC)

It wasn't yet enabled. -- Gwicke 11:59, 22 May 2004 (UTC)


External links[edit]

While the new bracketed URL (in Cologne Blue, that is) after an external link will be useful for article pages, it should be suppressed for Wikimedia-internal projects. Take a look at Wikisource or Wikibooks' recent changes page to see how it looks.

Is there a currently implemented method to prevent this? Thanks Dysprosia 11:32, 22 May 2004 (UTC)

Yes, a reload (shift-reload in moz, ctrl-f5 IE/opera) will get you the new css that hides that part. -- Gwicke 12:09, 22 May 2004 (UTC)
Lovely! Thank you. Dysprosia 12:34, 22 May 2004 (UTC)

Community Portal[edit]

Under the "nagivation" heading, there is a link to "community portal" even on wikis that don't have a community portal, such as meta (a community portal on meta would be redundant). Perl 13:48, 22 May 2004 (UTC)

Setting MediaWiki:portal to '-' removes that link, same with MediaWiki:currentevents. -- Gwicke 14:21, 22 May 2004 (UTC)

timelines, but not chemistry or chess or music[edit]

I remember requesting inclusion of the en:Wikitex code to allow for creation of chemical diagrams with PPCHTeX, music with Lilypond and chessboards with... whatever. I was told that it needed security testing, that it wouldn't be included. Out of left field comes this <timeline> syntax, which is suddenly getting stuck in 1.3. What gives here? Chemistry diagrams are made with a huge variety of drawing packages, and uploaded as images, which means that they lose the wiki-nature. I was unaware of a burning need for image-maps to replace enumerated lists---why are we getting <timeline>, but not <chem>, <music> or <chess>? <chem>, at the very least, should be trivial to implement---it'll work fine with a whitelist of exactly one command! Grendelkhan 23:49, 22 May 2004 (UTC)

We have timelines because somebody volunteered to do the work to implement them. -- Cyrius 00:20, 23 May 2004 (UTC)

MediaWiki vs. Template: The Insubordination[edit]

MediaWiki 1.3 seems to be insubordinating: I made a page MediaWiki:GOOToc as a Table Of Contents header to be used in the Wikibook on Genealogy. However, when I put in {{msg:GOOToc}} into the page, it insisted on Template:GOOToc when it's a MediaWiki: page! 24.184.225.245 03:10, 23 May 2004 (UTC)

Custom messages now go in the Template: namespace. MediaWiki: is just for interface pages, and the custom messages will be moved to the Template: namespace. Dori | Talk 04:32, 23 May 2004 (UTC)
And use {{GOOToc}} not {{msg:GOOToc}}. -- Tim Starling 04:49, 23 May 2004 (UTC)
Thanks for the help. 24.184.225.245 14:09, 23 May 2004 (UTC)

MediaWiki:Portal[edit]

I changed the content in MediaWiki:Portal from - to Goings-on so that Goings-on could be linked in the sidebar, but the result is that it points to Meta:Community Portal (which does not exist). How can this be fixed? --mav 12:52, 23 May 2004 (UTC)

You need to edit MediaWiki:Portal-url. I did it so the Goings-on text now links to Goings-on. Perl 13:04, 23 May 2004 (UTC)
For future reference, in such cases, do a search in Special:Allmessages for what you're looking to change in the interface. Dori | Talk 13:05, 23 May 2004 (UTC)

Categories enabled but broken[edit]

Category links are enabled but the categorylinks table doesn't seem to exist on any of the updated wiki. For example take a look at Special:Categories and try to view the category "stub" - 211.28.160.221

The exact error returned (on meta, it is slightly different for the other updated wikis) is
A database query syntax error has occurred. This could be because of an illegal search query (see Searching Meta), or it may indicate a bug in the software. The last attempted database query was:
SELECT DISTINCT cur_title,cur_namespace FROM cur,categorylinks WHERE cl_to='Test' AND cl_from=cur_id ORDER BY cl_sortkey
from within function "". MySQL returned error "1146: Table 'metawiki.categorylinks' doesn't exist".
- 211.28.160.221

center and images[edit]

When a centered image is followed by centered text, there needs to be a </center> after the image and <center> before the text. In the old software, a centered image followed by centered text could be accomplished simply by putting a <center> in front of the image without needing </center> after the image and <center> before the text.

Unclosed tags are invalid, please close them. -- Gwicke 13:58, 22 May 2004 (UTC)
I tried closing the <center> tag and the problem still exists. After I have looked at the problem, I have found that it seems to be somwehat ignoring a skipped line in this case. I have made a subpage: User:Perl/centerproblem which illustrates the problem. Perl 14:13, 22 May 2004 (UTC)
The real reason for this problem was simply that the parser didn't create paragraphs inside the center div. This is changed now- the break is there, the text is centered as intended. -- 217.81.59.171 18:28, 22 May 2004 (UTC)


problem with interwiki links in the new theme[edit]

Interwiki links don't show up at all. Look at [1]. Perl 13:41, 22 May 2004 (UTC)

Actually, it turns out that the software must think the links are interlanguage links because it has "english" listed 8 times under the "other languages" heading on the left. Perl 13:45, 22 May 2004 (UTC)

For example, on the wikibooks portal, links to things from the English Wikipedia are interpreted as interlanguage links, making them disappear from the text and creating a bunch of English ILLs on the sidebar. PM 15:47, 22 May 2004 (UTC)

There is now a similar problem at Wikisource. In w:sources:Author:Thomas Jefferson and in all similar "Author" pages the biographical section was set up to show links to biographical articles on the various Wikipedias. There was never any intention to bunch them up at the top or bottom of the page. Eclecticology 21:07, 22 May 2004 (UTC)
Fixed now, interwiki links are inline on wikibooks, source, meta, wikiquote, sep11. No need to prepend : to make them inline there. -- Gwicke 02:16, 23 May 2004 (UTC)


UTF-8 chars[edit]

UTF-8 chears changes to "?" see [2] after 00:24, 20 May 2004 KIZU M (=日本語= KIZU IRS score) --Suisui 14:37, 22 May 2004 (UTC)

As I see it now, there seems to be no problem. Tomos 00:33, 23 May 2004 (UTC)


Database-related errors (linkscc table)[edit]

This may be a one time thing, but I had never seen it before. I was editing a section when this came up.

A database query syntax error has occurred. This could be because of an illegal search query (see Searching Meta), or it may indicate a bug in the software. The last attempted database query was:

    SELECT cur_text FROM cur WHERE cur_namespace=8 AND cur_title='Wikititlesuffix' LIMIT 1

from within function "". MySQL returned error "0: ".

Dori | Talk 15:16, 22 May 2004 (UTC)

I got the same thing trying to access the meta Main Page PM 15:47, 22 May 2004 (UTC)
Got the same error while trying to access Talk:Mainpage. User:Tillwe, not logged in

I got a similar error too. And from time to time this database error keeps coming up, while logging in, while accessing a module...

Vijay

I got this when I clicked on a thumbnail

From Meta, a wiki about Wikimedia
A database query syntax error has occurred. This could be because of an illegal search query (see Searching Meta), or it may indicate a bug in the software. The last attempted database query was:

    REPLACE INTO linkscc(lcc_pageid,lcc_cacheobj) VALUES(6708, 'x^��� �@�E�%�P:V�fV*(BAWn���18u���)�wS��\\�����d�s���Ka�3�LM�P�r&��ՠ�G:���n�/3 ���U�M&���X��[���6��d����(ə�����a�0M���oX��+�Fh*tQ��A����V%���j��[�27��~��S�5��9*�U\"t�ʿ�F���� �|l_')

from within function "". MySQL returned error "1213: Deadlock found when trying to get lock; Try restarting transaction".

When I clicked on another thumbnail, I recieved this error:


From Meta, a wiki about Wikimedia
A database query syntax error has occurred. This could be because of an illegal search query (see Searching Meta), or it may indicate a bug in the software. The last attempted database query was:

    REPLACE INTO linkscc(lcc_pageid,lcc_cacheobj) VALUES(6709, 'x^��� �0���%�0V\'��I�E��E��[����ڡ�ٻ�9P��1_~�?�q���v�Lu!��������x�\0�q�#�T�i�^���A5D�9�Λ��X���l�4��d�<��*� Nj>�8���y�\0ݏ�+���*6��Z�����Ы���>�cT�ͯMKu����p�!І�#�QeBsg����O��I�n�')

from within function "". MySQL returned error "1213: Deadlock found when trying to get lock; Try restarting transaction".

When I refresh the image: page, the image displayed as it should, so it might be a one-time-thing. Perl 13:10, 23 May 2004 (UTC) Perl 13:10, 23 May 2004 (UTC)


I don't know if this is related, but I changed Trophy box some minutes ago. The change was saved, but the changed page didn't load, waiting for several minutes only brought the "hide" field of the TOC into view, rest of the page blank (in Netscape 7.0). And something completely unrelated: the cursor in this edit box has a little dot on the top? -- Tillwe 18:48, 23 May 2004 (UTC)

Jeronim just found the reason for this: the linkscc table (used for permanent link caching) wasn't updated to the new DB link table schema that uses numerical ids for both keys:
mysql> describe linkscc;
+--------------+---------------------+------+-----+---------+-------+
| Field        | Type                | Null | Key | Default | Extra |
+--------------+---------------------+------+-----+---------+-------+
| lcc_pageid   | int(10) unsigned    |      | PRI | 0       |       |
| lcc_title    | varchar(255) binary |      | UNI |         |       |
| lcc_cacheobj | mediumblob          |      |     |         |       |
+--------------+---------------------+------+-----+---------+-------+
3 rows in set (0.00 sec)
Trivial to fix, we disabled linkscc for now, Jeronim is updating the conversion script to do the table conversion automatically on upgrade. -- Gwicke 22:04, 23 May 2004 (UTC)


Comparing versions is history[edit]

When trying to compare two versions of the page, those are placed inside the frame. Of course, this is not wide enough, so a slider appears at the bottom of the frame. But since the length of the frame is dynamic, this slider is far below the point where you're comparing the versions. This might also hold ordinary pages, if there is a way to make them too wide, eg. with a table. (What is wrong with this editor field. It wants to display a few pixels more than its wide.) Aliter 17:52, 22 May 2004 (UTC)

That's an extramely annoying IE bug, i've removed the full-width footer for 5.5 and 6 in favour of solid horizontal scrolling. All other browsers render this correctly and have the full-width footer. To get the new style, do a ctrl-f5. -- Gwicke 23:58, 22 May 2004 (UTC)

?? For example, to see this on an ordinary page, try. (I hope at least someone on Af: knew what was happening. Still the main page does show a problem with the templates. Anyone willing to help?) Aliter 17:29, 23 May 2004 (UTC)

Hmm, can you give me a hint what i should look for on af? -- Gwicke 20:52, 23 May 2004 (UTC)

Sure: The right edge of the table on. (If you can see that, due to your screen being wide enough, shrink your window a bit first, to simulate a smaller screen; if the window gets a horizontal scroll bar you've made it too narrow.) Try to look at the top left cell, and then find the page's scroll bar to bring into view the entire top right cell, and now to the next cell on the left .... Aliter 00:10, 24 May 2004 (UTC)

Did you try a shift-f5 to get the current css? Looks fine here at 1024x768 and smaller in Firefox and IE6. Please make a screenshot if the problem is still there and tell us your browser type and version. -- Gwicke 11:08, 24 May 2004 (UTC)

Yes, I did a refresh (several) when I tried whether the history, here on meta, now functioned correctly. When it did, I went looking for a wide page, which I found on af:. What is logical, but not intuitive, is that af: has its own copy of the style sheet, and needed to be refreshed separately. (Fortunately, not a problem that will occur in everyday use.) Yes, you did solve this on the first try! Problem solved. (The problem on the front page of af: I've now historied back to an apparently incorrect conversion of
"{{msg:{{CURRENTMONTHNAME}}_{{CURRENTDAY}}_selektiewe_herdenkings}}"
to the new system. Anyone?) Aliter 13:15, 24 May 2004 (UTC)


History, diffs, and the Compare button[edit]

Can we please get a second "Compare selected versions" button at the top of History pages? At least for me, the most common thing I want to do with arbitrary diffs is compare the most recent revision to one 4-5 revisions back. -- Cyrius 19:35, 23 May 2004 (UTC)

Added the second button, made it an input type="submit" for better styling. Reload to get the new styles if the first button has a list bullet in front of it. -- Gwicke 14:12, 24 May 2004 (UTC)
Works for me. Much better than having to scroll a couple of pages to find the button. -- Cyrius 21:38, 24 May 2004 (UTC)


<pre> behaviour broken[edit]

In order to keep this page tidy see bug example at MediaWiki_1.3_comments_and_bug_reports_pre

Fixed. -- Gwicke 11:15, 24 May 2004 (UTC)

Table problem[edit]

I noticed that the afrikaanse wiki has already been upgraded to the new mediawiki version. Volunteer Wearth]] reported a problem with table syntax in the upgrade, see w:af:Suid-Afrika.

Could some developer pls check before upgrading other wikis????

TeunSpaans 06:31, 24 May 2004 (UTC) (I must confess i dont see much of a difference myself, just made a test)

A second issue on this page is the "Nasionale leuse", as Andre Engels remarked, "!ke e: /xarra //ke" doesnt look like afrikaans, english, bantu, zulu or any african langue. This seems to be present in all older versions, so it might have been a human error. Is there any conversion software that may have caused this?

TeunSpaans 06:31, 25 May 2004 (UTC) (it's some unknown near-extinct language)

IE6 script errors[edit]

In IE v6-SP1, with "Display a notification about every script error" turned on, pages have this "error": line=19 char=16 error="'addcss' is undefined" code=0. --Zigger

Fixed by clearing the local cache. --Zigger 07:05, 30 May 2004 (UTC)

Already reported to sourceforge - status=pending. --Zigger 13:42, 30 May 2004 (UTC)

Showing URL for external links[edit]

In the Arabic Wikipedia, in May 28 (after the software upgrade probably), when using the Standard skin, the URL of links are displayed in perathesis after them. for example [http://linux.org Linux.org] is displayed as "Linux.org (http://linux.org)" showing the link right after the linked word. -- Isam 11:25, 28 May 2004 (UTC)

This issue is fixed now.. Thanks -- Isam 13:42, 28 May 2004 (UTC)

"It's" with bad apostrophe in alt text[edit]

In the alt text which displays when you hover over the View Source link on a protected page, it says something like "This page is protected. You can view it's source." This should be "its" not "it's" - the apostrophe needs to be removed, please. Thanks --82.35.17.203 23:22, 29 May 2004 (UTC)

I believe this is something all sysops can fix by editing MediaWiki: pages, so I'll look into it on. Guanaco 03:02, 30 May 2004 (UTC)
It's fine on. Guanaco 03:08, 30 May 2004 (UTC)
Not as I see it, it is not. The example page I am using is the Main page, so do tell me if that's wrong. I tried swapping browsers but it's the same in Opera which could not on my machine have had a cache of the previous state - it still says "it's" not "its" as it should. Sorry to be a drag. Should I move this out of "resolved" again? 82.35.17.203 11:38, 30 May 2004 (UTC)
I looked through the MediaWiki messages and found. See [3]. The meta version is still broken, however. Guanaco 12:45, 30 May 2004 (UTC)
Thanks for sorting out en. I was getting palpitations! :) --82.35.17.203 00:47, 31 May 2004 (UTC)

New Style (moved from Talk:Main Page)[edit]

  • The search option puts "$1" in the googlebox;.
    • OK now. Aliter 00:53, 30 May 2004 (UTC)
  • The logo has disappeared; without logo the left column is about half its height too far down.
    • The logo is now present. Aliter 15:57, 22 May 2004 (UTC)
  • IE 6 claims the pages has an (ignorable) error. (Might be the logo.)
    • Indeed, with the logo appearing, the error has disappeared. Aliter 15:57, 22 May 2004 (UTC)?
  • There appears to be an empty box at the bottom of the virtual page on the Main page.
    • Disappeared. Aliter 18:22, 25 May 2004 (UTC)

Mozilla Firefox 0.8[edit]

Search box error in Firefox 0.8[edit]

In Firefox 0.8 on Windows XP the Search boxes are messed up in the new format.


Here is a screenshot.Jeff8765 23:48, 24 May 2004 (UTC)

This happens if you have a minimum font size set in your prefs, you can either reduce the minimum font size (most probably by one point), select a larger default font in your browser prefs or change the font size or input width in your user stylesheet. -- Gwicke 00:17, 25 May 2004 (UTC)
Thanks. 67.20.46.9 02:20, 25 May 2004 (UTC)

Search function[edit]

Hey! What happened to the Search function that Wikipedia used to have? Why was it removed? Are there any plans to restore it? --Fibonacci 20:47, 29 May 2004 (UTC)

  • The search box is still there for me, just moved. It's now below the navigation box on the left-hand side of the page. Jrdioko 21:00, 29 May 2004 (UTC)

Superscript entities not rendering properly[edit]

On certain articles (specific example, the page on the main Wiki), HTML entities used to render cm^3 are appearing as text rather than rendering appropriately. The HTML I'm receiving actually contains an escaped ampersand followed by the text 'sup3'. One way of "fixing" this problem is to use proper entities, i.e. those terminated with a semicolon, but the above page did show properly before the switch-over.

Compare: cm&sup3 vs. cm³

ChrisCostello 01:40, 30 May 2004 (UTC)

That's the point - proper entities. They need to have an ending semicolon in order to be valid HTML entities but the semicolon was most likely cut-off by the conversion script. --Borislav 10:57, 30 May 2004 (UTC)
Ah, understood. I'll fix them wherever I run across them, then, unless there's some more appropriate way of going about this. ChrisCostello

Italy is a user?[edit]

The Italy article has User contributions and E-mail this user nav links Niteowlneils 21:32, 30 May 2004 (UTC)

Confirmed fixed. Yeah, Vibber! Niteowlneils 23:37, 30 May 2004 (UTC)

HTML comments displayed[edit]

All of a sudden, HTML comments preceding custom messages are now appearing in the articles! RedWolf 05:56, 30 May 2004 (UTC)

Well my problem seems to have suddenly gone away by itself. Gremlins, I tell you... RedWolf 08:07, 30 May 2004 (UTC)

Opera 7[edit]

This browsers use presentation style when site is in full screen. But wiki doesn't have this style and i see site without all formating. -- Adam Dziura

I believe this has been fixed; works for me in Opera 7.50. --Brion VIBBER 06:56, 1 Jun 2004 (UTC)

Mozilla-based browsers[edit]

With Firefox 0.8 (Linux and Windows) I have this problem even if there are no categories. Judicious use of the Web Developer extension and the DOM inspector shows that the "catlinks" div is present and getting in the way of the image. --rbrwr 12:03, 31 May 2004 (UTC)

Screenshot showing this problem
File:Coulthard screenshot outlined.jpg
Detail of screenshot with the "catlinks" div outlined


I have added div#catlinks {display:none;} to my monobook.css and the images float correctly to the right. It does, however, leave me unable to view category links when they do exist. --rbrwr 15:15, 31 May 2004 (UTC)

This has already been fixed. --Brion VIBBER 07:00, 1 Jun 2004 (UTC)

script error[edit]

Also, they often get a script error message on nearly every page, I got one too, after some browsing, invalid argument at line 153 of their homepage, char 5. Same on meta, by the way. WXP, IE6, display script errors turned on.

Can you provide an url for the page this happens on? -- Gwicke 17:17, 25 May 2004 (UTC)
<w:af:Tuisblad> (but at the moment it doesn't happen to me there). Aliter 18:51, 25 May 2004 (UTC)
Already reported to sourceforge. --Zigger 13:24, 30 May 2004 (UTC)
Already fixed. --Brion VIBBER 07:00, 1 Jun 2004 (UTC)

Vietnamese Wikipedia[edit]

The following two bugs are described in SourceForge bug #962789 (group #34373):

Errors for logged in users[edit]

Anytime I am logged on, and I view any page at the, I get the following error:

A database query syntax error has occurred. This could be because of an illegal search query (see Searching Wikipedia), or it may indicate a bug in the software. The last attempted database query was:

SELECT user_name,user_password,user_newpassword,user_email,user_real_name,user_options,user_rights,user_touched FROM user WHERE user_id=4

from within function "User::loadFromDatabase". MySQL returned error "1054: Unknown column 'user_real_name' in 'field list'".

 – [[User:Mxn|Minh Nguye>?n (talk, blog)]] 23:04, 28 May 2004 (UTC)

Fixed a while ago. --Brion VIBBER 07:07, 1 Jun 2004 (UTC)

Errors creating an account[edit]

A database error is thrown when creating a new account:

A database query syntax error has occurred. This could be because of an illegal search query (see Searching Wikipedia), or it may indicate a bug in the software. The last attempted database query was:

INSERT INTO user (user_name,user_password,user_newpassword,user_email, user_real_name, user_rights, user_options) VALUES ('username', , , , , , 'quickbar=1 underline=1 hover=1 cols=80 rows=25 searchlimit=20 contextlines=5 contextchars=50 skin=monobook math=1 rcdays=7 rclimit=50 highlightbroken=1 stubthreshold=0 previewontop=1 editsection=1 editsectiononrightclick=0 showtoc=1 showtoolbar=1 date=0 searchNs-1=0 searchNs0=1 searchNs1=0 searchNs2=0 searchNs3=0 searchNs4=0 searchNs5=0 searchNs6=0 searchNs7=0 searchNs8=0 searchNs9=1 searchNs10=0 searchNs11=1')

from within function "User::addToDatabase". MySQL returned error "1054: Unknown column 'user_real_name' in 'field list'".

 – [[User:Mxn|Minh Nguye>?n (talk, blog)]] 23:18, 28 May 2004 (UTC)

Fixed a while ago. --Brion VIBBER 07:07, 1 Jun 2004 (UTC)

Special:Statistics[edit]

The HTML in this page is messed up. It comes from MediaWiki:Sitestatstext. Dori | Talk 21:40, 22 May 2004 (UTC)

Special->Maintenance page also has some visible raw HTML. I imagine it's probably known/expected that about half of the special pages (EG Orphaned pages) have no content at the moment? Niteowlneils 23:41, 29 May 2004 (UTC)
It seems the problem stands for all Special: pages, as well as for all tab labels (you cant use HTML entities like &nbsp; for exemple) Srtxg 07:27, 31 May 2004 (UTC)