MediaWiki 1.20

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page MediaWiki 1.20 and the translation is 62% complete.

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎polski • ‎русский • ‎中文 • ‎日本語

MediaWiki 1.20 является устаревшей версией MediaWiki. Это краткое изложение основных изменений, представляющих интерес для пользователей. Обратитесь к файлу RELEASE NOTES для просмотра полного списка изменений. Она была развернута на вики-ресурсах Фонда Викимедиа через инкрементные ветки wmf, начиная с апреля 2012. Финальная стабильная версия была выпущена 7 ноября 2012, см. Скачать .

Что нового

MediaWiki 1.20 includes all changes released in the smaller bi-weekly "1.20wmfX" updates for Wikimedia sites. An overview of their changes is available only for 1.20wmf1.

Diff

A rainbow of colours as viewed by a person with no colour vision deficiencies.
MediaWiki 1.20 no longer has diff views looking as meaningless as this rainbow to color-blind users.

New diff view, greatly improved in clarity especially when viewing at small changes to pages (including whitespace changes) and colour-blind users. This fixes at last a major deficiency in MediaWiki's accessibility, already noted by Sunir Shah in 2001.[1]

With the latest version, spotting changes is much easier. It's speeded up workflow considerably: the kdenlive manual has many pages where small updates have been made, it would have taken me ages with the old diffs.Anne Wilson

Новые возможности

Интернационализация

  • New languages supported: Emilian (egl), Tornedalen Finnish (fit), Mizo (lus), Santali (sat), Turoyo (tru)
  • New Cyrillic-Latin language converter for Uzbek (uz)

Heads-up for MediaWiki administrators

  • Минимальная версия PHP теперь 5.3.2.

Пакетные расширения

No new extensions bundles have been done for this release; add your suggestions for extensions to be integrated, they'll be considered for the next release.

However, the MediaWiki Language Extension Bundle is now available for easy installation and upgrade of language and translation-related extensions.

Устаревшее

The following extensions make use of one or more hooks added in MediaWiki 1.20.0 and may therefore require MediaWiki 1.20 for some or all of their functionalities:

См. также