Manual talk:$wgUploadDirectory

From MediaWiki.org
Jump to navigation Jump to search

Something missing[edit]

The page currently says "Note: There are other variables which are defined relative to this one. If you redefine this in your LocalSettings.php then all dependent variables will need redefining also!" Fair enough! It would be great if those variables were listed though, to make things easier for newbies (and folk like me who've forgotten this stuff after a few months away). --Kingboyk 16:16, 18 November 2006 (UTC)

Yes, that would be useful - please add it :p --HappyDog 00:54, 23 November 2006 (UTC)
I hope that's a general invite :) As for me, I would add it if I could, but I've been away from PHP and Mediawiki for the best part of a year and I'm only very very slowly finding my feet again :( --Kingboyk 11:29, 25 November 2006 (UTC)
I have a test/development wiki farm on my local box which has multiple wikis served by a shared LocalSettings. I've just enabled uploading on two of the wikis with different values for $wgUploadDirectory. I've not changed any other directory values. Will report back if anything breaks. --Kingboyk 16:06, 25 November 2006 (UTC)
OK. Upload worked, but viewing the image didn't (404 not found): $wgUploadPath also needs to be changed. I've added this to the article.
I'm not entirely sure how seperate image repositories are best achieved on a wiki farm with just one each of LocalSettings, Mediawiki, and Apache virtual server but I'll continue to look into it. Perhaps a redirect passed through to an alias, or perhaps it would be easiest to just have each wiki's uploads in a subdirectory of images and set $wgUploadPath to a different value for each wiki. --Kingboyk 17:11, 25 November 2006 (UTC)