Hilfe:VisualEditor/Handbuch

Aus MediaWiki
Diese Seite ist eine übersetzte Version der Seite Help:VisualEditor/User guide und die Übersetzung ist zu 94 % abgeschlossen sowie aktuell.
Veraltete Übersetzungen werden wie dieser Text markiert.
PD Hinweis: Wenn Du diese Seite bearbeitest, stimmst Du zu, dass Deine Bearbeitungen unter CC0 veröffentlicht werden. Siehe Public Domain Help Pages für genauere Informationen.
PD


Den VisualEditor öffnen

Um eine Seite mit dem VisualEditor zu bearbeiten, klicke auf den Reiter „Bearbeiten“ oben auf der Seite.

Manchmal dauert es einige Sekunden, bis die Seite bearbeitet werden kann, besonders wenn die Seite sehr lang ist.

Klickt man auf den Reiter „Quelltext bearbeiten“ öffnet sich der klassische Wiki-Quelltexteditor.

VisualEditor edit tab-de.png

Du kannst den VisualEditor auch durch das Klicken auf den „Bearbeiten“-Link an jeder Abschnittsüberschrift öffnen.
VisualEditor - Section edit links-de.png

Erste Schritte: Die VisualEditor-Werkzeugleiste

Screenshot der VisualEditor-Werkzeugleiste
Die Werkzeugleiste erscheint ganz oben auf dem Bildschirm, wenn man mit VisualEditor bearbeitet. Die Leiste enthält einige bekannte Symbole:

VisualEditor - Toolbar - Undo-redo.png
Rückgängig machen und Wiederholen der vorgenommenen Änderungen.

VisualEditor Toolbar Headings-de.png
Überschriftenmenü: Du kannst das Format des Textes ändern. Um den Stil eines Abschnittes zu ändern fahre mit dem Cursor über den Abschnitt und wähle den passenden Stil im Menü aus (dazu musst du den Text nicht markieren). Abschnittsüberschriften formatiert man mit „Überschrift“, Unterabschnittstitel mit „Unterüberschrift 1“, „Unterüberschrift 2“ usw. Das normale Textformat ist „Absatz“.

VisualEditor Toolbar Formatting-de.png

Formatierung: Wenn man auf das „A“ klickt, öffnet sich ein Menü.

  • Die Fett-Schaltfläche (F) setzt den markierten Text fett.
  • Die Kursiv-Schaltfläche (K) setzt den Text kursiv.
  • Die Hochstellen-Schaltfläche (x2) lässt den ausgewählten Text kleiner und hochgestellt im Vergleich zum umgebenden Text werden.
  • Die Tiefstellen-Schaltfläche (x2) erzeugt Text, der kleiner ist und tiefergestellt im Vergleich zum umgebenden Text.
  • Die Durchstreichen-Schaltfläche (S) streicht den gewählten Text durch.
  • Die „Computercode-Schaltfläche“ (geschweifte Klammern: { }) verändert die Schriftart des gewählten Textes in eine nichtproportionale Schriftart, die den Text von dem umgebenden Text (in proportionaler Schrift) abhebt.
  • Die Unterstreichen-Schaltfläche (U) unterstreicht den gewählten Text.
  • Die Sprache-Schaltfläche (文A) ermöglicht es dir, die Sprache (zum Beispiel Japanisch) und Schriftrichtung (zum Beispiel rechts nach links) des gewählten Textes festzulegen.
  • Die letzte Schaltfläche (VisualEditor MediaWiki theme clear icon bitmap.png), genannt Entfernen, entfernt jegliche Formatierung des gewählten Textes, inklusive Links.

Falls kein Text ausgewählt worden ist vor dem Klicken auf das „A“ und auf eine Schaltfläche, wird der im Folgenden eingegebene Text ab der aktuellen Position des Cursors entsprechend formatiert, egal, wo dein Cursor sich gerade befindet.


VisualEditor - Toolbar - Linking.png
Verlinkungstool: Die Kette ist das Verlinkungstool. Wenn man darauf klickt (typischerweise nach Markieren eines Textausschnittes) öffnet sich der Verlinkungsdialog.

VisualEditor - Cite Pulldown.png
Belegen-Menü: Das Belegen-Menü dient dazu, Verweise (auch Einzelnachweise oder Fußnoten genannt) innerhalb des Textes einzufügen. Alle Projekte haben Zugriff auf die $basic-Einzelnachweisformatierung und machen eine Mehrfachnutzung von Verweisen mithilfe dieses Menüs möglich. Außerdem kann man über das Menü einfach Quellenvorlagen nutzen, sofern sie in dem jeweiligen Projekt existieren.

VisualEditor citoid Cite button-de.png
Belegen-Schaltfläche: If the Citoid service and/or citation tool is enabled on your wiki, you will see a Belegen button instead of a Zitat menu.

(Anleitungen, um lokale Quellenvorlagen für ein bestimmtes Wiki zum Manuell hinzuzufügen, finden sich unter VisualEditor/Citation tool .)

Instructions for enabling the Automatisch tab are available at Enabling Citoid on your wiki

Der Citoid-Service versucht Quellen-Vorlagen automatisch auszufüllen.


VisualEditor Toolbar Lists and indentation-de.png
Listen und Einrückungen: Die beiden ersten Schaltflächen erlauben dir, den Text entweder als Aufzählungszeichen oder Nummerierte Liste zu formatieren. Die letzten beiden Schaltflächen ermöglicht es dir die Einrückungsebene der Einträge zu verändern.

VisualEditor Insert Menu-de.png
Einfügen: Das Einfügen kann sich von Projekt zu Projekt unterscheiden. Hier findet sich eine Liste aller möglichen Optionen die auftauchen könnten.
  • Das Bilder und Medien-Symbol (ein Bild mit Bergen) öffnet den Medien-Dialog.
  • Die Vorlage-Schaltfläche (ein Puzzleteil) ermöglicht das Bearbeiten von Vorlagen.
  • Die Tabellen-Schaltfläche ermöglicht das Einfügen von Tabelle.
  • Die Kommentar-Schaltfläche (eine Sprechblase) ermöglicht es, Kommentare einzufügen, die für Leser nicht sichtbar sind, also nur im Bearbeitungsmodus zu sehen sind. Dort werden sie durch ein Ausrufezeichen-Symbol markiert. Ein Klick auf das Ausrufezeichen-Symbol ermöglicht es, den Kommentar zu bearbeiten oder zu löschen.
  • Die Hieroglyphen-Schaltfläche (ein Ankh-Symbol - ☥) ermöglicht das Einfügen von Hieroglyphen (siehe unten).
  • Die Schaltfläche „Code-Block“ erlaubt die Eingabe von Code.
  • Die Notenschrift-Schaltfläche ermöglicht die Eingabe von Musiknoten.
  • Die Galerie-Schaltfläche (einige Photos) ermöglicht das Einfügen einer Galerie von Bildern.
  • Die Schaltfläche Math-Formel (Σ) öffnet den Dialog zum Einfügen von Formeln.
  • Mittels der Diagramm-Schaltfläche können Diagramme erstellt werden.
  • Die Schaltfläche „Deine Unterschrift“ fügt eine Unterschrift ein, die du auf dem Projekt benutzt. Diese Schaltfläche ist deaktiviert (nicht auswählbar), wenn du einen Seitentyp (einen Namensraum) wie Artikel bearbeitest, wo keine Unterschriften eingefügt werden sollten.
  • Die Schaltfläche Einzelnachweisliste (drei Bücher) öffnet einen Dialog der erlaubt, den Anzeigeort der Einzelnachweise festzulegen. Dies muss normalerweise nur einmal pro Seite getan werden.

Einfügen von Sonderzeichen: Beim Klicken auf die Sonderzeichen-Schaltfläche im Einfügen-Menü öffnet sich ein Dialog, der das Einfügen einer Vielzahl von Sonderzeichen ermöglicht. Wenn man auf eines der Zeichen klickt, wird es in den Text eingefügt. Diese Sonderzeichen enthalten einige Standardsymbole, Diakritika und mathematische Symbole. (Diese Liste kann von Land zu Land variieren. Weitere Hinweise unter VisualEditor/Sonderzeichen )
VisualEditor Toolbar SpecialCharacters-de.png

VisualEditor toolbar edit notices icon.png
Der „Bearbeite Notizen“-Knopf zeigt alle Notizen dieser Seite an.

VisualEditor More Settings-de.png
Das Menü Seitenoptionen befindet sich links neben dem Änderungen veröffentlichen-Knopf und dem Menü „Editor wechseln“. In diesem Menü befindet sich ein Knopf, mit dem man einen Optionen-Dialog mit den folgenden Reitern (links) öffnen kann:
  • Kategorien ermöglicht es, Kategorien zu dieser Seite hinzuzufügen und die Sortierung der Seite anzupassen, wenn sie innerhalb einer Kategorie angezeigt wird, indem ein anderer Index für die Sortierung festgelegt wird.
  • Seiteneinstellungen ermöglicht es, die Seite zu einer Weiterleitung zu machen und die Optionen dieser Weiterleitung anzupassen, die Einstellungen für die Anzeige des Inhaltsverzeichnisses anzupassen, die Bearbeitungslinks neben jeder Überschrift zu deaktivieren und die Seite als Disambiguierungs-Seite zu definieren.
  • Erweiterte Einstellungen ermöglicht die Anpassung der Einstellungen für die Indizierung der Seite durch Suchmaschinen, die Anzeige einer Registerkarte zum Hinzufügen eines neuen Abschnitts und den angezeigten Titel.
  • Sprachen zeigt eine Liste von Seiten in anderen Sprachen, die mit dieser Seite verlinkt sind.
  • Verwendete Vorlagen zeigt eine Liste von Links zu allen auf dieser Seite verwendeten Templates.

Die Reiter des Optionen dialogs werden auch im Menü Seitenoptionen angezeigt und können durch Anklicken geöffnet werden. Darüber hinaus enthält das Menü $pagemenu die Schaltfläche Von rechts nach links anzeigen und die Schaltfläche Suchen und Ersetzen, die ein Dialogfeld öffnet, in das die gesuchten Zeichen, Begriffe oder regulären Ausdrücke sowie die zu ersetzenden Zeichen eingegeben werden können, zusammen mit mehreren Options-Schaltflächen.


OOjs UI icon edit-ltr.svg
Die Editor wechseln-Schaltfläche befindet sich neben der Änderungen veröffentlichen-Schaltfläche. Ein Klick auf Sie öffnet ein Menü, das unten die Schaltfläche Quelltextbearbeitung enthält. Diese erlaubt dir, zum Wikitext-Editor zu wechseln.

Änderungen veröffentlichen

Wenn du mit dem Bearbeiten fertig bist, klicke auf die blaue Schaltfläche „Änderungen veröffentlichen“ in der Werkzeugleiste. Wenn du keine Änderungen vorgenommen hast, ist der Button deaktiviert (und wird daher grau angezeigt). Um all deine Bearbeitungen zu verwerfen, schließe entweder das Browserfenster oder klicke auf den Tab „Lesen“ oberhalb der Werkzeugleiste.
VisualEditor toolbar actions-de.png

Wenn du den blauen Knopf „Änderungen veröffentlichen …“ drückst, öffnet sich ein Dialogfenster. Hier kannst du eine kurze Zusammenfassung deiner Änderungen eingeben, deine Bearbeitung als klein markieren und/oder die Seite zu deiner $watchlist hinzufügen. Das Feld Zusammenfassung und Quellen entspricht dem Zusammenfassungsfeld im Quelltexteditor.

Wenn du auf „Überprüfe deine Änderungen“ drückst, kannst du den Unterschied zwischen deiner Version und der alten Version sehen. Diese Funktion gleicht dem „Änderungen zeigen“ des Quelltexteditors.

Der Bearbeitung fortsetzen-Button ermöglicht es dir zurück auf die Seite zu gelangen, die du gerade bearbeitest. Du kannst deine Bearbeitungen später veröffentlichen.

VisualEditor save dialog-de.png

Links bearbeiten

VisualEditor - Toolbar - Linking.png
Links können durch das Link-Symbol (Kettenglieder) in der Werkzeugleiste oder durch die Tastenkombination Strg+K (oder ⌘ Command+K auf einem Mac) hinzugefügt werden.

Wenn du Text markierst und dann auf „Link“ klickst, wird ein Link mit dem Text als Linktext eingefügt. Wenn du nur ein Wort als Linktext verwenden willst, reicht es, wenn sich der Cursor über dem Wort befindet.


VisualEditor-link tool-search results-de.png
Egal ob du die Schaltfläche oder die Tastenkombination genutzt hast, wird sich ein Dialog öffnen, in den du den Link eingeben kannst.

Der VisualEditor wird versuchen, dich bei internen Links zu unterstützen, indem er ähnliche Seitennamen vorschlägt. Nachdem du einen Link eingegeben oder ausgewählt hast, beendest du die Verlinkung indem du ↵ Enter klickst, durch Klicken die „Fertig“-Schaltfläche. Dein Link wird dann sofort auf der Seite erscheinen, wird aber wie alle anderen Änderungen an einer Seite, erst veröffentlicht, wenn du die gesamte Seite veröffentlichst.


VisualEditor-link tool-external link-de.png
Um auf eine Webseite einer anderen Website zu verlinken, ist der Vorgang ähnlich: Wählen Sie die Registerkarte „Externe Seite“ und geben Sie eine URL in das Feld ein.

VisualEditor link tool simple link.png
Externe Links ohne Titel sehen so aus: [1]. Diese können hinzugefügt werden indem man den Cursor weg von einem Wort setzt (z. B. nach einem Leerzeichen). Öffne das Verlinkungstool in dem du auf den Button klickst oder das Tastaturkürzel verwendest. Trage die URL in dem Eingabefeld ein und klicke auf „Fertig“ um den Link einzufügen.

VisualEditor-context menu-link tool.png
Um einen bestehenden Link zu ändern oder entfernen, klicke auf den Link und dann auf „Link“, das in der Nähe erscheint. Es öffnet sich ein Bearbeitungsfenster (Du kannst auch auf das gleiche Symbol in der Werkzeugleiste klicken oder die Tastenkombination Strg+K benutzen, während der Cursor im Linktext ist.) Wenn ein Link ausgewählt ist, erscheint er in einem blauen Rahmen.

Im Linkbearbeitungsdialog kannst du das Linkziel verändern. Du kannst zudem den Link komplett entfernen, indem du auf den Button „Entfernen“ klickst, der sich in der unteren linken Ecke des Dialogs befindet. Du kannst das Linkziel auch in einem anderen Fenster öffnen lassen, indem du auf die Kopie des Links im Dialog klickst. (Dies ist nützlich zur Überprüfung, ob ein externer Link noch gültig ist.)

Wenn du aus der Linkbearbeitung (oder dem Linktext) heraus möchtest oder nach dem Link weiterschreiben möchtest kannst du drücken.

  • Einmaliges Drücken wird den Linkbearbeitungsdialog schließen und den Cursor an das Ende des Linktextes setzen (blau eingerahmt und den Link zu bearbeiten)
  • Zweimaliges Drücken wird den Cursor hinter den Linktext setzten, so dass du den Rest deines Textes schreiben kannst.

Der angezeigte Text eines bestehenden Links kann bearbeitet werden, indem der Text angeklickt und der neue Text eingetippt wird. Solltest du den ganzen Tetx ersetzen wollen, beachte bitte Folgendes:

  • Falls du den ganzen Linktext ausgewählt hast, wird der Link durch das Tippen einer Taste gelöscht.
  • Um die Löschung des Links zu verhindern, einfach in den Linktext klicken und diesen mit der Rücklöschtaste (Backspace) und der Entfernen-Taste (Delete) löschen – wenn du diese Tasten nicht mehr als unbedingt nötig verwendest, bleibt ein schmaler blauer Linkbereich übrig. Jetzt kannst du den neuen Linktext für den bestehenden Link einfügen.
  • Du kannst ebenfalls Links auf Kategorien, Dateien und mehr erstellen.

Einzelnachweise bearbeiten

Für weitere Informationen siehe Help using citation templates oder Help using citoid's Automatisch button

Feststellen, welches System vorhanden ist

Dein Wiki kann eines von drei Fußnotensystemen benutzen. Rechts wird das einfachste System gezeigt, in dem das Belegen-Menü keine Quellenvorlagen enthält. Wenn dein Wiki dieses System verwendet, findest du alles, was du über Fußnoten wissen musst, auf dieser Seite weiter unten.
VisualEditor cite menu default.png

VisualEditor citoid Cite button-de.png
In the second system, you again start by pressing the Belegen button. Then a dialog box opens, which includes several popular citation templates set up for quick access in the "Manuell" tab. Wenn dein Wiki dieses System benutzt, findest du weitere Einzelheiten unter Help:VisualEditor/User guide/Citations-Templates .
Manual tab only - visual editor - citations.png

Im dritten System beginnen Sie wieder mit dem Drücken der Taste $citoid. Es öffnet sich dann ein Dialogfenster, das einen automatischen Prozess fürs Einfügen von Belegen enthält basierend auf dem Citoid-Service. Wenn dein Wiki dieses System verwendet, findest du weitere Informationen unter Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Inspector-de.png

Einen bestehenden Einzelnachweis bearbeiten

Um einen bestehenden Einzelnachweis zu bearbeiten, klicke auf die Stelle, wo er im Text auftaucht (meistens eine Zahl in eckigen Klammern). Du siehst dann entweder das Symbol „Einzelnachweis“ (Lesezeichen) oder ein Symbol (und Name) für die Vorlage, die verwendet wurde um diesen Einzelnachweis zu erstellen. In jedem Fall öffnet sich durch Klicken auf das die "Bearbeiten"-Schaltfläche ein Bearbeitungsdialog.
VisualEditor - Editing references 1.png

Ein Klick auf „$ref“ öffnet ein Fenster mit einem Mini-Editor, in dem du den Einzelnachweis bearbeiten kannst.

Viele Wikis benutzen Vorlagen, um Einzelnachweise einheitlich darzustellen. Wenn dein Einzelnachweis eine Vorlage benutzt, wird die gesamte Information in diesem Feld hervorgehoben, wenn du deinen Mauszeiger über dieses Feld bewegst.

Wenn eine Vorlage verwendet wird und du die Einzelnachweise angeklickst, erscheint das Vorlage-Symbol (Puzzleteil) mit einigen Zusatzinformationen. Klicke auf "Bearbeiten" um den Inhalt der Vorlage in dem Vorlagen-Minieditor zu bearbeiten.

VisualEditor - Editing references 6.png

Wenn bei einem Klick auf einen Einzelnachweis das Symbol einer Standard-Quellenvorlage erscheint (siehe Beispiel rechts), dann kann man mit einem Klick auf "Bearbeiten" den Vorlagen-Minieditor öffnen.
VisualEditor - Editing References - Cite Web.png

Im Vorlagen-Editor können Informationen oder Inhalte hinzugefügt, entfernt oder verändert werden. Am Anfang werden nur ausgefüllte Felder (Vorlagenparameter) angezeigt. Weitere Felder können mit einen Klick auf „Hinzufügen“ unten im Vorlagen-Minieditor hinzugefügt werden.
VisualEditor - Editing references 5.png

Klicke auf "Änderungen übernehmen", wenn du fertig bist.
VisualEditor Apply Changes-de.png

Einen bestehenden Einzelnachweis wiederverwenden

Wenn die Seite bereits einen Einzelnachweis enthält der zu dem Textabschnitt passt, den du belegen willst, kannst du diesen erneut verwenden.

Um einen Einzelnachweis ein weiteres Mal zu benutzen, platziere den Cursor an der gewünschten Stelle im Text, wo du den neuen Einzelnachweis (Nummer) für die Referenzierung angeben willst. Daraufhin klicke auf den Punkt „Weiterverwenden“ auf dem Menü „Zitat“ in der Werkzeugleiste.

(Bemerkung: Wenn dein Wiki das dritte Fußnoten-System hat, wie oben beschrieben, erscheint anstelle des Punktes "Weiterverwenden" im Menü "Weiterverwenden" ein „Zitat“-Tab im Bearbeitungsfenster.)

VisualEditor cite menu default.png

Im Dialog „Einzelnachweis“ kannst du den Einzelnachweis, den du wiederverwenden willst, auswählen. Gibt es dort viele Einträge, kannst das Suchfeld (genannt „Innerhalb aktueller Zitate suchen“) verwenden, um dir eine entsprechende Auswahl anzeigen zu lassen.
VisualEditor - Editing references 18.png

Einen neuen Einzelnachweis hinzufügen

Um ein Zitat über das Menü "Zitat" hinzuzufügen, platziert man den Cursor an der Stelle im Text, an der das Zitat eingefügt werden soll. Dann wählt man im Menü die entsprechende Zitierart aus. Then click "Einfach".
VisualEditor cite menu default.png

Einfaches Referenzieren verwenden

Hier ist dargestellt, was du siehst, wenn du das Basisform auswählst. Im Einzelnachweiseditor kannst du den Einzelnachweistext hinzufügen und formatieren.

Es ist möglich, die Referenz einer bestimmten Gruppe zuzuordnen, auch wenn dies normalerweise nicht getan wird. (Damit können Einzelnachweise gruppiert mit „Einzelnachweisliste“ angezeigt werden.)

VisualEditor - Editing references 20.png

Wenn du einen neuen Einzelnachweis hinzufügst und dabei Quellen- oder andere Vorlagen verwenden möchtest, musst du das Vorlage-Symbol in der Werkzeugleiste des Referenzen-Editors (Einfügen) anklicken.
VisualEditor Template Insert Menu-de.png

Danach kannst du die Vorlage wie im normalen Modus hinzufügen und anschließend bearbeiten wie jede andere Vorlage (siehe den Abschnitt Vorlagen bearbeiten weiter unten, wenn du mehr Informationen über Vorlagen benötigst.)

Nachdem die Vorlage bearbeitet wurde, klicke auf „Änderungen übernehmen“ um zum Einzelnachweiseditor zurückzukehren, und dann nochmal auf „Änderungen übernehmen“ um zur Seite zu zurückzukommen.

VisualEditor - Editing references 9.png

Wenn noch keine Einzelnachweisliste auf der Seite vorhanden ist (beispielsweise, wenn du den ersten Einzelnachweis hinzufügst), musst du sie ergänzen, damit deine Einzelnachweise dem Leser angezeigt werden.

Wähle dir die Stelle aus, an der die Einzelnachweise angezeigt werden sollen (üblicherweise am Ende der Seite), und öffne dann das Einfügen-Menü und klicke anschließend auf das Symbol „Einzelnachweisliste“ (drei Bücher), um die Liste hinzuzufügen.

VisualEditor References List Insert Menu-de.png

Wenn du mehrere Gruppen von Einzelnachweisen nutzt, was eher selten vorkommt, kannst du die gewünschte Gruppe im Fenster angeben. Nur die Einzelnachweise, die zu dieser Gruppe gehören, werden dann dort gezeigt werden.

Klicke zuletzt auf „Einfügen“.

VisualEditor references list-de.png

Einfache Einzelnachweisvorlagen verwenden

In deinem lokalen Wiki sind unter Umständen andere Quellenvorlagen in diesem Menü. (In der deutschen Wikipedia heißen diese beispielsweise „Webseite“ und „Literatur“.) So hast du einen schnellen Zugriff auf die am häufigsten verwendeten Quellenvorlagen deines Wikis. (Eine Anleitung, um weitere Quellenvorlagen in deinem lokalen Wiki hinzuzufügen, findet sich unter VisualEditor/Citation tool .)
Manual tab only - visual editor - citations.png

Wenn man auf ein Vorlagensymbol klickt, wie hier in der Abbildung „Cite book“, wird man zu einer Eingabemaske für diese Vorlage geführt. wichtige Felder sind dabei mit einem Sternchen markiert. Zudem werden zwar die üblichsten Felder aufgeführt, jedoch müssen nicht immer auch alle ausgefüllt werden.
VisualEditor - Editing references - Cite book required fields.png

Um weitere Parameter hinzuzufügen, scrolle ans Ende der Eingabemaske und klicke auf „Hinzufügen“.

Klicke auf „Einfügen“, wenn du fertig bist.

VisualEditor - Editing references - Add parameter.png

Bilder und andere Mediendateien bearbeiten

Bilder bearbeiten

Zum Hinzufügen eines Bildes (oder einer anderen Mediendatei) zur Seite musst du auf das "Bilder und Medien"-Icon in der Einfügen (ein Bild mit Bergen) klicken. Das Bild wird da eingefügt, wo der Cursor gerade steht.
VisualEditor Media Insert Menu-de.png

Das Klicken auf „Bilder und Medien“ öffnet ein Dialogfenster, das automatisch auf Wikimedia Commons nach Dateien sucht, die in Beziehung zur Seite stehen, die du gerade bearbeitest.

Durch das Ändern des Textes im Suchfeld kannst du nach anderen Mediadateien suchen.

Klicke auf ein Miniaturbild, um die Datei auszuwählen.

Dieses stellt das Bild auf die gerade bearbeitete Seite.

VisualEditor - Media editing 2.png

Nachdem das ausgewählte Bild auf der Seite eingefügt wurde, öffnet sich ein weiterer Dialog. Dieser Dialog erlaubt das Hinzufügen und die Veränderung der Bildunterschrift. Diese kann sowohl Formatierungen als auch Links enthalten.
VisualEditor - Media editing 6.png

Der Mediendialog erlaubt zudem das Hinzufügen von alternativen Unterschriften für Benutzer von Screenreadern oder Benutzern die die Anzeige von Bildern deaktiviert haben.
VisualEditor - Media editing 7.png

Im Fenster „Erweiterte Einstellungen“ können zudem unterschiedliche Parameter des Bildes, wie Ausrichtung, Typ oder Größe, eingestellt werden.
VisualEditor - Media editing 8.png

Wenn du mit dem Bearbeiten fertig bist, klicke auf „Änderungen übernehmen“, um sie Seite weiter zu bearbeiten.
VisualEditor Apply Changes-de.png

Zu einem bereits vorhandenen Bild können eine Bildunterschrift oder andere Parameter ergänzt oder verändert werden, in dem man auf das Bild und dann auf das darunter erscheinende Bilder und Medien-Symbol klickt.

Die Größe eines bereits vorhandenen Bildes kann verändert werden indem man auf dieses klickt und dann das Symbol mit dem Doppelpfeil (links unten) kleiner oder größer zieht.

Man kann auch ein Bild per Drag-und-Drop an eine andere Stelle ziehen.

VisualEditor - Media editing 3.png

Bilder hochladen

Du kannst Bilder entweder in einem Tab im Mediendialog, durch ziehen und ablegen einer Datei in den Editor oder durch einfügen eines Bildes aus der Zwischenablage hochladen
VisualEditor - Media upload 1.png

Klicke den Reiter "Hochladen" und wähle ein Bild von deinem Rechner aus. Du kannst den Dateinamen eintippen oder ein Bild in den Kasten ziehen. You can type the file name, or drag an image into the box. Wenn du ein Bild per Drag-und-Drop direkt in den Editor gezogen oder eines aus der Zwischenablage eingefügt hast, öffnet sich dieser Tab automatisch.
VisualEditor - Media upload 1.5.png

Du musst das Bild beschreiben und Kategorien hinzufügen, damit andere es finden können.
VisualEditor - Media upload 2.png

Das Bild wird in die Seite eingefügt, wenn du fertig bist.
VisualEditor-logo.svg

Galerien bearbeiten

Um eine neue Bildgalerie hinzuzufügen klicke auf das Symbol „Galerie“ (eine Gruppe von Photos) im Menü „Einfügen“. (Wenn das Symbol nicht im Menü auftaucht, dann ist diese Funktionalität noch nicht in deinem lokalen Wiki implementiert.)
VisualEditor - Gallery1.png

Eine bereits vorhandene Galerie kann bearbeitet werden, in dem man zuerst auf die Galerie klickt und dann unten auf das Galerie-Symbol (eine Gruppe von Photos). Dies öffnet den Galerie-Editor der alle Bilder in der Galerie auflistet.
VisualEditor - Gallery2.png
Der Galerie-Editor ist derzeit ein einfacher Kasten, mit dem Sie bestehende Galerien mit Hilfe von Wikitext-Auszeichnungen bearbeiten können. Um ein neues Bild zu einer bestehenden Galerie hinzuzufügen, geben Sie den Dateinamen ein, gefolgt von einem Balken (|) und der Bildunterschrift für dieses Bild. Sie müssen jedes Bild in der Galerie in eine eigene Zeile setzen. Diese Liste kann bearbeitet werden um Bilder zu entfernen oder umzupositionieren, sowie die Bildunterschriften zu verändern.

Klicke auf „Fertig“ um den Galerie-Editor zu verlassen. Die Änderungen sollten nun sichtbar sein.

Denke daran, dass durch Verlassen des Galerie-Editors deine Änderungen nicht abschließend gespeichert werden. Wie bei allen Änderungen mit dem VisualEditor, musst du erst die komplette Seite speichern, damit die Änderungen aktiv werden.

VisualEditor - Gallery3.png

Vorlagen bearbeiten

Mit dem mächtigen MediaWiki-Vorlagensystem lassen sich dynamische Inhalte, Text von anderen Seiten und vieles mehr einfügen. Eine ausführliche Erklärung und Beispiele findet sich auf der Hilfeseite Templates (Vorlagen).

Im VisualEditor können nach einer passenden Vorlage gesucht, ein Aufruf oder eine Transklusion auf der zu bearbeitenden Seite hinzugefügt und, falls erforderlich, mit Parameter benutzerdefinierte Inhalte hinzugefügt werden.

Neue Vorlage einfügen

Um eine neue Vorlage auf einer Seite einzufügen, platziert man den Cursor an die Stelle, an der die Vorlage eingefügt werden soll. Öffne dann das Einfügen-Menü und wähle "OOjs UI icon puzzle-ltr.svg Vorlage". Alternativ können auch zwei geschweifte Klammern {{ eingegeben werden, um denselben Dialog zu öffnen.
VisualEditor Template Insert Menu-de.png
Suchen Sie die Vorlage, die Sie einfügen möchten, indem Sie entweder ihren Namen oder ein entsprechendes Stichwort eingeben. Ergebnisse, die den Suchbegriff entweder im Namen oder in der Beschreibung enthalten, werden in einer Dropdown-Liste angezeigt. Dies sollte Ihnen helfen, eine relevante Vorlage zu finden, auch wenn Sie ihren genauen Namen nicht kennen.

Wenn Sie Schwierigkeiten haben, die gewünschte Vorlage mit Hilfe von Schlüsselwörtern zu finden, können Sie auf anderen Wikiseiten mit ähnlichem Inhalt nachsehen, welche Vorlagen verwendet werden. Wenn Sie den Namen der gewünschten Vorlage gefunden haben, können Sie ihn in dieses Feld eingeben, um ihn hier einzufügen.

Screenshot des Suchfelds für Vorlagen im visuellen Editor

Außerdem kann eine Vorlage bearbeitet werden, die sich bereits auf der Seite befindet. Wenn du die zu bearbeitende Vorlage auswählst, erscheint sie in Blau und es erscheint ein Feld mit der Aufschrift „OOjs UI icon puzzle-ltr.svg Vorlage“. Wähle dann den Link „Bearbeiten“ oder klicke doppelt auf die Vorlage selbst, um sie zu öffnen.
Screenshot of the VisualEditor interface with a template selected

Einige Vorlagen sind für die Leser der Seite nicht sichtbar. Im visuellen Editor werden solche versteckten Vorlagen weiterhin angezeigt, sodass du sie durch Anklicken bearbeiten oder löschen kannst. Der Name der Vorlage wird neben dem Puzzlesymbol angezeigt, wobei beide ausgegraut sind.
Screenshot of hidden templates in the Visual Editor interface

Vorlagenparameter

Dieses Dialogfeld wird angezeigt, wenn Sie eine neue Vorlage hinzufügen oder eine bereits vorhandene Vorlage bearbeiten. Was Sie in dem Feld sehen, hängt davon ab, ob die betreffende Vorlage TemplateData , hilfreiche Metadaten enthält, die von anderen Editoren hinzugefügt wurden, um die Bearbeitung von Vorlagen im visuellen Editor zu erleichtern.

Wenn eine Vorlage TemplateData enthält, kann der VisualEditor diese verwenden, um kommentierte Felder anzuzeigen, die Sie ausfüllen können.


Bei Vorlagen, die einige von der Gemeinschaft bereitgestellte TemplateData enthalten, zeigt der VisualEditor eine Liste der benannten Parameter und oft auch Beschreibungen und Anweisungen an, die die Bedeutung und das erforderliche Format für die Werte der einzelnen Parameter erklären.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

Sie können jeden optionalen Parameter (mit blauen Kontrollkästchen auf der linken Seite) deaktivieren. Wenn das Kontrollkästchen eines Parameters ausgegraut ist und nicht angeklickt werden kann, benötigt die Vorlage diesen Parameter, so dass er nicht deaktiviert werden kann.

Wenn Sie eine neue Vorlage einfügen, werden Sie feststellen, dass einige optionale Parameter vorausgewählt sind. Das bedeutet, dass der/die Autor(en) der Vorlage die Verwendung dieser Parameter empfiehlt/empfehlen. Es empfiehlt sich, alle Parameter, die in einer Vorlage verwendet werden, zu überprüfen, um sicherzustellen, dass Sie ihre Verwendung verstehen.

Wenn Sie auf einen nicht markierten Parameter klicken, wird er der Vorlage hinzugefügt. Wenn Sie auf einen bereits hinzugefügten Parameter klicken, gelangen Sie zum Eingabefeld des Parameters.

Einige Vorlagenparameter werden als "veraltet" angezeigt. Verwenden Sie keine veralteten Parameter, wenn Sie eine Vorlage einfügen. Sie sind nur für Sie sichtbar, weil diese Parameter auf älteren Seiten verwendet werden, in denen diese Vorlage enthalten war.

Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Hinzufügen undokumentierter Parameter

Wenn Sie eine Vorlage einfügen oder bearbeiten, deren Autor die Parameter nicht in TemplateData angegeben hat, handelt es sich um so genannte "undokumentierte" oder "unbenannte Parameter". In diesen Fällen sollten Sie die Seite für die Vorlage selbst konsultieren. Dort können Sie lernen, wie man alle Parameter der Vorlage richtig einsetzt und mit ihnen arbeitet. Dazu gehört auch, dass Sie die genauen Namen der Parameter lernen, wie sie vom Autor der Vorlage geschrieben wurden.

Wenn Sie in der Dokumentation feststellen, dass die Vorlage Parameter ohne Namen erwartet, geben Sie Zahlen als Platzhalter für die Parameternamen ein, indem Sie die undokumentierte Parametereingabe verwenden, und fügen Sie dann wie gewohnt Text zu den Werten hinzu, die Sie angeben möchten.

Beispiel:

  • erster unbenannter Parameter: "1"
  • Wert des ersten unbenannten Parameters: "en_US"
  • zweiter unbenannter Parameter: "2"
  • Wert des zweiten unbenannten Parameters: "ja"

Wenn Sie versehentlich nicht vorhandene, falsch geschriebene oder fehlerhafte Parameter eingeben, werden die Werte, die Sie für diese Parameter eingeben, nicht auf der Seite angezeigt, die Sie gerade bearbeiten.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Autogenerierte Parameter

In diesem Beispiel fehlen der betreffenden Vorlage die TemplateData, aber es war möglich, die Parameter automatisch zu generieren. Das bedeutet, dass die undokumentierten Parameter bereits für Sie hinzugefügt wurden, aber die Namen sind möglicherweise nicht leicht verständlich und der Dialog kann keine Anweisungen oder Beschreibungen anzeigen. Das Dialogfeld enthält einen Link zur Dokumentation der Vorlage, der Ihnen helfen soll, die verschiedenen Parameter der Vorlage zu ermitteln und auszufüllen.
Autogenerated parameters in the VisualEditor.png

Bearbeiten von mehrteiligem Vorlageninhalt

Während der Bearbeitung können Sie Vorlageninhalte öffnen, die aus mehreren Vorlagen oder einer einzelnen Vorlage bestehen, die mit einem Wikitext verknüpft ist. Während der Bearbeitung können Sie Vorlageninhalte öffnen, die aus mehreren Vorlagen oder einer einzelnen Vorlage bestehen, die mit einem Wikitext verknüpft ist. In diesem Fall lassen sich die Vorlagen besser als gestapelt oder verbunden darstellen.

Diese Inhalte enthalten häufig "unausgewogene Vorlagen", d. h. Vorlagen, die für sich genommen unvollständig sind und mit einem Wikitext oder einer anderen Vorlage kombiniert werden müssen, um zu funktionieren.

Diese zusammenhängenden Teile des Vorlageninhalts müssen in wikitext erstellt werden, können aber im VisualEditor bearbeitet werden. In diesen Fällen wird oben im Dialogfeld ein Hinweis angezeigt, um die Situation zu signalisieren, und unten in der Seitenleiste wird eine spezielle Symbolleiste eingeblendet. Dort können Sie über die Icon-Schaltflächen weitere Vorlagen und zusätzlichen Wikitext hinzufügen, Elemente löschen oder deren Reihenfolge ändern.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

Verschachtelte Vorlagen

Schablonen können andere Schablonen als Wert für Parameter enthalten. Sie erkennen dies daran, dass ein Parameter, dessen Wert die doppelten geschweiften Klammern ( {{ }} ) enthält, eine Vorlage bezeichnet.

Der VisualEditor kann diese Vorlage nicht innerhalb einer Vorlage (einer verschachtelten Vorlage) mit der benutzerfreundlichen Oberfläche des Editors darstellen. Wenn Sie also selbst eine Vorlage verschachteln wollen, müssen Sie wissen, wie Sie die Vorlage von Hand in wikitext in das entsprechende Parameterfeld einfügen.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

Abschluss der Bearbeitung

Wenn Sie die Bearbeitung einer Vorlage abgeschlossen haben, können Sie auf "Änderungen übernehmen" klicken. Dann können Sie eine Vorschau Ihrer Bearbeitung anzeigen und sicherstellen, dass sie so aussieht, wie Sie es wünschen und erwarten.

Möglicherweise wird auch eine Fehlermeldung angezeigt, bei der es sich (wie bei den anderen oben genannten TemplateData) um von der Gemeinschaft bereitgestellte Inhalte handelt, die unterschiedlich nützlich sein können. Möglicherweise müssen Sie die Dokumentation der Vorlage konsultieren, um einigen Fehlern auf den Grund zu gehen. Wenn Sie immer noch Probleme haben, können Sie Ihr Problem auf der Diskussionsseite der Vorlage schildern.

VisualEditor Apply Changes-de.png

Entfernen einer Vorlage

Um eine Vorlage im VisualEditor zu entfernen, klicken Sie auf das Vorlagenfeld. Drücken Sie die "Entf"- oder "Backspace"-Taste auf Ihrer Tastatur. Die Vorlage wird von der Seite verschwinden.
Screenshot of the button to remove a template
Entfernen einer Vorlage im VisualEditor

Bearbeitung auf dem Handy

Wenn Sie eine Vorlage auf einer Seite mit dem VisualEditor auf einem mobilen Gerät bearbeiten, werden Sie feststellen, dass die Seitenleiste zunächst ausgeblendet ist. Sie können sie sichtbar machen, indem Sie auf die Schaltfläche "Optionen ein-/ausblenden" klicken.
Screenshot of editing a template on a mobile device
Bearbeiten einer Vorlage auf dem Handy mit dem VisualEditor

Vorlagen substituieren

Wenn Sie eine Vorlage in eine Wikiseite einfügen, werden ihr Inhalt und ihr Aussehen jedes Mal, wenn die Seite geladen wird, auf der Grundlage des Vorlagencodes und der Werte ihrer Parameter neu bewertet. Das heißt, wenn jemand den Code einer Vorlage aktualisiert, wird jede Seite, die diese Vorlage verwendet, ebenfalls aktualisiert, wenn sie veröffentlicht wird.

Es gibt aber noch eine andere, weit weniger verbreitete Möglichkeit, Vorlagen zu verwenden, nämlich die Substitution einer Vorlage. Auf diese Weise wird der Inhalt der Vorlage dauerhaft so übernommen, wie er zum Zeitpunkt des Einfügens erscheint. Er wird nicht aktualisiert, wenn der Vorlagencode später geändert wird.

Die meisten Nutzer werden nie auf die Substitution zurückgreifen müssen. Die Ersetzung ist in der Regel nur dann sinnvoll, wenn Sie das genaue Erscheinungsbild einer Version einer Vorlage erfassen müssen, z. B. wenn der Inhalt gerade entwickelt wird und bewertet werden muss.

Um eine Vorlage im VisualEditor zu ersetzen, fügen Sie eine Vorlage mit der Namenssyntax subst:<Vorlagenname> ein. (Die Autovervollständigung funktioniert in diesem Fall nicht.) Drücken Sie dann auf die blaue Schaltfläche "Vorlage hinzufügen".

Wenn Sie fertig sind, klicken Sie auf "Einfügen", um den Inhalt der Vorlage so einzufügen, wie Sie ihn sehen.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Listen bearbeiten

VisualEditor Toolbar Lists and indentation-de.png
Du kannst mit dem VisualEditor Listen erstellen oder das Format bestehender Listen verändern. Es gibt zwei Arten von Listen: Liten mit Aufzählungszeichen (unsortiert) und nummerierte Listen (sortiert).

Um eine neue Liste zu erstellen, klickst du einfach einen der beiden Menueinträge an, die hier gezeigt werden. Oder, falls du eingegebenen Text in eine Liste verwandeln willst, markiere den entsprechenden Text (mehrzeilig) im Editor und klicke dann auf einen der Menueinträge.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Hier siehst du zwei Beispiele für eine Liste mit Aufzählungszeichen (unsortiert) und eine nummerierte Liste (sortiert).

VisualEditor lists 3 select to indent.png
Wenn du die Einrückung (Einzug) einer bestehenden Liste verändern möchtest, markiere den Teil der Liste, welchen du verändern willst.

VisualEditor lists 4 indentation menu.png
Dann kannst du über das Menu oder die Tabulator-Taste den Einzug verändern. (Die Tabulator-Taste vergrößert den Einzug; beim gleichzeitigen Drücken der Umschalttaste mit der Tabulator-Taste wird der Einzug verringert.)

VisualEditor lists after indenting.png
So sieht eine Liste mit vergrößertem Einzug aus.

VisualEditor lists mixed.png
In einer Liste können auch Nummern (sortiert) und Aufzählungszeichen (unsortiert) kombiniert werden, wenn die Einträge unterschiedliche Einrückung haben.

Tabellen bearbeiten

VisualEditor insert table-de.png
Du kannst den VisualEditor benutzen, um Tabellen einzufügen und zu bearbeiten.

Du kannst sogar eine Tabelle importieren, indem du eine .csv-Datei von deinem Rechner in das Hauptbearbeitungsfenster ziehst.


Wenn du auf „Tabelle“ in dem „Einfügen“-Menü klickst, fügt der VisualEditor eine leere Tabelle mit vier Zeilen und vier Spalten ein.

Es wird dann ein „Tabellen“-Menü angezeigt. Über dieses Menü kannst du einen Titel über der Tabelle einfügen

VisualEditor empty table.png

Um eine Zelle auszuwählen, klicke sie ein Mal an.
VisualEditor tables select one cell.png

Um den Inhalt einer Zelle zu bearbeiten (z.B. um Inhalt einzufügen oder einen Fehler zu korrigieren), klicke sie zwei Mal an. Du kannst auch die Zelle auswählen und dann die Eingabe-Taste (Return) drücken.

Um die Bearbeitung der Zelle abzuschließen, klicke irgendwo außerhalb der Zelle.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
Sie können eine Spalte oder eine Zeile hinzufügen, verschieben oder löschen.

Du kannst Zellen verbinden: Wähle sie aus und klicke bei „Zellen zusammenführen“ auf „Verbinden“.
VisualEditor tables merge cells.png

Wenn du Zellen verbindest, wird nur der Inhalt einer Zelle behalten; etwaiger Inhalt der anderen Zellen wird dabei gelöscht. Wurde etwas versehentlich gelöscht, kannst du die Schaltfläche „Rückgängig“ in der Toolbar verwenden, den Inhalt verschieben oder kopieren und dann die Zellen erneut verbinden.
VisualEditor tables post-merge cell.png

Du kannst Zellen, die zuvor verbunden wurden, wieder teilen. Alle Inhalte, die in der verbundenen Zelle waren, werden beim Teilen in der ersten Zelle bleiben. Du kannst dann Text ausschneiden und in andere Zellen einfügen, falls du möchtest.
VisualEditor tables split cells.png

Kategorien bearbeiten

VisualEditor category item-de.png
Um die Kategorien zu Bearbeiten klicke im Menü „Seitenoptionen“ auf die „Kategorien“-Schaltfläche.

VisualEditor category editing-de.png
Ein Klick auf „Kategorien“ öffnet ein Dialogfenster, in dem die vorhandenen Kategorien aufgelistet sind und das es dir ermöglicht, neue hinzuzufügen und vorhandene zu löschen.

Dort gibt es auch die Möglichkeit, den (Standard-)Sortierschlüssel der Seite zu ändern, der beeinflusst, an welcher Stelle der Artikel in den Kategorien aufgeführt wird.

Beispielsweise ist beim Artikel „Konrad Adenauer“ die Standardsortierung „Adenauer, Konrad“ damit dieser in der Kategorie „Bundeskanzler (Deutschland)“ unter A und nicht unter K geführt wird.


VisualEditor - Category editing 3.png
Um eine neue Kategorie hinzuzufügen, gib ihren Namen in das Feld "Eine Kategorie hinzufügen" ein. Während der Eingabe wird der VisualEditor passende Treffer auf vorhandene Kategorien anzeigen. Du kannst entweder eine eine bestehende Kategorie auswählen oder eine neue hinzufügen. (Solange die neue Kategorie noch keine eigene Kategorienseite besitzt, wird diese mit einem roten Link aufgeführt.)

VisualEditor - Category editing 2.png
Um eine bestehende Kategorie zu entfernen, klicke sie an und dann in dem sich öffnenden Dialog auf „Entfernen“ (einen Abfalleimer).

Durch einen Klick auf eine Kategorie kann der Sortierschlüssel für diese spezifische Kategorie festgelegt werden. Er überschreibt dann den allgemeinen Sortierschlüssel.


VisualEditor Apply Changes-de.png
Wenn du mit dem Bearbeiten der Kategorien fertig bist, klicke auf „Änderungen übernehmen“, um zum Seiteneditor zurückzukehren.

Seiteneinstellungen bearbeiten

VisualEditor page settings item-de.png
Um die Einstellungen einer Seite zu bearbeiten öffne per Klick das Pulldown-Menü „Seitenoptionen“ in der Werkzeugleiste und klicke auf die „Seiteneinstellungen“-Schaltfläche.

VisualEditor Page Settings-de.png
„Seiteneinstellungen“ öffnet einen Dialog mit mehreren Optionen.

VisualEditor Page Settings Redirects-de.png
Um diese Seite auf eine andere weiterleiten zu lassen setzte ein Häkchen bei „Diese Seite weiterleiten nach“ und gebe dann den Namen der Zielseite ein auf die der Leser geführt werden soll, wenn er den Namen der Seite die gerade bearbeitet wird eingibt.

Am Ende ist ein Option um zu verhindern, dass Seitenumbenennungen diese Weiterleitung aktualisieren. Diese wird jedoch nur in den seltensten Fällen benötigt.


VisualEditor Page Settings TOC-de.png
Mit diesen drei Schaltflächen kann bestimmt werden, ob die Seite ein Inhaltsverzeichnis aufführt. Die Standardeinstellung ist „Falls nötig“ bei der das Inhaltsverzeichnis angezeigt wird, wenn mindestens drei Überschriften vorhanden sind.

VisualEditor Page Settings Edit Links-de.png
Um zu verhindern, dass Bearbeiten-Links neben den Überschriften angezeigt werden, wähle diese Schaltfläche an.

VisualEditor Apply Changes-de.png
Wenn du mit dem Bearbeiten von Seitenoptionen fertig bist, klicke auf „Änderungen übernehmen“, um zum Seiteneditor zurückzukehren.

Bearbeitung von Karten

Visual editor showing editing an existing map.jpg
Sie können Karten hinzufügen und ändern. Siehe Hilfe:VisualEditor/Karten .

Mathematische Formeln bearbeiten

Um eine Vorlage auf der Seite einzufügen, kannst du den Cursor an die gewünschte Stelle setzen und anschließend auf „Math-Formel“ (Σ) im Menü „Einfügen“ klicken.
VisualEditor Formula Insert Menu-de.png

Es öffnet sich ein Fenster in dem die Formel in LaTeX-Syntax eingegeben werden kann. Der VisualEditor wird die Formel während des Schreibens laufend aktualisieren, so dass man sofort das Ergebnis sehen kann. Ist die Formel fertig, klick auf „Einfügen“.
VisualEditor formula-de.png

Um eine bereits vorhandene mathematische Formel zu bearbeiten, klicke auf diese und dann auf das Σ-Symbol um das Formelfenster aufzurufen in dem die Änderungen vorgenommen werden können.
VisualEditor - editing existing mathematical formula.png

Mathematische Formeln können innerhalb des Texts („inline“) oder als separater, zentrierter Absatz („Block“) angezeigt werden.
VisualEditor mathematic formula inline.png

Musiknoten bearbeiten

Um einer Seite eine neue Musiknotation hinzuzufügen, setzen Sie den Cursor an die Stelle, an der die Musiknotation eingefügt werden soll. Wählen Sie dann aus dem Menü "Einfügen" in der Symbolleiste die Option "Musikalische Notation".

Um eine vorhandene Notation auf der Seite zu bearbeiten, drücken Sie doppelt auf sie.

VisualEditor-Insert-Musical-Notation.png

Dies öffnet den Dialog "Musikalische Notation". Hier kann die Notation nach Tonleiter bearbeitet werden, entweder im ABC- oder im Lilypond-Format. Sie können die Notation auch mit einer Audio- oder MIDI-Datei verknüpfen. Wenn Sie fertig sind, klicken Sie auf die Schaltfläche "Fertig", um den Dialog zu schließen und Ihre Änderungen zu veröffentlichen.
Musical.png

Gedichte und andere spezielle Elemente bearbeiten

Manche Elemente, wie zum Beispiel assoziative Listen und Gedichte werden vom VisualEditor derzeit noch nicht vollständig unterstützt.
VisualEditor editing poem 1.png

In den meisten Fällen können bereits vorhandene Elemente bearbeitet, jedoch keine neuen eingefügt werden.

Bis diese voll unterstützt werden, kannst du sie von anderen Seiten kopieren oder den Wikitext direkt bearbeiten.

VisualEditor editing poem 2.png

Wechseln zwischen VisualEditor und Quelltext

Um vom visuellen Editor zum Wikitext-Editor zu wechseln, drücken Sie die Schaltfläche [[ ]] ganz rechts in der Symbolleiste.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

Du siehst dann die Änderungen im Code angezeigt. (Falls du auf „Änderungen verwerfen“ geklickt hast, siehst du einfach das Eingabefeld für den Quelltext (Wikitext).)

Scrolle nach unten, bis du das Eingabefeld für den Quelltext (Wikitext) siehst.

VisualEditor bi-directional switching diff before wikitext.png

Du kannst auch von der Quelltextbearbeitung zum VisualEditor wechseln. Hierfür klicke auf die Schaltfläche mit dem Bleistift rechts in der Werkzeugleiste.

VisualEditor bi-directional switching pencil icon in wikitext.png

Tastenkürzel

Viele Benutzer sind es gewöhnt, Wikitextformatierungen direkt einzugeben, insbesondere Fett-/Kursivschrift und Wikilinks. Die Tastenkombinationen erlauben das schnelle Einfügen ähnlicher Formatierungen, ohne dafür die Werkzeugleistensymbole verwenden zu müssen. Hier sind einige Tastenkombinationen des VisualEditors gelistet:

Tastenkombination (PC) Funktion Tastenkombination (Mac)

Ctrl+B Fett ⌘ Cmd+B

Ctrl+I Kursiv ⌘ Cmd+I

Ctrl+K Link einfügen ⌘ Cmd+K

Ctrl+X Ausschneiden ⌘ Cmd+X

Ctrl+C Kopieren ⌘ Cmd+C

Ctrl+V Einfügen ⌘ Cmd+V

Ctrl+Z Rückgängig machen ⌘ Cmd+Z