Help:VisualEditor/Instrukcja/Szablony cytowania

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Help:VisualEditor/User guide/Citation templates and the translation is 73% complete.

Outdated translations are marked like this.
Other languages:
Cymraeg • ‎English • ‎Tiếng Việt • ‎català • ‎dansk • ‎polski • ‎português do Brasil • ‎română • ‎български • ‎中文 • ‎日本語
PD Uwaga: Jeśli edytujesz tę stronę, wyrażasz nieodwołalną zgodę na udostępnianie Twojego materiału na podstawie wolnej licencji CC0. Zobacz Strony Pomocy w Domenie Publicznej, aby uzyskać więcej informacji.
PD

To jest instrukcja dodawania przypisów na wiki, gdzie skonfigurowano lokalnie obecne szablony cytowania, ale bez skonfigurowanej usługi Citoid.

Pasek narzędzi

Pasek narzędzi edytora wizualnego pojawia się na górze ekranu przy rozpoczęciu edycji.
VisualEditor - Cite Pulldown.png
Menu Przypis: Menu lub przycisk "Przypis" służy do dodawania przypisów. Wszystkie projekty mają dostęp do formatowania "Zwykły przypis" oraz "Użyj istniejącego". To menu umożliwia także szybki dostęp do obecnych lokalnie szablonów cytowania.

(Instrukcja dodawania szablonów cytowania do menu Przypis znajduje się na stronie VisualEditor/Citation tool.)

VisualEditor Insert Menu-pl.png
Wstaw: Menu "Wstaw" może różnić się na niektórych projektach. Znajdują się w nim dwie przydatne do wstawiania przypisów funkcje:
  • Przycisk "Szablon" (ikona puzzla) umożliwia wstawianie i edycję szablonów. Możesz także go wykorzystać do wstawiania szablonów cytowania, tak jak wstawiane są inne szablony. Jeżeli ta opcja będzie użyta w głównej edycji, szablon nie zostanie dodany jako przypis.
  • Ikona "Lista przypisów" (trzy książki) służy do określenie miejsca, w którym czytelnik zobaczy listę przypisów dla strony. Zwykle wystarczy to wykonać raz dla każdej strony. (Jeśli strona już zawiera przypisy, nie musisz klikać tej ikony.) You can also set references group to display using dialog window.

Edycja istniejącego przypisu

VisualEditor - Editing references 1.png
Aby edytować istniejący przypis, kliknij go tam, gdzie się pojawia w tekście (zazwyczaj jako liczba nawiasach kwadratowych). Zostanie wyświetlona ikona "Zwykły przypis" (zakładka) lub inna ikona z nazwą szablonu, który został użyty do utworzenia tego przypisu. Kliknięcie przycisku "Edytuj" spowoduje otwarcie okna dialogowego, w którym można edytować przypis.

VisualEditor - Editing references 6.png
Jeśli edytujesz "Zwykły przypis", kliknięcie na "Edytuj" otworzy okno dialogowe Przypis, gdzie można edytować tekst znajdujący się w przypisie. Edytowanie tego tekstu jest podobne do edycji w głównym oknie - można formatować tekst, dodać łącze lub używać znaków specjalnych.

Jeśli nie jesteś pewien co robisz, nie używaj menu Cytuj ani Wstaw w oknie dialogowym Odwołania.


VisualEditor - Editing References - Cite Web.png
Jeśli zamiast ikony "Zwykły przypis" (zakładka) pojawi się ikona niezdefiniowanego przypisu, kliknięcie przycisku "Edytuj" spowoduje przejście bezpośrednio do okna dialogowego mini-edytora szablonów.

W polskiej wersji Edytora Wizualnego po wybraniu przypisu nie pojawia się typ przypisuj, jak jest to zamierzone. Zamiast tego mamy niezdefiniowany przypis z opisem "Podaj źródło". Problemem może być nieprawidłowo zdefiniowany szablon Cytuj lub błędna implementacja funkcji edytora.


VisualEditor - Editing references 5.png
W mini-edytorze szablonów początkowo wyświetlone będą tylko pola (parametry szablonu) zawierające treść lub jeśli zostały dodane wcześniej. Możesz zmienić zawartość tych pól lub je usunąć.

Aby dodać pola, kliknij "Dodaj więcej informacji" na samym dole mini-edytora.


VisualEditor Apply Changes-pl.png
Gdy skończysz, kliknij "Zastosuj".

Ponowne użycie istniejącego przypisu

VisualEditor Cite menu re-use.png
W idealnej sytuacji, każde zdanie lub ustęp w artykule powinien być poparty cytatem w przypisie. Jeśli masz jakiś tekst, który potrzebuje poparcia cytatem (źródłem), a strona ma już przypis, który odnosi się do tego tekstu, możesz ponownie użyć istniejącego cytatu, ponieważ jeden przypis może odnosić się do wielu różnych zdań lub akapitów.

Aby ponownie użyć istniejącego odniesienia, umieść kursor w treści tekstu, w którym chcesz dodać przypis. Następnie kliknij "Przypis" i wybierz zakładkę "Użyj istniejącego".


VisualEditor - Editing references 18.png
W oknie dialogowym Przypis, przejrzyj listę odnośników i wybierz ten, który chcesz użyć. Jeśli jest dużo przypisów, możesz użyć pola wyszukiwania (opisanego "Wyszukiwanie spośród użytych przypisów"), aby znaleźć tylko te odniesienia, które zawierają określony tekst.

Dodawanie nowego przypisu

Wykorzystanie standardowego szablonu cytowania dla nowego przypisu

VisualEditor - Editing References - Cite Pulldown.png
The "Przypis" menu is used to add a new footnote. First, place your cursor where you want to add a footnote, in the text. Then, from this menu, select a standard citation type in the menu. If the citation type you want is not on the menu, select the "Zwykły przypis" item. (Instructions for adding more citation templates to this menu, on your local wiki, are available at VisualEditor/Citation tool.)

VisualEditor - Editing references - Cite book required fields.png
Clicking on a standard cite template icon such as "Book" will take you into the template mini-editor for that template. While the most common fields (template parameters) will be shown, not all of them are required. Important fields may be marked with an asterisk.

VisualEditor - Editing references - Add parameter.png
To add more parameters, scroll down in the template mini-editor and click on the "Dodaj więcej informacji" option.

Click on "Wstaw" when you're done.

Stworzenie "Zwykłego przypisu"

VisualEditor references more.png
You can also choose the "Zwykły przypis" item from the "Przypis" menu.

The "Zwykły przypis" item is used for two purposes. You can create a footnote that doesn't use any citation template. Or you can create a footnote using a citation template that is not on the "Przypis" menu.


VisualEditor - Editing references 20.png
Shown here is an example of selecting the "Zwykły przypis" item, and then, in the Reference editor, adding text, including formatting, but not using a citation template.

You can make the new footnote belong to a group other than general references, although this is normally not done. (If you do have two or more groups of footnotes, the "Lista przypisów" tool must specify the group of footnotes to be displayed).


In the Reference dialog, you can get to a citation template that is not (yet) on the "Przypis" menu. From the "Wstaw" toolbar menu, click on the Szablon icon (puzzle piece).

VisualEditor - Editing references 9.png
Następnie wpisz nazwę (lub fragment nazwy) szablonu cytatu, który chcesz użyć, wybierz go, kliknij "Dodaj szablon" i uzupełnij go tak, jak w przypadku każdego innego szablonu. (Więcej informacji na temat szablonów znajdziesz w sekcji Edycja istniejącego przypisu w sekcji powyżej).

After you're done editing the template, click on "Wstaw" to return to the Reference editor, and "Wstaw" again to return to the page you're editing.

Dodawanie cytatu bez umieszczania przypisu

How to create a ==Further reading== list using Insert > Template > Cite book (etc.)

VisualEditor Template Insert Menu-pl.png
Możesz dodać szablony cytowania bezpośrednio w artykule, bez umieszczania ich w przypisach. Z menu Wstaw kliknij na "Szablon" (ikona puzzla)

VisualEditor - Editing references 9.png
Następnie wpisz nazwę (lub fragment nazwy) szablonu cytatu, który chcesz użyć, wybierz go, kliknij "Dodaj szablon" i uzupełnij go tak, jak w przypadku każdego innego szablonu. (Więcej informacji na temat szablonów znajdziesz w sekcji Edycja szablonów w podręczniku użytkownika).

Po zakończeniu edytowania szablonu kliknij "Wstaw", aby powrócić do edytowanej strony.