Help:ビジュアルエディター/利用者ガイド/引用テンプレート

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Help:VisualEditor/User guide/Citation templates and the translation is 98% complete.

Other languages:
Cymraeg • ‎English • ‎Tiếng Việt • ‎català • ‎dansk • ‎polski • ‎português do Brasil • ‎română • ‎български • ‎中文 • ‎日本語
PD 注意: このページを編集すると、編集内容が CC0 のもとで公開されることに同意したと見なされます。詳細はパブリック・ドメインのヘルプ ページを参照してください。
PD

このページでは、ユーザーが利用するウィキに地域化された注釈テンプレートは設定されたがcitoid serviceは導入されていない場合に、脚注("注釈"、"本文中の注釈"、"出典" とも呼ぶ)を追加する方法を示しています。

ツールバー

ビジュアルエディターのツールバーの画面キャプチャ
編集を始めると画面上部にビジュアルエディタのツールバーが表示されます。
VisualEditor - Cite Pulldown.png
引用 メニュー: 「引用」メニューあるいはボタンを使って脚注を追加。 出典の書式設定の「基本」とここで説明する注釈を作成する「再利用」は、どのプロジェクトでも利用できます。 このメニューからはまた、地域化された注釈テンプレートに素早くアクセスできます。

(ご利用のウィキの引用メニューに地域化した注釈テンプレートを追加する手順はVisualEditor/Citation toolを参照してください。)

VisualEditor Insert Menu-ja.png
挿入: 「挿入」メニューはプロジェクトごとに異なることがあります。注釈には便利なオプションが2種類。
  • 「テンプレート」アイコン(ジグソーパズルの駒の形)を押すとテンプレートの使用と編集ができます。脚注にしたくない注釈は、これを使って標準的なテンプレートを挿入し注釈を作ります。
  • 「情報源一覧」アイコン(3冊の本の形)は、ページに脚注を表示する場所で押します。通常は1ページに1回使えば充分です。(すでに脚注が表示されたページでは押さないでください。) またダイヤログ枠を利用して、入れ子の脚注も作れます。

既存の脚注の編集

VisualEditor - Editing references 1.png
文中にある脚注の編集は、本文に表示された脚注マークをクリックします(一般に角カッコで囲まれた半角数字)。すると基本アイコン(ブックマーク)もしくはこの脚注の作成に使ったテンプレートとその名前が表示されます。「編集」ボタンをクリックするとダイヤログが開き、脚注の編集ができます。

VisualEditor - Editing references 6.png
「基本」脚注の編集をするときは、「編集」ボタンを押すと出典ダイアログが開き、脚注内の文を編集できます。編集そのものは本文の編集と同じで - 書式設定やリンクの添付、あるいは特殊な文字の使用ができます。

手順を十分に理解しないうちは、注釈ダイアログで「出典」や「挿入」メニューを使わないでください。


VisualEditor - Editing References - Cite Web.png
脚注マークをクリックした時に「基本」アイコン (開いた本の形) 以外のものが表示されたらそれは標準的な出典用のテンプレートで、「編集」ボタンを押すとそのテンプレートの小型のダイアログが開きます。

VisualEditor - Editing references 5.png
テンプレートの小型エディタを開くと、まず内容がある欄 (テンプレートのパラメータ) のみ表示されます。欄の内容を編集したり、不用なら除去することもできます。

欄を追加するには、小型エディタの下辺の「詳細情報を追加」ボタンを押します。


VisualEditor Apply Changes-ja.png
完了したら、「変更内容を適用」を押します。

既存の脚注の再利用

VisualEditor Cite menu re-use.png
理論上は、記事の文章単位で典拠を脚注に補足すればよいのです。要出典(典拠)の文章に使える(補足する)脚注が既にあるなら、流用してください。脚注は複数の文や段落に補足できます。

既存の出典の流用の手順は、本文の脚注を付けたい箇所にカーソルを置きます。次に「引用」メニューの「再利用」をクリックします。


VisualEditor - Editing references 18.png
流用したい出典は、脚注 ダイアログにある一覧から探して選びます。表示された出典が多数なら、検索ボックス (「現在の引用内を検索」ボタン) に文字を入れて絞り込むます。

新しい脚注の追加

標準的な出典テンプレートで脚注を追加

VisualEditor - Editing References - Cite Pulldown.png
「引用」メニューから新しい脚注を追加します。最初に文中の脚注を作る位置にカーソルを置きます。次にメニューへ移り、ボタンのどれかを選択。メニューに使いたいものがない場合は、「基本」の項目を選びます(ご利用のウィキのメニューに注釈テンプレートを追加する方法はこのツールのページで解説しています)。

VisualEditor - Editing references - Cite book required fields.png
メニューにある出典テンプレートから例えば「書籍」ボタンを押すと、そのテンプレート用の小窓が開きます。もっとも多用される欄
(テンプレートの引数) が表示されるものの、場合により使わない欄もあります。米印 (*) が付いた欄は必ず記入します。 

VisualEditor - Editing references - Add parameter.png
引数を追加するには小窓の中を下へスクロール、「詳細情報を追加」オプションをクリック。

完了したら、「挿入」を押します。

「標準」ボタンで脚注を追加

VisualEditor references more.png
「引用」メニューから「基本」を選ぶこともできます。

「基本」項目の使用目的は、注釈テンプレートを使わずに脚注を作るか、「引用」メニューにない注釈テンプレートを使って脚注を作るかの2つあります。


VisualEditor - Editing references 20.png
このサンプルは「基本」を押してから、出典テンプレートを使わない手順を示します。出典エディタを使って記入、フォーマット他を指定します。

新しく追加した脚注を他と区別する方法もありますが、一般的ではありません。 (脚注を2グループ以上に分割するときは、どのグループの脚注を表示するか「情報源一覧」ツールで指定してください。)


VisualEditor Basic citation Insert menu with citation templates-en.png
出典エディタでは「引用」に (まだ) 表示されない出典テンプレートを呼び出すことができます。ツールバーの「挿入」メニューからテンプレートアイコン (ぱずるのかけら) をクリック。

VisualEditor - Editing references 9.png
次に出典テンプレートの名前 (もしくはその一部 ) を入力、表示されたらクリックして

「テンプレートを追加」ボタンを押すと、他のテンプレート同様に編集できます (テンプレートの詳細は#Editing templates (草稿) をご参照ください。)

テンプレートの編集が終わったら、「挿入」を押すと出典エディタに戻り、もう一度「挿入」を押すと編集していた元のページに戻ります。

脚注以外のところに注釈を追加

How to create a ==Further reading== list using Insert > Template > Cite book (etc.)

VisualEditor Template Insert Menu-ja.png
脚注節を作らなくても、あるいは基本機能の出典エディタを使わなくても、記事本文に直接、出典テンプレートを追加できます。「挿入」メニューを開き「テンプレート」アイコン(パズルのかけら)をクリック。

VisualEditor - Editing references 9.png
記入欄に使いたいテンプレートの名前(の冒頭の数文字)を入力すると候補が表示されるので、青字の表示をクリックして「追加」ボタンを押すとテンプレートの窓が開きます。各欄の記入の方法はほかのテンプレートと共通です (ユーザーガイドのテンプレートの編集節に詳しい説明があります。)

テンプレートの編集が終わったら、「挿入」を押すと出典エディタに戻り、もう一度「挿入」を押すと編集していた元のページに戻ります。