Fatal error: require once()/pl

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Fatal error: require once() and the translation is 11% complete.

Other languages:
Deutsch • ‎English • ‎dansk • ‎español • ‎français • ‎italiano • ‎magyar • ‎occitan • ‎polski • ‎português • ‎português do Brasil • ‎русский • ‎日本語

During installation of mediawiki 1.16, you can have the bug:

'''Warning:''' require_once(includes/Defines.php) [function.require-once]: failed to open stream: No such file or directory in
/mnt/155/sdb/4/5/yoursite/Wiki1.16/config/index.php  on line 42

'''Fatal error:''' require_once() [function.require]: Failed opening required 'includes/Defines.php'
(include_path='/mnt/155/sdb/4/5/yoursite/include:.:/usr/php5/lib/php') in /mnt/155/sdb/4/5/yoursite/Wiki1.16/config/index.php
on line 42

This is due to your server which could not accept the ini_set function.

Solution

The only solution for using the 1.16 is: replace IN EVERY FILES this:

require( "..." );

require_once( "..." );

by

require( "$IP/..." );

require_once( "$IP/..." );

Przykład

Replace

require( "includes/Defines.php" );

require_once( "includes/Defines.php" );

by

require( "$IP/includes/Defines.php" );

require_once( "$IP/includes/Defines.php" );