Before several coder begin to work on central modules themselves and many coders use them as tools, and to avoid many confusions, we must choose names of libraries and of their main functions.
How to distribute functions in one or some libraries?
How to name also main functions of these libraries?
How to continue the actual library names, add the central modules ones and do not constrain future developments?
See a draft base to talk in Central modules
- How to name actual centre library? center, central, centralize, centralizer?
- table is very ambiguous, presently :
- as 2 dimensional matrix in math, not used now in central modules. To rename math.table or how?
- luatable as a LUA table,
- in tools.luatable_lister which lists the structure of a LUA table. To rename table.view or table.list or how?
- in tools.luatablecount and tools.luatables_counts. which count numbers of vars, functions and tables of a LUA table To rename table.count and table.counts or how?
- tableview as a table to display with columns, rows, headers, footers, sortable or not.
- Now it is drawn from tools.Th(t), tools.Tc(t), tools.Tr(t), tools.Td(t), tools.Te(t).
- Now we can draw them with first and intermediate headers.
- In future we could draw them horizontal or draw with some headers and footers and lefters and righters. Also even draw circular like flowers in 3D.
- Do we rename them viewers.table or viewers.tableview, in a new library or how?
- in tools.luatable_lister which list the structure of a LUA table. To rename table.view and table.views or how?
- Another group is subject to rename, they are tranlators of parametric texts, containing %1 %2 %3 ... , in userlang and wikilang, based on tools.string_vars to collect and translate, form and display groups of strings, errors, messages, categories.
- Now they are named tools.str_vars, tools.cat_add, tools.catGroup, tools.err_add, tools.errGroup, tools.msg_add, tools.errors_lister, and so on...
- Do we rename them groupviews.err, groupviews.errGroup, groupviews.errList, ... or how?
- Do we rename them viewsgroup.err, viewsgroup.errGroup, viewsgroup.errList, ... or how?
- Do we rename them translist.err, translist.errGroup, translist.errList, ... or how?
- In viewers we also could put tools.dropbox and tools.dropdownfunc.
- Do we rename them viewers.dropbox and viewers.dropdownfunc, ... or how?
- TestCases are now in tools.TestsCases_report and so on.
- Do we rename them TestCases.report and so on, in a new library ... or how?