Extension talk:ChapTimeline

Jump to navigation Jump to search

About this board

Smith.dan (talkcontribs)

In recent versions of MediaWiki (1.29, 1.31), I've found it necessary to patch ChapTimeline.class.php as follows:

$wgOut->getTitle()

gets replaced with

$wgOut->getTitle() ?: Title::newMainPage()

in two places.

Before doing so, no timeline was displayed, and some maintenance scripts crashed. Afterwards, it seems to behave properly.

Reply to "Patch for compatibility"

The future of this extension

3
Sabretache (talkcontribs)

Upgrading to MW 1.22 from 1.21.3 has broken a reasonably functional implementation of the existing Timeline results format which is also no longer maintained (See here). This is further reason why the Chaps Timeline format should have a worthwhile future. However, I have still been unable to get it to work. On the Latest MW release, it fails to display any results and without a displayed error before trying to contact the Google api. Suggestions anyone?

Sabretache (talkcontribs)

The latest GIT updates have this working a treat now. It could just do with having more of the library-available facilities implementing on this MW version. In particular I would like to be able to define an initial zoom level by reference to say, screen-visible start and end date/time parameters and a 'center-on' date/time parameter. There are bags more possibilities illustrated at the library demo site

Fractalfederation (talkcontribs)

When I run rebuildData.php for SMW I am getting an error:

PHP Catchable fatal error: Argument 2 passed to Parser::parse() must be an instance of Title, null given, called in extensions/ChapTimeline/ChapTimeline.class.php on line 243 and defined in includes/parser/Parser.php on line 391

Catchable fatal error: Argument 2 passed to Parser::parse() must be an instance of Title, null given, called in extensions/ChapTimeline/ChapTimeline.class.php on line 243 and defined in includes/parser/Parser.php on line 391

Posted as issue on Git with more info.

Reply to "The future of this extension"

ChapTimeline doesn't display anything

2
Rainer Klute (talkcontribs)

I installed Semantic MediaWiki and ChapTimeline today, but couldn't get the latter to work. My #ask query works okay, i.e. it displays data nicely as long as the "format" parameter is not "chap-timeline". If it is, the generated HTML is

<div class="chap-timeline"><div id="chap-timeline-1" class="container"></div></div>

but nothing is displayed there.

I also installed the InteractiveTimeline extension which works flawlessly.

Thanks for consideration!

MichaelZ70 (talkcontribs)

I had the same problem. Please check if you have two date fields selected first. my query looks like thisː

{{#ask:[[Date2::+]]
|?Date2
|?Date1
|?Project
|?User
|mainlabel=-
|format=chap-timeline
<!-- Parameter for Chap-Timeline -->
|startproperty=Date1
|endproperty=Date2
|height=auto
|zoomable=true
}}
Reply to "ChapTimeline doesn't display anything"

Use of the parameters 'scale' and step

1
MichaelZ70 (talkcontribs)

Is there any possibility to use the parameters scale and step as described in the Configuration Options? I tried to enter the parameters but there is no change. Automatic scaling is still enabled.

Reply to "Use of the parameters 'scale' and step"

Has anyone got this to work

3
Sabretache (talkcontribs)

I have spent quite a while trying to get this extension to work, including exchanges with it's author, but to date without success. The extension fails whilst attempting to connect to the Google api. If there is anyone out there who does have it working I'd be grateful for a heads up and any pointers to how you did it. FI, my test installation is here.

129.13.72.196 (talkcontribs)

Today I installed the newest version (Version 0.1) via git - everything works just fine! Cheers, Basil

129.13.72.196 (talkcontribs)

forgot to mention: MediaWiki 1.21.2, Semantic MediaWiki 1.8.0.4

Reply to "Has anyone got this to work"
Gborgonovo (talkcontribs)

I am using MediaWiki 1.22.3, Semantic MediaWiki 1.9.1.1 and ChapTimeline 0.1 (cloned with Git). I am getting dates on the wrong day, moved ahead of one month. For example, 2014/1/1 is shown on 2014/2/1. What can I do to troubleshoot this issue? Thank you.

Sabretache (talkcontribs)

It's known to the extension author. It's the result of javascript months numbering from 0 to 11 and should be fixed on a < 1 month timeframe

Reply to "Garbled dates"

Can anyone post detailed instructions on how to install this extension?

5
Zzmonty (talkcontribs)

I am using MediaWiki 1.22. I uploaded the extension to the extension directory with the folder name ChapTimeline. I then added the require_once( "$IP/extensions/ChapTimeline/ChapTimeline.php" ); to the LocalSettings.php. But when I add the sample code as follows, it does not work:

{{#ask:Myprop::+ |?Start date |?End date |height=600px |cluster=true |format=chap-timeline |startproperty=Start date |endproperty=End date }}

What am I doing wrong? Zzmonty (talk) 14:22, 2 March 2014 (UTC)

Sabretache (talkcontribs)

Your install/setup and query look OK to me.

FI, My queries below are now void in that I have the extension working fine. I just need some enhancements to be coded by the author (or somebody) before converting fully from the Simile-based ResultFormat.

My only suggestions involve versions. You do need the latest SMW + validator (which I think is now bundled by the Composer install process) Also the latest ChapTimeline code from Git.

Zzmonty (talkcontribs)

I do not know what I am doing wrong. I have a page that has a timeline on it:

http://researchwithconfidence.com/w/index.php?title=From_Colonies_to_Independence:_the_American_Revolution

But the problem is that when an event takes place over only 1 year, you can't see the text of the box. I tried all three options of "none", "box", and "dot", and none of them seem to fix the problem. The example show a dot on the bottom with a line to the box and the whole text of the box being display. But I can't seem to get that to work. The only text that I see is when the even takes place over a number of years. Do you have any idea what I am doing wrong?

Zzmonty (talkcontribs)

This is what i have installed:

  • Semantic Bundle (Version 1.8.0.5.3)
  • Semantic MediaWiki (Version 1.8.0.5)
  • [ ChapTimeline] (Version 0.1)
  • Validator (Version 0.5.1)

The strings don't seem to be reading in correctly for the ChapTimeline.

Sabretache (talkcontribs)

The best I can offer is that I had to u/grade to SMW 1.9 and the latest zip file on the ChapTimeline repository before I got it to work - but it does work now. It is both consistent and reliable, though in need of enhancements and correction of a years/months/days anomaly on the bottom scale.

Reply to "Can anyone post detailed instructions on how to install this extension?"
There are no older topics