Extension:UploadBlacklist

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Extension:UploadBlacklist and the translation is 100% complete.
Other languages:
English • ‎Türkçe • ‎español • ‎polski • ‎中文 • ‎日本語
MediaWiki manüel uzantıları
OOjs UI icon advanced.svg
UploadBlacklist
Sürüm durumu: kararlı
Uygulama Kullanıcı etkinliği
Açıklama Artık yüklenemeyen sha1 karmalarıyla bir dizinin yapılandırılmasına izin verir
Yazar(lar) Brion Vibber (Brion VIBBERtalk)
MediaWiki 1.25+
Lisans GNU Genel Kamu Lisansı 2.0 veya üstü
İndir
  • $ubUploadBlacklist
Translatewiki.net adresinde mevcutsa, UploadBlacklist uzantısını çevirin
Kullanım ve sürüm matrisini kontrol edin.
Sorunlar Açık görevler · Hata bildir

İndir

Uzantı doğrudan Git'ten alınabilir [?]:

  • Kodu göz at
  • Bazı uzantıların kararlı sürümler için etiketleri vardır.
  • Her dal geçmiş bir MediaWiki sürümüyle ilişkilendirilmiştir. Ayrıca en son alfa sürümünü içeren bir "ana" dalı da vardır (MediaWiki'nin alfa sürümünü gerektirebilir).

Anlık görüntüyü ayıklayın ve MediaWiki kurulumunuzun extensions/UploadBlacklist/ dizinine yerleştirin.

Git'e aşina iseniz ve sunucunuza kabuk erişiminiz varsa, uzantıyı aşağıdaki gibi elde edebilirsiniz:

cd extensions/
git clone https://gerrit.wikimedia.org/r/mediawiki/extensions/UploadBlacklist.git

Kurulum

  • İndir ve dosyaları extensions/ klasörünüzdeki UploadBlacklist adlı bir dizine yerleştirin.
  • LocalSettings.php dosyanızın altına aşağıdaki kodu ekleyin:
    wfLoadExtension( 'UploadBlacklist' );
    $ubUploadBlacklist = array ('hash1', 'hash2', ...)
    
  • Yes Yapıldı – Uzantının başarıyla yüklendiğini doğrulamak için vikinizde Special:Version seçeneğine gidin.

MediaWiki 1.24 veya önceki bir sürümü çalıştıran kullanıcılara:

Yukarıdaki talimatlar, bu eklentiyi wfLoadExtension() kullanarak kurmanın yeni yolunu açıklar. Bu uzantıyı önceki sürümlerine (MediaWiki 1.24 ve önceki sürümler) yüklemeniz gerekirse, wfLoadExtension( 'UploadBlacklist' ); yerine kullanmanız gerekir:

require_once "$IP/extensions/UploadBlacklist/UploadBlacklist.php";