Extension:UploadBlacklist/pl

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Extension:UploadBlacklist and the translation is 25% complete.
Other languages:
English • ‎Türkçe • ‎español • ‎polski • ‎中文 • ‎日本語
Podręcznik rozszerzeń MediaWiki
OOjs UI icon advanced.svg
UploadBlacklist
Status wydania: stabilne
Realizacja Aktywność użytkownika
Opis Allows configuration of an array with sha1 hashes which can then no longer be uploaded
Autor(zy) Brion Vibber (Brion VIBBERtalk)
MediaWiki 1.25+
Licencja GNU General Public License 2.0 or later
Pobieranie
  • $ubUploadBlacklist
Przetłumacz rozszerzenie UploadBlacklist jeżeli jest dostępne na translatewiki.net
Sprawdź wykorzystywanie i matrycę wersji.
Problemy Otwarte zadania · Zgłoś błąd

Download

The extension can be retrieved directly from Git [?]:

  • Browse code
  • Some extensions have tags for stable releases.
  • Each branch is associated with a past MediaWiki release. There is also a "master" branch containing the latest alpha version (might require an alpha version of MediaWiki).

Extract the snapshot and place it in the extensions/UploadBlacklist/ directory of your MediaWiki installation.

If you are familiar with git and have shell access to your server, you can also obtain the extension as follows:

cd extensions/
git clone https://gerrit.wikimedia.org/r/mediawiki/extensions/UploadBlacklist.git

Instalacja

  • Pobierz i umieść plik(i) w katalogu o nazwie UploadBlacklist w swoim katalogu extensions/.
  • Dodaj poniższy kod na dole swojego pliku LocalSettings.php:
    wfLoadExtension( 'UploadBlacklist' );
    $ubUploadBlacklist = array ('hash1', 'hash2', ...)
    
  • Yes Zrobione – Przejdź do Special:Version na swojej wiki, aby sprawdzić czy rozszerzenie zostało pomyślnie zainstalowane.

Do użytkowników mających wersję MediaWiki 1.24 lub wcześniejszą:

Powyższe instrukcje opisują nowy sposób instalowania tego rozszerzenia, poprzez wfLoadExtension(). Jeżeli chcesz zainstalować to rozszerzenie we wcześniejszych wersjach (MediaWiki 1.24 i wcześniejsze), zamiast wfLoadExtension( 'UploadBlacklist' ); użyj:

require_once "$IP/extensions/UploadBlacklist/UploadBlacklist.php";