Extension:OpenLayers

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Extension:OpenLayers and the translation is 50% complete.

Other languages:
English • ‎asturianu • ‎polski • ‎日本語
MediaWiki 拡張機能マニュアル
OOjs UI icon advanced.svg
OpenLayers
リリースの状態: 安定
説明 Makes OpenLayers module available
作者 Paladox, Yaron Koren
最新バージョン 1.0.0 (2016-01-21)
MediaWiki 1.23+
PHP 5.4+
データベースの変更 いいえ
ライセンス GNU General Public License 2.0 or later
ダウンロード
translatewiki.net で翻訳を利用できる場合は、OpenLayers 拡張機能の翻訳にご協力ください
使用状況とバージョン マトリクスを確認してください。
問題点 未解決のタスク · バグを報告

The OpenLayers extension makes the OpenLayers module available.

インストール

  • ダウンロードして、ファイルを extensions/ フォルダー内の OpenLayers という名前のディレクトリ内に配置します。
  • 以下のコードを LocalSettings.php の末尾に追加します:
    wfLoadExtension( 'OpenLayers' );
    
  • Yes 完了 – ウィキの「Special:Version」に移動して、拡張機能が正しくインストールされたことを確認します。

MediaWiki 1.24 以前を稼働させている利用者へ:

上記の手順では、wfLoadExtension() を使用してこの拡張機能をインストールする新しい方法を記載しています。 この拡張機能をこれらの過去のバージョン (MediaWiki 1.24 以前) にインストールする必要がある場合は、wfLoadExtension( 'OpenLayers' ); の代わりに以下を使用する必要があります:

require_once "$IP/extensions/OpenLayers/OpenLayers.php";