Extension:LuaLexer

From mediawiki.org
Jump to navigation Jump to search
MediaWiki extensions manual
OOjs UI icon advanced.svg
LuaLexer
Release status: experimental
Implementation API
Description Provides Lua lexer for Scribunto.
Author(s)
Compatibility policy Master maintains backwards compatibility.
MediaWiki 1.36 Not formally tested
MediaWiki 1.34 Not formally tested
MediaWiki 1.32 Not formally tested
Database changes No
License GNU General Public License 2.0 or later
Download
README, LDoc
Translate the LuaLexer extension

Check usage and version matrix.

This extension is still under development!

LuaLexer provides a lexer for Scribunto modules.

Installation[edit]

LuaLexer depends on modules from the Scribunto extensions.

  • Download and place the file(s) in a directory called LuaLexer in your extensions/ folder.
  • Add the following code at the bottom of your LocalSettings.php:
    wfLoadExtension( 'LuaLexer' );
    
  • Yes Done – Navigate to Special:Version on your wiki to verify that the extension is successfully installed.

Usage[edit]

For further help, see the generated LuaLexer documentation.

Development[edit]

For recreating the Vagrant-based development environment, see LuaLexer: Topics/Vagrant.

See also[edit]

External links[edit]