Compatibilidade

From mediawiki.org
Jump to navigation Jump to search
This page is a translated version of the page Compatibility and the translation is 90% complete.
Outdated translations are marked like this.

O MediaWiki se esforça para manter ampla compatibilidade entre as versões, e com uma gama de softwares atuais e antigos. Ao mesmo tempo, não será possível manter a compatibilidade com o software antigo indefinidamente, devido a características do mais recente desenvolvimento da MediaWiki, e visto que a base de código está em constante evolução.

Se você deseja sugerir uma mudança para o suporte do MediaWiki, você pode enviar uma solicitação de comentário em Phabricator.

Software de servidor

Essas seções fornecem uma visão geral do software necessário no servidor para executar o MediaWiki.

PHP

A última ramificação estável do MediaWiki (1.37) roda em qualquer versão do PHP $2 a partir de 7.3.19/7.4.3 e superior, e qualquer versão do PHP $4 a partir de $3 e superior.

Para as próximas versões, consulte Support policy for PHP .

O suporte a HHVM foi eliminado no MediaWiki 1.34. Você é fortemente desaconselhado a usá-lo.

O MediaWiki é não compatível com o PHP 7.3.0 - 7.3.18 e 7.4.0 - 7.4.2 devido a um erro do upstream. Use PHP 7.3.19+ ou 7.4.3+ em seu lugar. Consulte tarefa T246594 para mais informações.
MediaWiki ainda não é compatível com PHP 8. Veja task T248925 para maiores informações.
1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 1.34 1.35 1.36 1.37 master
 7.4.3+
 7.3.19+
 7.2.x 
 7.1.x 
 7.0.x 
 5.6.x 
 5.5.9+ 
 5.5.0–5.5.8 
 5.4.x 
 5.3.3+ 
1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 1.34 1.35 1.36 1.37 master
 5.3.2 
 5.2.3+ 
 5.1.x 
 5.0.x 
1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 1.34 1.35 1.36 1.37 master

Base de dados

O MediaWiki é compatível com muitos servidores de banco de dados, embora para o MySQL o suporte é melhor. (O MariaDB também pode ser usado.)

O status de suporte para outros softwares de banco de dados varia de fraco para razoável. O MediaWiki fornece camadas de abstração da base de dados para PostgreSQL e SQLite, que geralmente são bem mantidas.

Since version 1.36, MediaWiki only commits to supporting upgrades from two major long term support releases (LTS) ago (see phab:T259771). Upgrades from older versions of MediaWiki will have to be performed in multiple steps.
Atenção Atenção: Since MediaWiki 1.34 , we no longer support using Oracle and Microsoft SQL Server . We strongly advise to no longer to use these.
1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 1.34 1.35 1.36 1.37 master
 MySQL 5.5.8+
 MySQL 5.0.3+  
MySQL 4.x 
MySQL 3.x 
 SQLite 3+
 PostgreSQL 9.4+
 PostgreSQL 9.2+  
 PostgreSQL 8.3+  
 PostgreSQL 8.1 
1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 1.9 1.10 1.11 1.12 1.13 1.14 1.15 1.16 1.17 1.18 1.19 1.20 1.21 1.22 1.23 1.24 1.25 1.26 1.27 1.28 1.29 1.30 1.31 1.32 1.33 1.34 1.35 1.36 1.37 master

Upgrade

Since MediaWiki 1.36, it only commits to supporting upgrades from two LTS releases ago (see phab:T259771). Upgrades from older versions of MediaWiki will have to be performed in multiple steps. This means that if you want to upgrade to 1.36 from 1.23 or earlier, you'll first have to upgrade your 1.23 wiki to 1.27 (or 1.35), and, from 1.27 (or 1.35), you'll be able to upgrade to 1.36.

Servidor Web

O MediaWiki é amplamente compatível com todos os principais servidores da Web que podem invocar uma versão compatível do PHP. O Apache é o mais usado e testado. Nginx é uma boa escolha também.

Extensões do MediaWiki

Enquanto uma extensão é mantido adequadamente (o que você pode ver no topo da infobox em sua página de descrição), a ramificação principal da extensão deve ser compatível com a ramificação principal do MediaWiki. Para determinar a compatibilidade com versões mais antigas do MediaWiki, existem as seguintes políticas comuns usadas por extensões:

  • master (chave: master): o ramo master da extensão é compatível com as versões atuais e antigas do MediaWiki. Os hacks de compatibilidade posterior são adicionados ao código-fonte da extensão conforme necessário.
  • release branches (chave: rel): Para cada lançamento do MediaWiki, existe um ramo correspondente na extensão. Então, por exemplo, se você usa o MediaWiki 1.37, você deve usar o ramo REL1_37 da extensão.

So e.g. if you use MediaWiki 1.35, you should use the REL1_35 branch of the extension. If you use a non-LTS version of MediaWiki, usually you will need to use the extension's branch for the previous LTS version. For instance, MediaWiki 1.34 wikis using a ltsrel extension would usually use the REL1_31 branch of that extension. However, there is no guarantee of compatibility.

O campo da política de compatibilidade do infobox Extension informa qual política é usada por uma determinada extensão. Use as respectivas chaves indicadas acima para especificar as informações.

Algumas extensões podem ter políticas de compatibilidade mais específicas, por exemplo:

Navegadores

Informação geral

Há um número cada vez maior de navegadores diferentes no mundo.

Muitos para testar e apoiar ativamente cada um. Para orientar nossas práticas em torno do suporte ao navegador, temos três níveis de suporte. Cada camada representa uma categoria diferente de navegadores.

Moderno (Grau A)

Este grupo (também conhecido como Grade A) representa o nível mais alto de suporte. Os recursos aproveitam os recursos dos navegadores modernos, ao mesmo tempo em que permitem um retorno interessante para navegadores mais antigos. Todos os recursos fornecidos pelo software (com ou sem degradação) devem funcionar nesses navegadores.

Os navegadores nesta categoria são conhecidos (listados abaixo) e foram ativamente testados contra. Os problemas que os usuários percebem nesses navegadores são tratados com .alta prioridade..

Básico (Grau C)

O grupo (também conhecido como Grade C) é fornecido com a funcionalidade principal da plataforma MediaWiki. Nossas respostas HTTP são compatíveis com esses navegadores (por exemplo, recursos HTTP nos quais dependemos, codificação de caracteres e formatos de imagem usados pelo conteúdo; devem funcionar nesses navegadores). No front-end, isso significa que o conteúdo é apresentado de uma maneira legível e, até certo ponto, as ações do usuário podem ser executadas, mas esses navegadores não obtêm recursos JavaScript.

Os navegadores nesta categoria são conhecidos (listados abaixo) e identificados no conjunto de testes de recursos e um filtro de agente de usuário no módulo de inicialização.

Desconhecido (Grau X)

Este grupo (também conhecido como Grade X) representa todos os outros navegadores. Isso inclui navegadores que não são mais desenvolvidos ou navegadores não são populares o suficiente para justificar o custo de manutenção adicional para o desenvolvimento de software.

Navegadores não incluídos em nenhum outro grupo pertencem a esta categoria.

Os problemas que os usuários percebem nesses navegadores recebem apenas baixa prioridade, ou nem mesmo recebem algum suporte.

O MediaWiki lida com esses navegadores da mesma forma que os navegadores modernos (Grau A) e, portanto, eles são considerados capazes. Este princípio fornece vários benefícios importantes:

  • Versões novas ou não suportadas de navegadores modernos podem ser temporariamente consideradas Desconhecidas se ainda não foram testadas por nós. Tratar os navegadores desconhecidos como capazes garante uma ótima experiência do usuário nesses navegadores.
  • Os usuários de navegadores novos e em evolução têm a chance de ter uma experiência moderna.
  • Os usuários de navegadores menos populares baseados em, ou derivados de, navegadores modernos conhecidos não são afetados negativamente ( por exemplo, Iceweasel).

Na prática, a única diferença entre os navegadores Desconhecido e Moderno é que não testamos ativamente em navegadores Desconhecidos.

Esses navegadores recebem o conjunto completo de recursos, o que significa que os recursos HTTP, HTML, CSS e JS podem ou não ser compatíveis com esses navegadores e podem ou não ser afetados por medidas (por exemplo, CSS substituto para recursos CSS mais recentes) destinados aos Navegadores de Grau C. Em particular, o JavaScript será desativado se nenhum suporte para os recursos usados pelo MediaWiki for encontrado.

Tratamento especial para IE11

A partir de março de 2021, novos recursos JavaScript em qualquer projeto da Wikimedia não serão suportados no IE11, conforme documentado em Compatibility/IE11 . Este é o começo do downgrade deste navegador para suporte básico (grau C).

Matriz de suporte do navegador

Embora os princípios e as diferentes classificações descritas acima se apliquem ao núcleo e às extensões do MediaWiki, a matriz de suporte abaixo do navegador aplica-se apenas ao núcleo do MediaWiki (e às extensões que decidem segui-lo). Extensões individuais podem ter sua própria matriz de suporte distribuindo navegadores entre os diferentes níveis de suporte. Veja também painel de análise do agente do usuário analítico para desktop.

Matriz de suporte do navegador a partir de março de 2021 v · d · e
Navegadores Chrome Firefox Opera Edge Edge legado Internet Explorer Safari iOS Android
Moderno (nota A) Versão atual e anterior (2021) Nenhum 11+ (2013)[1][2][3][4] 9.1+[5] 9+[5] 4.3+[5]
Básico (nota C) 31+ (2013)[6] 27+ (2014)[6] 18+ (2013)[6] 79+ (2020) 12+(2015) 9+ (2011)[7][6] 9.1+ (2015)[6] 9+ (2015)[6] 4.3+ (2013)[7][6]
Desconhecido (nota X) Todos os outros navegadores

Mobile

A equipe da Web na Wikimedia Foundation aplica uma matriz de suporte mais restrita para temas específicos para celular por exemplo, Minerva e/ou extensões projetadas apenas para funcionar em dispositivos móveis por exemplo, MobileFrontend . A matriz de suporte é compilada a partir dos dados fornecidos pelo painel de análise do agente do usuário analítico. Onde o uso do navegador é superior a 5%, uma experiência moderna(Grade A) é suportada. O suporte básico (Grau C) é fornecido para algo acima de 0,1% durante os 12 meses anteriores. Em dispositivos móveis, nos esforçamos para fornecer uma nota B. Usuários de nota B podem ou não obter JavaScript e nós não testamos no mesmo nível que A, portanto, priorizamos correções de bugs mais baixas.

A lista de navegadores de suporte moderno no MobileFrontend é definida no arquivo .browserlistsrc.

Qualquer coisa ausente na lista ou mais antiga é considerada um navegador com suporte básico.

Notas

  1. A partir do MediaWiki 1.24, o JavaScript para Internet Explorer 6 e 7 foi desativado. gerrit:152072, gerrit:152128, Wikitech-ambassadors message
  2. A partir do MediaWiki 1.27, o JavaScript para Internet Explorer 8 foi desativado. gerrit:252383, Wikitech-ambassadors message
  3. A partir do MediaWiki 1.29, o JavaScript para o Internet Explorer 9 foi desativado junto com outros navegadores não-ES5. T128115
  4. A partir do MediaWiki 1.31, o JavaScript para o Internet Explorer 10 foi desativado. T187869
  5. 5.0 5.1 5.2 As of MediaWiki 1.36, Modern support is removed for Android 4.1-4.2, iOS 6.1-8, and Safari 5.1-8. T266866
  6. 6.0 6.1 6.2 6.3 6.4 6.5 6.6 As of MediaWiki 1.36, Basic support is removed for Firefox 3-26, Internet Explorer 8, Safari 3-8, iOS (Safari) 5-8, Android 3.0-4.2, Chrome 1-30, and Opera 15-18. T248061, T262946, T266866
  7. 7.0 7.1 A partir do MediaWiki 1.35, o suporte básico para Internet Explorer 6 e 7 foi interrompido. T232563, T249788

Ver também