For MediaWiki (recent comments | status changes | tags | authors | states | release notes | statistics)
Wouldn't it be more consistent to name them:
like we already have:
Actually the current consistency is that month is zero-padded by default and day is unpadded by default.
If we do the proposed change with REVISIONMONTH we should also do this CURRENT/LOCALMONTH.
Subscribing to this revision notification. I am writing unit tests for this.
I am still working on the tests although I did not made any progress with the Xmas break ;-b
test suite with r81414. Still need to decide what we want to do.
Can we please just decide something? This has been sitting here for almost a year now. One way or the other, pick one.
Ping Raymond, Matěj, Hashar, please.
It has been deployed like this already, so changing it would break stuff. I'd say we'll keep it as it is and mark this ok.
I personally don't care. I was just raising the possible inconstancy enlighten by r81414 tests:
[x] Currentday is un padded
[x] Currentdaytwo is zero padded
[x] Localday is un padded
[x] Localdaytwo is zero padded
[x] Currentmonth is zero padded
[x] Currentmonthone is un padded
[x] Localmonth is zero padded
[x] Localmonthone is un padded
[x] Revisionday is un padded
[x] Revisiondaytwo is zero padded
[x] Revisionmonth is zero padded
[x] Revisionmonthone is un padded
It should be revisionmonttwo to be consistant with our other uses.
Has already been deployed and almost released. Let's not break stuff again, so marking this as ok.