For MediaWiki (recent comments | status changes | tags | authors | states | release notes | statistics)
Hook names conventionally start with a capital letter, and omit the verb, because there is a little-known feature in Hooks.php which adds "on" to the start of the hook name to make a method name. This hook should be called "OtherBlockLogLink". Also in the documentation, the parameter should be given a more sensible name, like $ip, rather than $this->ip.
The screenshot on r58323 looks nice.
Thanks for CR.