Project:Support desk/Sections/Installation

From MediaWiki.org
Jump to: navigation, search
This page is no longer used.
Please ask questions on the new support desk.


Installation/Legalities Support[edit | edit source]

Page Linking Help Needed[edit | edit source]

Hi, is there a plugin that automatically links key words to other Wiki pages? At the moment I am manually creating links but I'm sure there must be another way?

Any help would be much appreciated!

Mediawiki Appliance Version 1.13.20 Problems[edit | edit source]

Downloaded rPath Mediawiki Appliance, Running it on VMwear PLayer but can't find the localsettings.php file to edit.

Can't find much documentation. Any help or documentation would be great!

Extension Licensing Guidelines[edit | edit source]

I was wondering if there were licensing guidelines for extensions. I am combined several extensions with MediaWiki and noticed that some of the extensions have licenses that are incompatible with other extensions (e.g. Affero v.3 with a majority of extensions under GPL v.2). There are also several extensions that have no license indicated--is there a default license if you are coding for combination with MediaWiki? I was wondering if there was already guidance or if there could be some written on these topics. Thanks.

mySQL database username[edit | edit source]

  • MediaWiki version: 1.15.1
  • PHP version: 5.2.9
  • MySQL version: 5.1.33

I am configuring MediaWiki, except the one part I am having problems with is when it is asking me for a database username and password and confirm password. Below that is the superuser account, which is root.


>>>Granting user permissions... Query "GRANT DELETE,INSERT,SELECT,UPDATE,CREATE TEMPORARY TABLES ON `wikidb`.* TO 'username'@'%' IDENTIFIED BY 'password' " failed with error code "Can't find file: 'user' (errno: 2) (localhost)". <<<<


But it will not let me continue the configuration unless I specify a user and password since it will not let me leave it blank.

I am installing on Windows XP, just need some help with this issue. I am not very familiar with databases, i know the root user account info, but it is asking for a username and password and confirm password.

Any help would be much appreciated.


homerm@rosedale.ca

FIX: provide the user with ALTER, INDEX rights as well

What server variables are needed[edit | edit source]

My neywork admin needs to set server variables to allow the upload to be successful...

Trying to load to www.high12.org,

current php and all info can be seen at www.high12.org/phpinfo.php

currently receive "?"s when attempt to load php is made...admin requesting server settings needed

attempted to register for the forum but never receive conformation email...so hear i am.

I am not able to open setup wiki page, getting the following error[edit | edit source]

Getting PHP 5.2.1 installed Could not find a suitable database driver! Issue while Installing Mediawiki. 妈的,啥意思啊,奶奶的个熊

  • MediaWiki version: 1.15.1
  • PHP version: 5.2.12
  • MySQL version: MySQL Server 5.1
  • OS: FreeBSD 8
  • URL: http://localhost/wiki


I am not able to open setup wiki page, getting the following error:

MediaWiki 1.15.1 Installation

   * Don't forget security updates! Keep an eye on the low-traffic release announcements mailing list.

Checking environment...

Please include all of the lines below when reporting installation problems.

   * PHP 5.2.12 installed

Installation Issue: Access denied for user root@localhost to datbase 'wikidb'[edit | edit source]

  • MediaWiki version: 1.15.3
  • PHP version: 5.2.8
  • MySQL version: 5.1.30
  • URL: Local Intranet

I downloaded and unarchived the Mediawiki package to a new folder (w) under htdocs. I tried running the installation and entered the required information on screen but then when I get this error and no successful installation message.

Checking environment... Please include all of the lines below when reporting installation problems.

PHP 5.2.8 installed Found database drivers for: MySQL PostgreSQL PHP server API is apache2handler; ok, using pretty URLs (index.php/Page_Title) Have XML / Latin1-UTF-8 conversion support. Session save path (D:\xampp\tmp) appears to be valid. PHP's memory_limit is 32M. Couldn't find Turck MMCache, eAccelerator, APC or XCache; cannot use these for object caching. GNU diff3 not found. Found GD graphics library built-in, image thumbnailing will be enabled if you enable uploads. Installation directory: D:\xampp\htdocs\w Script URI path: /w Installing MediaWiki with php file extensions Environment checked. You can install MediaWiki. Warning: $wgSecretKey key is insecure, generated with mt_rand(). Consider changing it manually. Generating configuration file...

Database type: MySQL Loading class: DatabaseMysql Attempting to connect to database server as root...success. Connected to mysql 5.1.30-community; enabling MySQL 4.1/5.0 charset mode Database wikidb exists There are already MediaWiki tables in this database. Checking if updates are needed... Granting user permissions... Query "GRANT DELETE,INSERT,SELECT,UPDATE,CREATE TEMPORARY TABLES ON `wikidb`.* TO 'wikiuser'@'%' IDENTIFIED BY 'admin' " failed with error code "Access denied for user 'root'@'localhost' to database 'wikidb' (localhost)".


Any help on this matter is greatly appreciated. Thank you.

Regards, Yogesh Nahar E: yogeshnahar@crouse.org

Migration stoped umlauts from working[edit | edit source]

  • MediaWiki version: 1.15.2
  • PHP version: 5.2.13-pl0-gentoo
  • MySQL version: 5.0
  • URL: ------

Hi there, i just wanne describe my problem once again and maybe today there someone with an great idea, i have an wiki running, it was migrated from another webspace _whithout_ changing the database, the webspace are the same architecture, an gentoo webserver with equal configuration, so now, it stoped showing umlauts, even in preview mode and only when the side gets edited or is new, the old sides works just fine, So if i edit the side on the old Webspace it shows umlauts very well, if i edit the same side and go to preview mode then it just changes every ä ü ö to <?>, the encoding in evry file is set tu utf-8, the database as well, and in php and mysql config also. I created an php file which writes data to an tinyblob in the same database, and umlauts work. so it should/must be something within mediawiki itsel, but i really dont know where i should take a look. Remember the side is just migrated, with an tar cpf and unpacked at the new webspace, there was no change in the sources. Hope someone has an really good idea

regards Jörg

Vector font is way too small (totally illegible)[edit | edit source]

I have just upgraded from 1.12 to 1.16, hoping to refresh our site with the really nice vector skin. I followed the handy upgrade article and all went fine! I then edited the LocalSetttings.php to:

$wgDefaultSkin = 'vector';

The pages still render but the are now completely illegible. The fonts on all articles seem to be about 4pt! I tried a variety of browsers (IE, Chrome) but no joy. If I change back to

$wgDefaultSkin = 'monobook'; all is well again. I spent the evening trawling forums, but no joy at all.

any ideas?