Pomoč:VisualEditor/Uporabniški priročnik

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 22% complete.

Other languages:
العربية • ‎asturianu • ‎azərbaycanca • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎British English • ‎Esperanto • ‎español • ‎eesti • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎Scots • ‎slovenčina • ‎slovenščina • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎中文
PD Note: When you edit this page, you agree to release your contribution under the CC0. See Public Domain Help Pages for more info.
PD
Če bi radi preiskusili VisualEditor ne da bi urejali članek, je na voljo tukaj stran kjer ga prosto lahko preiskusite. Na tej strani za uporabo VisualEditorja ne potrebujete računa.

§Odpiranje VisualEditorja[edit | edit source]

To edit a page using VisualEditor, click on the "Uredi" tab at the top of the page.

Odpiranje strani za urejanje lahko traja nekaj sekund in več, če je stran zelo obsežna.

Clicking on the "Uredi kodo" tab will open the classic wikitext source editor.

VisualEditor - Edit tab2-sl.png

You can also open VisualEditor by clicking on the "uredi" link on each section.
Section editing VE-sl.png

§Začetek: VisualEditor opravilna vrstica[edit | edit source]

Zaslonski posnetek orodne vrtstice VisualEditorja
Ko pričnete urejati z uporabo VisualEditorja, se na vrhu ekrana pojavi orodna vrstica. Vsebuje nekatere poznane ikone:

VisualEditor - Toolbar - Undo-redo.png
Razveljavi and Uveljavi the changes you have made.

VisualEditor Toolbar Headings-sl.png
Headings pull-down menu: allows you to change how the paragraph is formatted. To change the style of a paragraph, put your caret in the paragraph and select an item in this menu (you don't have to highlight any text). Section titles are formatted "Naslov", and subsections are "Naslov 2", "Naslov 3", and so on. The normal format for text is "Odstavek".

VisualEditor Toolbar Formatting-sl.png

Oblikovanje: klik na "A" odpre menu. Za kakršno koli uporabo morate najprej izbrati (označiti) nekaj besedila.

  • The "Krepko" item (B) bolds the selected text.
  • The "Ležeče" item (I) italicizes the selected text.
  • The "Nadpisano" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly higher than the surrounding text.
  • The "Podpisano" item (x2) causes the selected text to appear smaller than surrounding text and slightly lower than the surrounding text.
  • The "Prečrtano" item (S) adds a solid bar through the selected text.
  • The "Računalniška koda" item (a set of curly brackets: {}) changes the font of the selected text to a monospaced font, which sets it apart from surrounding (proportionally spaced) text.
  • The "Podčrtano" item (U) adds a solid line beneath the selected text.
  • The "Jezik" item (Aあ) allows you to label the language (for example, Japanese) and direction (for example, right-to-left) of the selected text.
  • The final item (VisualEditor MediaWiki theme clear icon bitmap.png), called "Počisti slog", removes all character formatting from the selected text, including links

VisualEditor - Toolbar - Linking.png
Orodje za povezovanje: Gumb v obliki verige je orodje za povezovanje. Če kliknete nanj (običajno po izbiri nekaj besedila), se odpre pogovorno okno za urejanje povezav.

VisualEditor - Cite Pulldown-sl.png
Navedi menu: The "Navedi" menu is used to add inline citations (also called "footnotes" or "references"). All projects have access to "Osnovno" reference formatting and the ability to "Uporabi ponovno" citations, using this menu. This menu also gives you quick access to local citation templates, if these are enabled on your wiki.

(Instructions for adding local citation templates to the Navedi menu at a specific wiki are available at VisualEditor/Citation tool.)


VisualEditor Toolbar Lists and indentation-sl.png
Lists & indentation: The first two items allow you to format text as either a "Neoštevilčen seznam" or a "Oštevilčen seznam". The last two items allow you to decrease or increase the indentation level of list items.

VisualEditor Insert Menu-sl.png
Vstavi: The "Vstavi" menu may be different on some projects. Below is a list of all options that may appear.
  • The "Predstavnost" icon (a picture of mountains) opens the media dialog.
  • The "Galerija" icon (a set of photos) allows you to insert a gallery to the page.
  • The "Predloga" icon (a puzzle piece) allows you to edit templates.
  • The "Pripomba" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode.
  • The "Formula" icon (Σ) opens the formula inserter dialog.
  • The "Seznam sklicev" icon (three books) opens a dialog in which you can specify where will references be displayed to the reader. Usually this only needs to be done once on every page.
  • The "Hieroglifi" icon (an ankh symbol - ☥) allows you to enter the hieroglyphics inserter. (See below.)
  • The "Posebni znak" icon (Ω) allows you to insert some special characters. (See immediately below.)

VisualEditor Toolbar SpecialCharacters-sl.png
Special character insertion: The "Posebni znak" icon on the "Vstavi" menu, when clicked, displays a dialog showing many special characters. By clicking on a specific character, you place it into the text. These special characters include some standard symbols, accents, and mathematical symbols. (Ta seznam se lahko lokalno prilagodi. Za navodila glej VisualEditor/Special characters.)

VisualEditor cancel save-sl.png
The Možnosti strani menu is to the left of the Shrani stran button. On this menu there are options to adjust page settings, such as whether the page is a redirect, or how it is indexed; to add, edit, or delete categories; and to see, using the "Jezik" item, the list of articles on the same subject that are in other languages. You can also switch (one-way only) from VisualEditor to the classic wikitext source editor without losing the editing work you've done.

§Shranjevanje sprememb[edit | edit source]

When you're done editing, click the green "Shrani stran" button in the toolbar. (If you have made no changes, the green button will be greyed out - not usable.) Za preklic vseh vaših sprememb, samo zaprite vaše okno za urejanje.
VisualEditor cancel save-sl.png

Pressing the green "Shrani stran" button opens a dialog. You can then enter a brief summary of your actions, mark your edit as minor, and add the page to your Spisek nadzorov. The box for the summary is the equivalent of the Povzetek urejanja: field in the wikitext editor.

You can also review your changes using the "Preglejte svoje spremembe" button to be sure they will work as intended before saving your changes. This is similar to the "Prikaži spremembe" button in the wikitext editor.

The "Razveljavi" button returns you to the page you were editing. You can save all of your changes later.

VisualEditor save dialog-sl.png

§Urejanje povezav[edit | edit source]

VisualEditor - Toolbar - Linking.png
Links can be added through the "Povezava" icon (links in a chain) in the toolbar, or by using the shortcut  Ctrl+K (or  Command+K on a Mac).

If you select (highlight) text and then press the "Povezava" button, a link will be inserted using that text. For single-word links it's enough to just do it while the caret is on that word.


VisualEditor - Link editing inline-sl.png
Pri uporabi gumba ali bližnjice se bo odprlo okno, v katero lahko vnesete povezavo. VisualEditor vam bo skušal pomagati pri notranjih povezavah (povezave na ostale strani Wikipedije) z iskanjem verjetnih zadetkov, ko začnete vnašati besedilo.

Pri tipkanju vam bo VisualEditor skušal pomagati z iskanjem notranjih povezav z iskanjem verjetnih zadetkov.


VisualEditor - Link editing inline box-sl.png
Once you have entered or selected the link, you complete the linking process by pressing  Enter, pressing the "Končano" button, or just clicking outside of the box. Your link will immediately appear on the VisualEditor page, but it will not be saved until you save the entire page.

VisualEditor - External link.png
To link to a web page on another website, the process is the similar: you enter a URL in the box, and it will be added as an "Zunanja povezava".

External links without labels look like this: [1]. You can add these by placing your cursor away from any word (e.g., after a space). Open the link tool by clicking on the button or pressing the shortcut keys. Type the URL in the box, and click the "Končano" button to insert the link.

VisualEditor - Link editing inline.png
To change or remove an existing link, click within the text for that link, then press the "Povezava" icon that appears near it. The dialog will appear, for editing. (You can also get to the dialog with the  Ctrl+K keyboard shortcut.)

In the dialog, you can then change where the link goes. You can also remove the link altogether by pressing the "Odstrani" button in the lower left corner of the dialog. You can also open the link's target in another window by clicking on the "Odpri" button. (You might want do this to check if an external link is valid.)

§Editing references[edit | edit source]

§Urejanje obstoječih sklicev[edit | edit source]


VisualEditor - Editing references 1.png
To edit an existing reference, click on it where it appears in the text (usually as a bracketed number). You will see either a "Osnovno" icon (bookmark) or an icon (and name) for the template that was used to create this reference. Clicking on this icon will open a dialog where you can edit the reference.

VisualEditor - Editing references 6.png
If what appears is the "Osnovno" icon, clicking on it opens the Reference dialog, where you can edit the reference's contents.

Many wikis use templates to format references. If a template is used in your reference, then all the text in the template will be highlighted when you click on the reference information.

If a template was used and you've clicked on information in that template, then the Predloga icon (puzzle piece) will appear. Click on that icon to edit the content of the template in the template mini-editor dialog.


VisualEditor - Editing References - Cite Web.png
If, instead of the "Osnovno" icon (bookmark), what appears when you click on a reference is an icon for a standard template for citations, clicking on that icon will take you directly to the template mini-editor dialog.

VisualEditor - Editing references 5.png
Inside the template mini-editor, you can add or remove types of information or change current content. Only fields (template parameters) that have content are supposed to be shown initially. To add fields, click on "Dodajte več informacij" at the bottom of the mini-editor.

VisualEditor - Apply changes.png
Click on "Shrani spremembe" when you're done.

§Re-using an existing reference[edit | edit source]


VisualEditor Cite menu re-use.png
Če stran že vsebuje sklice, lahko ponovno uporabite obstoječe navedbe, če se le-te nanašajo na besedilo, ki ga želite citirati.

Da bi ponovno uporabili obstoječ sklic, postavite svoj kazalec na mesto v besedilu, kjer ga želite dodati. Nato kliknite na ikono "Reference" (zaznamek) v opravilni vrstici.


VisualEditor - Editing references 18.png
In the Sklic dialog, look at the list for the reference you want to reuse, and select it. If there are many references, you can use the search box (labeled "Na kaj se želite sklicevati?") to list only those references that include certain text.

§Adding a new reference[edit | edit source]


VisualEditor references more.png
To add a citation using the "Navedi" menu, place your cursor where you want to add it in the text. Then select the appropriate citation type in the menu.

§Using the "Basic" citation[edit | edit source]


VisualEditor - Editing references 20.png
V urejevalniku sklicev lahko dodate, urejate in oblikujete vaše navedbe.

You can make the reference belong to a given group, although normally this is left blank. (This option is used to display groups of references with the "Seznam sklicev" tool.)


VisualEditor Template Insert Menu-sl.png
Če dodajate nov sklic in hočete vanj vključiti predlogo, kliknite ikono za vstavljanje (kos sestavljanke) v orodni vrstici urejevalnika sklicev.

VisualEditor - Editing references 9.png
Then, look for the template you want to use, add it and edit it as you would any other template. (See the Editing templates section, below, if you need more information about templates.)

After you're done editing your new template, click on "Shrani spremembe" to return to the Reference editor, and "Shrani spremembe" again to return to the page you're editing.


VisualEditor Reference List Insert Menu-sl.png
Če na strani še ni seznama sklicev (na primer, če dodajate prvi sklic strani), ga je potrebno dodati, da bo besedilo vašega sklica prikazano.

Place the cursor where you want to display the references list (usually at the bottom of the page), open the "Vstavi" menu and click the "Seznam sklicev" icon (three books).


VisualEditor - Editing references 11.png
If you are using several groups of references, which is relatively rare, you can specify the group in this dialog. Only the references that belong to that group will be displayed here.

The final step in the References list dialog is to click "Vstavi".

§Using standard cite templates[edit | edit source]


VisualEditor - Editing References - Cite Pulldown.png
Your local wiki may have added extra citation templates to this menu. This offers quick access to the most-used citation templates. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool.)

VisualEditor - Editing references - Cite book required fields.png
Clicking on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.

VisualEditor - Editing references - Add parameter.png
To add more parameters, scroll down in the template mini-editor and click on the "Dodajte več informacij" option.

Click on "Vstavi" when you're done.

§Editing images and other media files[edit | edit source]

§Editing images[edit | edit source]

Da bi na stran dodali novo sliko (ali drugo predstavnostno datoteko), kliknite na ikono "Media" v opravilni vrstici (ikona ima sliko gore).
VisualEditor Media Insert Menu-sl.png

Clicking the "Predstavnost" icon opens a dialog that automatically searches Wikimedia Commons and your local wiki for media files related to the title of the page you're editing.

Z spreminjanjem besedila v iskalnem polju okna lahko poiščete preostale predstavnostne datoteke.

Kliknite na sličico, da jo izberete.

This places the image onto the page you are editing.

VisualEditor - Media editing 2.png

After the image you selected is inserted into the page, another dialog will open. This dialog allows you to add and edit the caption of the image. The caption can contain formatting and links.
VisualEditor - Media editing 6.png

The media dialog also allows you to add alternative text captions, to help users who use screen readers, or who have disabled image display.
Media editing 7.png

You can also set various parameters for the image in the "Napredne nastavitve" window. These include the alignment, the type, and size of the image.
VisualEditor - Media editing 8.png

Ko končate, kliknite "Apply changes" za zaprtje okna in vrnitev na urejevalca strani.
VisualEditor - Apply changes.png

For an existing image, you can add or edit a caption or other settings by clicking on the image, then clicking on the "Predstavnost" icon that appears below the picture.

You can resize an existing image by clicking on it, then moving the resize icon (the two-headed arrow on the bottom left).

You can also drag and drop an image to a place higher or lower on the page.

VisualEditor - Media editing 3.png

§Editing media galleries[edit | edit source]


To edit an existing gallery in VisualEditor, click that gallery. Then, near the bottom of the gallery, click the gallery icon (a set of photos). This brings up the gallery editor, with the full list of images included in the gallery.
VisualEditor - Gallery2.png
The gallery editor is currently a simple box that allows you to edit existing galleries using wikitext markup. To add a new image to an existing gallery, type the file name, followed by a bar (|) and the caption for that image. You must put each image in the gallery on its own line. You can also edit this list to remove or rearrange images or to change captions.

When you click the "Končano" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not save your changes. As with other changes made using VisualEditor, you must save the entire page in order to save your work.

VisualEditor - Gallery3.png

§Editing templates[edit | edit source]

To add a new template to the page, place your cursor where you want the template to be inserted, and click on the "Predloga" icon (puzzle piece) in the "Vstavi" menu.
VisualEditor Template Insert Menu-sl.png

Type the name of the template you want to insert. When you see it on the list, click on its name. Then click "Dodaj predlogo".
VisualEditor - Template editing 4.png

You can also edit templates that are already on the page by selecting them (they turn blue), and clicking on the "Predloga" icon (puzzle piece) that appears.
VisualEditor - Template editing 1.png

Adding a new template or opening an existing one opens the "Vključitev" dialog. If the template has have been updated to contain TemplateData information, then the dialog will show a list of individual parameters; otherwise, a link to the documentation will be available in the dialog.
VisualEditor - Template editing 2.png

For an existing template, you edit the parameters already listed, and you can add additional parameters by clicking "Dodajte več informacij", at the very bottom of the dialog.
VisualEditor - Template editing 3.png

Ko predloga vdela ostale predloge, se bojo te pod-predloge pojavile kot parametri. Lahko jih uredimo ali odstranimo s klikom na njihovo ime.

Nove pod-predloge so dodane enako kot dodajanje parametra. Morda boste morali preveriti dokumentacijo predloge, da se prepričate, da je ta pod-predloga podprta.

VisualEditor - Template editing 5.png

Ko ste končali, kliknite "Apply changes", da zaprete okno in se vrnete v urejevalca strani.
VisualEditor - Apply changes.png

§Substituting templates[edit | edit source]


Če želite predlogo zamenjati, vpišite subst: (z dvopičjem) pred imenom predloge.

Samodejno dokončanje ne deluje z subst:; če potrebujete samodejno dokončanje, dodajte subst: šele potem, ko najdete predlogo, ki jo iščete.

Then, click the green "Dodaj predlogo" button.

VisualEditor - Template editing 7.png

Add any parameters as usual and "Shrani spremembe".
VisualEditor - Template editing 6.png

V začetni fazi ne boste videli razširjene predloge na strani.
VisualEditor - Template editing 8.png

§Editing tables[edit | edit source]

VisualEditor-logo.svg
You can use VisualEditor to insert and change tables. This is a new feature, and the details will be changing rapidly.

VisualEditor table editing add and remove columns.png
You can add and remove columns and rows.

VisualEditor-logo.svg
Double-click inside a cell to add or change the contents.

§Editing categories[edit | edit source]

VisualEditor Categories.png
To edit categories, on the "Možnosti strani" menu, click the "Kategorije" button.

VisualEditor - Category editing 1.png
The "Kategorije" button opens a dialog that lists existing categories and allows you to add new ones.

You have the option of setting or changing the general (default) sorting key, which used to determine where the page appears when listed with other pages in the same category.

For example, the default sorting key for the article "George Washington" is "Washington, George", and so in the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".


VisualEditor - Category editing 3.png
To add a category for a page, type the name of the category into the field "Dodaj kategorijo". As you type, VisualEditor will search for possible matching, existing categories. You can either select an existing category, or you can add a category that doesn't yet have its own category page. (Until that category page is created, your new category will show as a red link after you save all your editing changes.)

VisualEditor - Category editing 2.png
To remove an existing category, click on it and click on the "Odstrani" icon (trash can) in the dialog that opens.

Clicking on a category also allows you to specify a sorting key for that specific category. Such a sorting key overrides the default sorting key.


VisualEditor - Apply changes.png
Click "Shrani spremembe" when you're done editing categories to return to the page editor.

§Editing page settings[edit | edit source]

VisualEditor - Page Settings menu.png
To edit a page's settings, click to open the "Možnosti strani" menu, in the toolbar, and select the "Nastavitve strani" button.

VisualEditor Page Settings-sl.png
The "Nastavitve strani" button opens a dialog that shows several options.

VisualEditor Page Settings Redirects-sl.png
You can make a page a redirect to another page by checking the "Preusmeri stran na" checkbox, and then typing the name of the page to which you want to send the reader who tries to go to the page that you're editing.

At the bottom is the option to prevent page renames from updating this redirect. This is very rarely used.


VisualEditor Page Settings TOC-sl.png
You can change whether the page shows a Table of Contents by selecting one of these three buttons. The default option is "Če je potrebno", which shows a Table of Contents if there are three or more headings.

VisualEditor - Page Settings Edit Links.png
You can make a page not show edit links next to each section header by checking this checkbox.

VisualEditor Apply Changes-en.png
Click "Shrani spremembe" when you're done editing the Možnosti strani to return to the page editor.

§Editing mathematical formulae[edit | edit source]

To add a new mathematical formula to the page, place your cursor where you want it to be inserted, and click on the "Formula" icon ("Σ") in the "Vstavi" menu on the toolbar.
VisualEditor Formula Insert Menu-sl.png

A window will open in which you can type the formula, using LaTeX syntax. VisualEditor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, click the "Končano" button.
VisualEditor formula-sl.png

To edit an existing mathematical formula on the page, click on it and then click on the "Σ" icon that appears. This will open up the formula window, where you make changes.
VisualEditor - editing existing mathematical formula.png

§Editing poems and other special items[edit | edit source]

Some items, such as poems and musical scores, are not yet supported by VisualEditor. Until they are, you will need to edit the source wikitext directly if you want to add these or change these.

§Keyboard shortcuts[edit | edit source]

Many editors are used to entering wikitext directly, especially bold, italics and wikilinks. Keyboard shortcuts allow to quickly insert similar formatting without having to use toolbar items. Here are the common general shortcuts in VisualEditor:

Bližnjica Rezultat Mac bližnjica

 Ctrl+B Krepko  Cmd+B

 Ctrl+I Poševen tisk  Cmd+I

 Ctrl+K Vstavi povezavo  Cmd+K

 Ctrl+X Odreži  Cmd+X

 Ctrl+C Kopiraj  Cmd+C

 Ctrl+V Prilepi  Cmd+V

 Ctrl+Z Razveljavi  Cmd+Z